Super high ping in the last few days — Guild Wars 2 Forums
Home

Super high ping in the last few days

Hi guys, I am from Brazil. Currently running a pretty good and stable connection.
Just tested my connection on twitch streams, youtube, US sites, etc... everything running smooth and normal.
Usually I play under 160 ping, but in the last few days I am getting insane ammounts of latency, 1000+, 2000+, 4000+, DCs, etc. Only on guildwars 2, everything else is pretty normal.

Anyone experiencing the same issue?
Any tips for me to fix things out?

Thanks!

Comments

  • Shao.7236Shao.7236 Member ✭✭✭✭

    I've posted in many threads and there never was really an answer, this also seems to be on a player basis because my internet is never having any problems anytime it happens. I do keep ping spikes of 1k plus mostly in the HotM but it can also happen in conquest games too.

    Willing to help with anything Revenant related.
    twitch.tv/shaoaz

  • I've been getting random ping spikes that climb up to around 3000 and stay there for a few minutes before returning to normal. Only in the last few days. Didn't have them before.

  • Sylvia.4870Sylvia.4870 Member ✭✭

    It has been quite laggy since my return to the game 4 days ago. I have experienced the extremely high ping (between 450-4,650) all day and all night despite the fitting internet connection . I can barely move my character to do anything in PvE including WvW (with or without a zerg around). ;-;

  • Cerpin.7839Cerpin.7839 Member ✭✭

    I'm having the same issue the last few days with ping. I'm in the US and I don't ever have problems. Not sure what the deal is. Ping spiking over and over.

  • Sylvia.4870Sylvia.4870 Member ✭✭

    Today, I can't play the game any longer. I can't even move my character! Ping keeps on rising to 1.5k everytime. Worse, I get stuck in the loading screen forever!

  • Ray Koopa.2354Ray Koopa.2354 Member ✭✭✭
    edited April 15, 2020

    It just completely lagged out for me too and many other players in the SAB hub, throughout multiple restarts and logins. PMs don't go through, ping is at 3000, interactions are not happening. Fun times :P

    OH by the way. This may be another yearly reminder to finally make mushrooms and trampolines client-side so they're not behaving (completely) ridiculous at a ping of 150 or higher.

  • getting 4k ping at every meta map, this is just beyond frustrating

  • Zaxares.5419Zaxares.5419 Member ✭✭✭

    SEA (Singapore) player here. Lag has been EXTREMELY bad over the past week or so, and I'm getting similar feedback from other friends in SEA, OCX and south Asia. I strongly suspect that the problem lies with whatever login server ANet is using to service those regions because if I use a VPN to tunnel straight to the US (and therefore trick the game servers into letting me use whatever login server US players use), the lag spikes disappear. My ping doesn't improve above its normal level of ~250 of course, but the higher ping of 500-800, with the occasional spike to 1k-2k, vanish.

  • Australia. Having the same problem with lag spikes 320-5k (serious on the 5k too). The same problem is being experienced by a significant amount of people in Oz as contacted our National Broadband Network (NBN) techs. The problem allegedly is at the Amazon bottleneck (not enough capacity) and the length of time the server is taking for computations before the RTT resumes. In my case: wvw is unplayable as is pvp. Normal maps either wont load past opening screen or the laf spikes simply are never ending 350-1200+ every 10-15sec

  • @Darkbeefy.5729 said:
    The problem allegedly is at the Amazon bottleneck (not enough capacity) and the length of time the server is taking for computations before the RTT resumes.

    I'm in Good Korea. Amazon-owned hops are just one of the spots where my data drops out (It's always once it hits America mind you), but Amazon is definitely the most consistent name that comes up when I do my due diligence. Since it's been happening for a long time either Anet can't do anything about it, or don't see it as a priority due to low numbers of players playing from across the Pacific. Probably a bit of both.

    The Commander will end you.

  • I am from Singapore, the game has been totally unplayable for the past one week, keeps getting disconnected and got booted out of the game to the character selection screen, and sometimes i cant load at the loading screen it just freezed there loading for a long time.

    Its been one week and i am surprised that no action is taken by Anet to solve the problems. Wtever it is, fix the problems.

  • Bumping this thread up as getting same issue as well. From SEA - past week the pings is mostly 3~4K, it is impossible to play. Weird things like the chat would be people talking about the end of the fight/meta but the whole screen is just going through the fight. Most of the time, i will get kicked out to the login screen. And then once in awhile will get bombarded by a lot of code 42 login error message. Come on, Anet, do something.

  • @Imbris.5782 said:
    Bumping this thread up as getting same issue as well. From SEA - past week the pings is mostly 3~4K, it is impossible to play. Weird things like the chat would be people talking about the end of the fight/meta but the whole screen is just going through the fight. Most of the time, i will get kicked out to the login screen. And then once in awhile will get bombarded by a lot of code 42 login error message. Come on, Anet, do something.

    This is exactly what's happening to me. Game is unplayable atm.

  • Lexi.1398Lexi.1398 Member ✭✭✭

    I only get ping drops at late day eu (NA server, essentially, whenever all the NA players come online) and while I cannot do the content i am most dedicated to at NA prime anymore, i can play fine early in the day - likely too much load on servers in this case.

  • It's been unbearable lately, so much so that instead of just ignoring it like I usually do I went googling to find out what exactly the problem is. There is regularly a huge delay (multiple seconds) when doing pretty much anything. (Activating mount, activating skills, gathering...) I checked my ping and it was between 77-2500. Two thousand five hundred. That's ten times what the guide says will cause issues. My other games aren't doing this, so it isn't just the increased traffic due to quarantine or whatever. I also play in the morning when there aren't as many people around, and it's still doing this. I am in the EU and playing on EU servers.

  • I'm from Brazil, I have format PC, called internet support and is not my internet, not even my PC. And the anet told on ticket that my internet is having loss on game files, but why all other games run so smooth?
    The game is really unplayable last days, and this quarentine time is a time to play and relax.
    I love this game, but if this keep happening I will call for it.

  • suzako.1526suzako.1526 Member ✭✭

    Arenanet silence is deafening

  • Inculpatus cedo.9234Inculpatus cedo.9234 Member ✭✭✭✭

    @suzako.1526 said:
    Arenanet silence is deafening

    If you want a response, you can contact the Tech CS Team.
    Those in the know on tech issues rarely post on the forums.
    During this crisis, when everyone is working from home, it seems only the Moderators/Forum-focused Devs are posting, at all.

    Good luck.

  • suzako.1526suzako.1526 Member ✭✭

    @Inculpatus cedo.9234 said:

    @suzako.1526 said:
    Arenanet silence is deafening

    If you want a response, you can contact the Tech CS Team.
    Those in the know on tech issues rarely post on the forums.
    During this crisis, when everyone is working from home, it seems only the Moderators/Forum-focused Devs are posting, at all.

    Good luck.

    Oh, thanks!

  • Fueki.4753Fueki.4753 Member ✭✭✭✭
    edited April 24, 2020

    The least Arenanet should do is given an official statement to let people know they at least know of the issues.
    But Arenanet isn't even putting in the minimum effort to communicate.

  • Bumb
    Same here.
    Super highend glassfiber connection.
    more then decend gaming PC.

    Since 1 week game is unplayable for me in wvw over 9k pings

  • Same, absolutely unplayable. It's just GW2 for me and the spikes go from 100 - 4000 ping. I play mainly WvW and it seems to affect only a few players in my guild.

  • Profanity.6829Profanity.6829 Member ✭✭
    edited March 25, 2021

    Bump, same here (Netherlands). MS easily goes in between 150 to 800 in ranked games which makes competitive impossible. My MS us usually 20 ish.
    (speed tests: 205 mbps, 3 ms)

    Started since this weeks patch!

  • Erze.7253Erze.7253 Member ✭✭

    In the US of A, Seattle area. Ping 2000-3000, consistently. Hard to play like this.

  • JOHNNY.7364JOHNNY.7364 Member ✭✭

    I am also getting very high ping spikes while playing. I even posted this on my ISP’s forum and more people replied there on their forum. The weird thing is that you can’t properly do a trace because you only get time-out after like the 3th node. It’s seems like something has changed in the routing table. All I know is that between me and my isp I get 3-4 ms and that is perfect.

  • Linken.6345Linken.6345 Member ✭✭✭✭

    @Toast.4592 said:
    Same, absolutely unplayable. It's just GW2 for me and the spikes go from 100 - 4000 ping. I play mainly WvW and it seems to affect only a few players in my guild.

    A friend had trouble with high ping in my raid static.
    Not just reseting router fixed it they had to factory reset it to get back to a stable connection.
    Might be worth trying it.

  • I have also the same problems with high ping. Contacted my provider they say its the Amazon servers that are the issue. Contacted support with a ticket and they dont look at all. They only want me too check my computer and connection. Again it's not my pc or internet connection its Amazon servers that are the issue.

  • Also have the same, started since last patch. other games are fine only GW2 is having this ping issue...