Upgraded from Win7 to Win10 = lag — Guild Wars 2 Forums
Home

Upgraded from Win7 to Win10 = lag

Hello everyone,

I recently upgraded my computer from Win7 to Win10 (both 64x-versions)
On Win7 I could play the game on almost max settings with no lags. Now with Win10 I have lags every 10 seconds or so.

Specs:
iMac Intel(R) Core(TM) i5-4670 CPU @ 3.40Ghz
8 GB RAM
GeForce GTX 780M

Internet conection
ping=24ms
download=128mbps
upload=6mbps

Is it possible that I need more RAM because of WIN10?
Any other ideas?

Many thanks
Cruzy

Comments

  • Ashantara.8731Ashantara.8731 Member ✭✭✭✭

    Did you do a clean install of Windows 10, or did you just apply an upgrade?

    It's not recommended to do the latter. A clean install is always the best way to go.

  • Cruzy.3706Cruzy.3706 Member ✭✭

    I did a clean installation of Win10

  • Ashantara.8731Ashantara.8731 Member ✭✭✭✭
    edited June 2, 2020

    @Cruzy.3706 said:
    I did a clean installation of Win10

    Did you install all the drivers for your system?

    Keep in mind that there is a lot of configuration work required before you can properly use Windows 10, as it installs and activates so much kitten that no one needs and unnecessarily slows down the system (it's probably the worst Windows Microsoft has ever released). You should definitely read up on how to tweak the system to work as smoothly as possible (although a notebook is not ideal for a heavy system like Windows 10 to begin with).

    Furthermore, 8 GB of RAM isn't a lot these days... Just sayin'.

    P.S. Perhaps Windows 10 isn't fully compatible with an iMac notebook?

  • Gundahar.2765Gundahar.2765 Member ✭✭✭

    Try disabling windows 10 game mode. Make sure you have Visual C++ Redistributable Runtimes All-in-One latest version, NET framework latest version and of course latest nvidia drivers. Also remove geforce experience in case you have it installed.

  • KrHome.1920KrHome.1920 Member ✭✭✭✭
    edited June 4, 2020

    Why is everyone giving advices before actually knowing where the problem is located?

    Before changing anything on your PC and waste a lot of time, you could be smart and start with checking how much RAM is utilized when you play GW2 via the Windows Task Manager. If the Ram is fully utilizerd then Windows starts moving Ram data to the virtual memory and this would indeed cause heavy stutters.

    In general the game should run fine with 8GiB Ram in Windows 10, if you are not running a ton of background tasks. What's running in the background and how much Ram it consumes, is also something you can check in the Task Manager.

  • Cruzy.3706Cruzy.3706 Member ✭✭

    @KrHome.1920 said:
    Why is everyone giving advices before actually knowing where the problem is located?

    Before changing anything on your PC and waste a lot of time, you could be smart and start with checking how much RAM is utilized when you play GW2 via the Windows Task Manager. If the Ram is fully utilizerd then Windows starts moving Ram data to the virtual memory and this would indeed cause heavy stutters.

    In general the game should run fine with 8GiB Ram in Windows 10, if you are not running a ton of background tasks. What's running in the background and how much Ram it consumes, is also something you can check in the Task Manager.

    I checked the Task Manager while my charackter stands in the new map (drizzelwood)
    This is the result:
    GW2 = CPU 40-50%; RAM 2GB
    Overall = CPU 40-50%; RAM 61%

    I am not quite sure if its normal or not =)

  • It sound like a driver issue like what has been posted, did you install all the latest drivers for your system including the commonly over looked chipset drivers!