[6.9.2020] Autotarget Not Autotargeting — Guild Wars 2 Forums
Home Bugs: Game, Forum, Website

[6.9.2020] Autotarget Not Autotargeting

Memoranda.9386Memoranda.9386 Member ✭✭✭
edited July 1, 2020 in Bugs: Game, Forum, Website

After the 6.9.20 patch, I noticed that my skills were not targeting correctly. Autotarget and Promote Skill Target are both enabled. No settings have been changed.

Symptoms:

1.) Using auto attack will not select a target, even if standing directly in front of any enemy.

2.) Skills 2 - 5 also do not select a valid target if applicable. (Eg., Ranger LB 2 will shoot where you are facing instead of selecting a target. This was most noticable in WvW.)

3.) Can't re-target by using skill 1 (like the baddie I am).

4.) Ground target skills will usually select an ally if present, and deselect the current target.

Update 6.15.20:

5.) "Snap Ground-cast to Target Location" becomes broken during combat and will only cast at self-location.

Anecdotally, one of my CM group also noticed some sort of discrepancy, as have a few players in map chat when asking if anyone noticed a change or new issues.

Anyone here noticed something amiss with autotarget behaving strangely?

==========

Update [7.1.2020]:

The patch released on 6.24.20 appears to have resolved the majority of players concerns regarding autotarget.

If you feel that autotarget is still not working correctly please state why you believe that to be the case, and provide examples of skills/autotarget malfunctioning.

Also, if appropriate submit an in-game bug report under the support option in Settings (accessed by hitting the "Escape" key in-game), with as much detail as you can provide.

<1

Comments

  • Khisanth.2948Khisanth.2948 Member ✭✭✭✭

    Works for melee skills with a range limit of around 900 units

    Doesn't work on ranged? Only tested on renegade shortbow.

  • Lamont.5973Lamont.5973 Member ✭✭✭
    edited June 11, 2020

    I and my guild noticed this too. It was bad enough when auto targeting chose something half way across the map but now it doesn't seem to target at all or targets a friendly instead of an enemy half the time.

  • i noticed this too. As a dragonhunter, the class is practically unplayable. During raids i kept leaping off platforms, and i thought perhaps i was just playing badly. but today i dug a little deeper and found other people were having this problem too. It feels pretty dang awful, i hope they fix it soon..

  • TallBarr.2184TallBarr.2184 Member ✭✭✭

    Noticed this too. Thought i was going insane

  • It's been a pain last couple of days. DHs using greatsword leap to another random place, chrono sword 3 leap doensnt work and struggle getting clones up. many raids/strikes have become unplayable for certain classes for people who are used to autotargeting.

  • Opopanax.1803Opopanax.1803 Member ✭✭✭✭

    Help on this! It is a problem!

  • Same problem here since 09/06 patch

  • Memoranda.9386Memoranda.9386 Member ✭✭✭

    If you disable to the setting "Right-click to attack/interact" that seems to help with accidentally selecting allies. Other issues still seem unresolved.

  • Lamont.5973Lamont.5973 Member ✭✭✭

    @Memoranda.9386 said:
    If you disable to the setting "Right-click to attack/interact" that seems to help with accidentally selecting allies. Other issues still seem unresolved.

    Thanks, that helped a great deal

  • YtseJam.9784YtseJam.9784 Member ✭✭✭

    hmm i kinda noticed something weird last night but i thought it was the toggle, cause it always does what it wants and disables it. so I had to enable a key to toggle the autotarget lock on/off to fix it, but this is something that has been going on for years. and speaking of that, i was thinking that we should have some UI indicator that the autotarget is on or off, since using your toggle key doesnt show you if it's on or off, i have to target someone, hold down on one of my skills that locks to target and see if it's on or off, and then toggle if i need.

  • Obfuscate.6430Obfuscate.6430 Member ✭✭✭

    God, this has been an issue for me as well. It chooses targets nowhere near me, and if I use a leap skill it sends me flying in some random direction even if I have an enemy highlighted. It's been so frustrating blowing my long cool down skills on nothing,

  • Hesione.9412Hesione.9412 Member ✭✭✭

    And to add: I will get neutral NPCs, e.g. deer in Drizzlewood, selected over enemy NPCs.

  • Sleepwalker.1398Sleepwalker.1398 Member ✭✭✭✭
    edited June 12, 2020

    I'm seeing something weird too.
    Just wondering if this is the same thing.
    When i am fighting someone, it seems as i targeted someone else mid fight like i lose target on boss/enemy players and it would target my clone or something.
    I thought it was me mistakenly click "Tab" key but now i'm not too sure after seeing this thread.

  • Khisanth.2948Khisanth.2948 Member ✭✭✭✭

    @Sleepwalker.1398 said:
    I'm seeing something weird too.
    Just wondering if this is the same thing.
    When i am fighting someone, it seems as i targeted someone else mid fight like i lose target on boss/enemy players and it would target my clone or something.
    I thought it was me mistakenly click "Tab" key but now i'm not too sure after seeing this thread.

    that sounds like the typical case of leaving "Right click to interact" enabled. it is very easy to end up switch target when trying to move your camera if you leave it on

  • Memoranda.9386Memoranda.9386 Member ✭✭✭

    @Khisanth.2948 said:

    @Sleepwalker.1398 said:
    I'm seeing something weird too.
    Just wondering if this is the same thing.
    When i am fighting someone, it seems as i targeted someone else mid fight like i lose target on boss/enemy players and it would target my clone or something.
    I thought it was me mistakenly click "Tab" key but now i'm not too sure after seeing this thread.

    that sounds like the typical case of leaving "Right click to interact" enabled. it is very easy to end up switch target when trying to move your camera if you leave it on

    That did improve the situation, however, for me that has always been enabled by default. It was never a problem before the 6.9.20 patch.

  • I fear "this skill requires a target" will be burned into my screen soon. I had to switch to a melee weapon because of it.

  • Cristalyan.5728Cristalyan.5728 Member ✭✭✭

    I want to add that the special mastery skill related with essences - in Drizzlewood - works strange. It pop-ups in the fight. And when you activate it you receive the message: "invalid target, please use it on an enemy imbued with .... " What? How is this "invalid target"? The special skill is not activated by me - to make a mistake. It appears whn you select an enemy who can be damaged by such a skill. And why after it appears the target is invalid?

  • Tukaram.8256Tukaram.8256 Member ✭✭✭

    I noticed it too. I generally just click the "1" and I, and my critters, attack. Auto target is not working at all. I thought either my keyboard quit working... or my rum & coke was too strong ha ha.

    Seriously though, this needs to be fixed ASAP.

  • gilles.1642gilles.1642 Member ✭✭

    Same issue here, please fix it asap. Thanks

  • same problem here...

  • Khisanth.2948Khisanth.2948 Member ✭✭✭✭

    @Cristalyan.5728 said:
    I want to add that the special mastery skill related with essences - in Drizzlewood - works strange. It pop-ups in the fight. And when you activate it you receive the message: "invalid target, please use it on an enemy imbued with .... " What? How is this "invalid target"? The special skill is not activated by me - to make a mistake. It appears whn you select an enemy who can be damaged by such a skill. And why after it appears the target is invalid?

    That is a completely different problem resulting from a different bad design decision. The special action skill from essesnces only works on targets with one of the essence buffs(vigiliance, resilience, valor), with t3 you need to care about matching skill with colors and with t4 you don't but guess what?! Mixed in with all the different enemies that have the buff are enemies without it. Notably the members of the steel warband do not have the buff so if you are doing the final fight or trying cap village/lighthouse and you are trying to fight Ranoah or Vishen you will be getting that message a lot. Also makes the skills mostly useless at a time when they should be the most useful.

  • Requiem.9648Requiem.9648 Member ✭✭
    edited June 13, 2020

    I have same problem an that very annoying. Mirage and chrono had hard time cause they keep losing targeting so they can't create properly clones/fantasm. Doing pistol 4 and torch 5 can be very hard. I mean can be very hard for player now for a very moving taget like Largos twins.

  • mordefelix.5826mordefelix.5826 Member ✭✭
    edited June 14, 2020

    Anet. Please. Help us all. Auto targeting is an essential function in this game. T .T

  • I wish an ANET support would at least acknowledge the problem. This seriously impacts gameplay for everyone.

  • Agreed......

  • Bump - . -

  • Memoranda.9386Memoranda.9386 Member ✭✭✭

    Also note: when using "Snap Ground-cast to target location" last night, about half way through MAMA it would no longer target the selected enemy, and only would target at self location.

  • Armen.1483Armen.1483 Member ✭✭✭

    Can confirm and add to the "2.)" the skills 6-9 aka the utility skills are bugged the same way.

  • I also have this problem on all characters, it's especially annoying on DD staff 2 and mesmer though.

  • Hesione.9412Hesione.9412 Member ✭✭✭

    With a bit of testing today, and no overlay, the problem occurs when the mob is removed from my view on the screen. So when maneuvering around a champion to move away from AoEs, etc, I lose autotarget. I don't strafe as I find that movement difficult to do.

    Is this the cause of the problem for others?

  • Memoranda.9386Memoranda.9386 Member ✭✭✭
    edited June 16, 2020

    @Hesione.9412 said:
    With a bit of testing today, and no overlay, the problem occurs when the mob is removed from my view on the screen. So when maneuvering around a champion to move away from AoEs, etc, I lose autotarget. I don't strafe as I find that movement difficult to do.

    Is this the cause of the problem for others?

    For me, I will lose autotarget in the middle of a fight, or during split phases it won't recommit to the primary creature, such as in split phases for CMs.

    More broadly, in overworld PvE, I can't count on a skill behaving as it has using the same game settings for the past entire duration of my playtime. Now sometimes I can't select the target I want as easily or even at all in crowded situations, and certainly can't count on a leap skill actually leaping towards my target if I deselect it for some reason. The game won't re-aquire that target for me, and it seems, many others.

  • Hesione.9412Hesione.9412 Member ✭✭✭

    @Memoranda.9386 said:

    More broadly, in overworld PvE, I can't count on a skill behaving as it has using the same game settings for the past entire duration of my playtime. Now sometimes I can't select the target I want as easily or even at all in crowded situations, and certainly can't count on a leap skill actually leaping towards my target if I deselect it for some reason. The game won't re-aquire that target for me, and it seems, many others.

    I experienced that same problem today in PvE, at a time when the target wasn't off screen :( It went from targetting the enemy NPC to targeting a player.

    I've tried unticking boxes, ticking boxes, and nothing seems to improve it. I wish this would get resolved.

  • Galmac.4680Galmac.4680 Member ✭✭✭

    +1

    Noticed this in WvW. Was standing in front of a guard (npc), not focused yet, and was willing to attack him. Pressed my buttons 1 to 5 (necro keyboard roll :) ), got some cooldowns active, but no damage to him. After focussing it worked then. My staff aoes deselected sometimes this target (changed to a friendly player). Please look into this!

    Praise Joko!

  • HotDelirium.7984HotDelirium.7984 Member ✭✭✭
    edited June 16, 2020

    @Memoranda.9386 said:
    After the 6.9.20 patch, I noticed that my skills were not targeting correctly. Autotarget and Promote Skill Target are both enabled. No settings have been changed.

    Symptoms:

    1.) Using auto attack will not select a target, even if standing directly in front of any enemy.

    2.) Skills 2 - 5 also do not select a valid target if applicable. (Eg., Ranger LB 2 will shoot where you are facing instead of selecting a target. This was most noticable in WvW.)

    3.) Can't re-target by using skill 1 (like the baddie I am).

    4.) Ground target skills will usually select an ally if present, and deselect the current target.

    Update 6.15.20:

    5.) "Snap Ground-cast to Target Location" becomes broken during combat and will only cast at self-location.

    Anecdotally, one of my CM group also noticed some sort of discrepancy, as have a few players in map chat when asking if anyone noticed a change or new issues.

    Anyone here noticed something amiss with autotarget behaving strangely?

    OMG I thought I suddenly became like a terrible player because my targeting is all over the friggin place now and not promote targeting almost ever and yeah i keep targeting non-enemies and since skill don't work like that you'll either fly towards an ally or not do anything. Make sure you put in a ticket because I will too.

  • YtseJam.9784YtseJam.9784 Member ✭✭✭

    yeah targetting and autotargetting has been terrible since forever, like sometimes it targets stuff that is behind you or very far away, or even ambient creatures, but now it seems not to be working at all. . a good example is the 4 mobs in Uncategorized fractal, right at the beginning. Tab NEVER targets the Veteran, only cycles through the Champs. I remember a really really long time ago they did some "priority targetting" but it seems certain mobs never get targetted at all. A lot of the times there's something standing in front of you, attacking you and it decides to target something far away, sometimes even a non-aggressive creature and now you brought it into the fight cause the autotarget decided to pick the wrong thing... just to mention a few issues. Think targetting system is due a rework

  • keenedge.9675keenedge.9675 Member ✭✭✭

    @Reckoner.1786 said:
    Autotargeting is completely broken. On my mesmer I'll try cast clones and it goes nowhere. I'm using leap skills into my death. Sometimes it's even selecting targets all the way in Narnia instead of what's in front of me. This is degrading gameplay massively for me in fractals and raids and I don't even want to play the game in this state.

    lol @ Narnia - BUT TRUE

    It's been bad, now WORSE. In the past years, it would happily target something downstairs or behind a wall rather than the mob next to me who's attacking.

    Moral Statute Machine: John Spartan, you are fined five credits for repeated violations of the verbal morality statute.

  • Leamas.5803Leamas.5803 Member ✭✭✭
    edited June 16, 2020

    Doesn't work with necro staff skill #1 either, 1200 range. I can go close enough that a mob will agro on me, but skill #1 will not target them. I have to physically select a target by clicking on them before my skill will hit them.

  • Leamas.5803Leamas.5803 Member ✭✭✭
    edited June 16, 2020

    After reading the thread more closely, I can clear up the confusion about "Right-click to attack/interact". Whether this is enabled or not is not the issue. I've been AFK farming CS for months with my minions (Some of you have probably seen me idling at Ewan). While there, I will occasionally reach over to press skill #1 to tag mobs not close enough to aggro on me or my minions. This is all I've ever needed to do. Since the recent update, now I have to physically click a mob before my attack will tag them and send my minions in to action.

  • Hesione.9412Hesione.9412 Member ✭✭✭

    Yeah, try clicking on the leyline anomaly at reset event. :( Tab targeting tends to cycle me through the orbs instead. I can see how this is a problem in zerg versus zerg in wvw. And surely the expectation cannot be that you should tab through everyone. :(

  • Anet.... are you going to acknowledge this post whatsoever?

  • Memoranda.9386Memoranda.9386 Member ✭✭✭

    I would encourage anyone who has not done so to file an in game bug report as that would bring more attention than my forum post.

  • RDEF.8513RDEF.8513 Member ✭✭
    edited June 19, 2020

    It is a major problem, raids aren't even fun anymore since we fail mechanics because of this bug, please fix this anet.

  • YtseJam.9784YtseJam.9784 Member ✭✭✭

    yeah definitely this is something that needs to be addressed soon, after 7 years playing with autotarget, now it doesnt work and half of my skills end up getting wasted. has ANET even acknowledge the issue?

  • Vash.2386Vash.2386 Member ✭✭✭

    I thought it was just me.... for the past couple of weeks I have been faffing about with the autotarget settings as I assumed I turned something on/off. I had asked in guild chat but no one had noticed any problem.

    Anet please release a fix, it makes it very hard to deal damage when your suddenly no longer attacking a target but instead spamming your skills towards a friendly.

  • bobsort.4097bobsort.4097 Member ✭✭✭
    edited June 21, 2020

    I have the same issue, note that I did not change my settings and previously I could easily turn toward my target and hit 1 and it would target and start hitting it.

    This is not only for my ranged toons, it happens on my melee toons too. Skills that need a enemy target become totally useless, I have to hit select next target (tab) to get a target which most of the times are behind me or too far out of range and then keep pressing select next target hopelessly to target the enemy that is attacking me and then give up, grab the mouse and click the target then back to keyboard. For ranged attacks that has CD of 6 to 12 seconds (stun for example), trying to hit the enemy target suddenly realizing that last evade targeted your team member instead and wasted your cool down and attack all together

  • YtseJam.9784YtseJam.9784 Member ✭✭✭

    yeah there's nothing in the settings that fixes it, i toggled every single one and still not working. but i have to say that it's not broken 100% of the time, but like 90%