one node from Skyscale Rider: Ruins of Orr is bugged — Guild Wars 2 Forums
Home Bugs: Game, Forum, Website

one node from Skyscale Rider: Ruins of Orr is bugged

According to map in Wiki, following node is the only one that I'm missing.

Cursed Shore 3 [11436, 26861]

it is south east of Altar of the Withered Heart ([&BBYDAAA=])

A month ago I tried doing this and even though it drops the [Mistborn Mote], it does not credit for achievement.
That day I tried it a few times after waiting few minutes (as suggested in wiki) and still didn't get credit

I tried it again today and it still drops the mote and still no credit. Appreciate if it get fixed.

Comments

  • slayerking.3581slayerking.3581 Member ✭✭✭

    Are you doing it fast enough? The ones for skyscale need to be done within a time limit if I remember right and even if you don't you still get the mistborn mote.

  • I've had the same thing happen to me today, so it;s not a time limit thing. I received the mote and collapsed the end point.

  • Sorry to bump such an old post, but figured it'd be better to continue this one.
    Anyway, same thing happened to me today and yesterday. Completed the course (its not hard, just a straight line), and no achievement update. Only the mote.

  • Same here, tried it on two different characters yesterday, and the day before, and it's not complete.

  • Ruins of Orr is where I'm stuck. i just completed all 7 and only get credit for 6.