Disconnection every ~30sec — Guild Wars 2 Forums
Home

Disconnection every ~30sec

Disconnection every ~30sec , sometimes i can log and choose character , sometimes not . After cutting data file from folder , similar disconnection while downloading files , 30-60 sec download then stop for moment and resuming downloading again.

Comments

  • Astyrah.4015Astyrah.4015 Member ✭✭✭
    edited July 23, 2020

    @bozywor.3962 said:
    Disconnection every ~30sec , sometimes i can log and choose character , sometimes not . After cutting data file from folder , similar disconnection while downloading files , 30-60 sec download then stop for moment and resuming downloading again.

    if you're on wifi, i would try a LAN connection (cabled ethernet). does it happen on other games? i would also check if downloading or watching/streaming (try some netflix/youtube/spotify) anything on another device like your phone or tablet or another computer/laptop would cause your connection to cut/disconnect or buffer for a long time...

    this is to find out if it's your local network(wifi/ethernet), if it's your internet provider(isp) or if it's your own computer that's the source of the issues. really hard to know what's wrong on your end unless you can test or give out more details.

  • bozywor.3962bozywor.3962 Member ✭✭

    Only happens in GW2 , rest games or apps work fine

  • Astyrah.4015Astyrah.4015 Member ✭✭✭

    @bozywor.3962 said:
    Only happens in GW2 , rest games or apps work fine

    i see

    are you using a third party anti virus (anything that isnt windows defender) that has network security? you can try disabling that if ever, or whitelist GW2.

    you can also try and see if running the game through a vpn (like exitlag/mudfish/etc.) might give you a more stable connection to the servers.

    if all else fails you can try to contact support or your internet provider with your issue they may be able to help.

  • Cynder.2509Cynder.2509 Member ✭✭✭

    I don't know if that's related but I do get a disconnect error message quite often too for several months now but the strange part is that I'm still in the game playing and not in the character select screen like it should be the case.
    The popup tends to happen more often whenever I open the trading post which usually is very slow sometimes but it can happen randomly without using the tp.
    It's just a strange thing I've heard other people experienced as well. Might be because of the EU servers maybe.
    Sometimes the error pop up every 2 to five minutes and sometimes every 30 minutes.
    What I noticed too is that whenever the game patches the download speed is slow in the middle and then after a time it speeds up again.
    Another thing that others mentioned as well.
    I also tend to get the strange disconnect popup whenever I'm unblocking people which I have to do quite often as my blocklist limit is always exceeded (I wish the limit would be increased). The friend/blocklist panel then resets and shows only a small portion of people. It's fixed by reactivating the panel again however.
    That's so far my experience with weird disconnection issues and maybe it has the same cause like your problem because random disconnects seem to have been increasing as of now.

    I'm Hunter, he/him
    Character infos: https://is-it-because-im-charr.tumblr.com/charactersgw2

  • Zeesh.7286Zeesh.7286 Member ✭✭

    Same I'm also getting an error. Unable to log in to anything. I can't get past the map loading screen after character selection

  • Astyrah.4015Astyrah.4015 Member ✭✭✭

    @Cynder.2509 said:
    I don't know if that's related but I do get a disconnect error message quite often too for several months now but the strange part is that I'm still in the game playing and not in the character select screen like it should be the case.
    -snip-

    @Zeesh.7286 said:
    Same I'm also getting an error. Unable to log in to anything. I can't get past the map loading screen after character selection

    i play on the NA servers and i see more people now in /map (and /say during metas) mention that they're lagging, i mean like more often than the last few months

    and i've experienced some lag spikes too (particularly on Icebrood Saga Maps, much less evident on other maps) but no disconnects on my end.

    it does seem the servers have been janky recently. and given the existence of this thread: https://en-forum.guildwars2.com/discussion/110054/eu-servers-a-catastrophe , i'd say it's something that's happening in all servers not just an EU thing.

  • Cynder.2509Cynder.2509 Member ✭✭✭

    I forgot to mention that I had a huge skill lag a few days ago in Desolation and Desert Highlands during bounties. For a moment everything looked like I was about to disconnect but then it came back. It was strange and somehow made me feel bad since I couldn't perform like snowcrows as everyone expects.

    I'm Hunter, he/him
    Character infos: https://is-it-because-im-charr.tumblr.com/charactersgw2