FPS locked to 60 all of a sudden — Guild Wars 2 Forums
Home

FPS locked to 60 all of a sudden

Yes yes, I know you'll now suggest me to do this and that but I already tried everything of that.
I had an issue where my PC slowed down today all of a sudden overall. A Windows update fixed that and the only oddity now is that GW2 is locked to 60fps despite no vsync turned on and fps set to unlimited in both game settings and the Nvidia control panel. I also repaired the client and tried installing again.
Nothing helped there.
I usually get above 100 to 120 to 160 and even 200 depending on the area, amount of people, etc on highest settings.
So what is this and how can I fix it because it's literally unplayable this way.
Every other game works fine.
Rolling back to the previous windows version would only cause the slowing down issue to happen again, I fear.
And yes, every driver is updated.

I'm Hunter, he/him
Character infos: https://is-it-because-im-charr.tumblr.com/charactersgw2

Comments

  • Ayrilana.1396Ayrilana.1396 Member ✭✭✭✭
    edited July 23, 2020

    Unless your monitor is rated above 60hz, any FPS above 60 won’t really matter.

    Being stuck at 60 FPS is hardly “literally unplayable” especially since the majority of players appear to struggle to even reach half that and yet are still able to play the game.

  • Cynder.2509Cynder.2509 Member ✭✭✭

    As I mentioned before, I usually have above that and it's just unusual for me and I want to fix that since it's an oddity only occuring with this game.

    I'm Hunter, he/him
    Character infos: https://is-it-because-im-charr.tumblr.com/charactersgw2

  • Ayrilana.1396Ayrilana.1396 Member ✭✭✭✭
    edited July 23, 2020

    Are you running in full screen or windowed mode? FPS can be affected by this.

    Just because the game shows you have a certain FPS, that doesn’t mean that’s what you’re actually getting. GW2 can show you running at 100+ FPS but you won’t actually be getting that if your monitor doesn’t support it.

    For the NVIDIA control panel, you may also have to force specific settings to the app itself rather than rely on the global settings.

  • Cynder.2509Cynder.2509 Member ✭✭✭

    I'm running the game always in fullscreen unless I'd need to use TaCo, then it's in windowed.

    Anyways I seem to have fixed it by starting the game up through the install directory instead of my desktop shortcut.
    Really don't know what was causing that and how it was connected to the shortcut.

    I'm Hunter, he/him
    Character infos: https://is-it-because-im-charr.tumblr.com/charactersgw2

  • Ayrilana.1396Ayrilana.1396 Member ✭✭✭✭
    edited July 23, 2020

    @Cynder.2509 said:
    I'm running the game always in fullscreen unless I'd need to use TaCo, then it's in windowed.

    Anyways I seem to have fixed it by starting the game up through the install directory instead of my desktop shortcut.
    Really don't know what was causing that and how it was connected to the shortcut.

    For the shortcut that was giving you issues, right click it and go to properties. Go go the compatibility tab and check to disable full screen optimization. It’s been known to cause FPS capping.

  • Cynder.2509Cynder.2509 Member ✭✭✭

    Okay, thanks.
    I was just confused because it never happened to me on numerous machines.

    I'm Hunter, he/him
    Character infos: https://is-it-because-im-charr.tumblr.com/charactersgw2

  • Ashantara.8731Ashantara.8731 Member ✭✭✭✭
    edited July 23, 2020