Massive fps drops — Guild Wars 2 Forums
Home

Massive fps drops

Hey guys,
It's like 4 - 5 days when I start to get massive lag spikes. Every 2-3 seconds my fps drop to 1 and after couple of seconds go back to 50. At this state it's unplayable for me. It doesnt matter if there 100 or 0 players around me or if I have maxed details or low.
I tried dx1w, repair and reinstall game. Doesn't help a bit.
Does anyone have any solution or a tip?
Last thing I can do is reinstall pc.

Thanks

Comments

  • Mack.3045Mack.3045 Member ✭✭✭

    @Blodgarn.5204 said:
    Hey guys,
    It's like 4 - 5 days when I start to get massive lag spikes. Every 2-3 seconds my fps drop to 1 and after couple of seconds go back to 50. At this state it's unplayable for me. It doesnt matter if there 100 or 0 players around me or if I have maxed details or low.
    I tried dx1w, repair and reinstall game. Doesn't help a bit.
    Does anyone have any solution or a tip?
    Last thing I can do is reinstall pc.

    Thanks

    Hi, can you check your CPU & GPU temps under load and report back

  • Ashantara.8731Ashantara.8731 Member ✭✭✭✭
    edited September 16, 2020

    @Blodgarn.5204 said:
    I tried dx1w, repair and reinstall game. Doesn't help a bit.
    Does anyone have any solution or a tip?

    It must be a system issue. But since you did not post your specs, it is hard to make an educated guess (remote diagnostics are difficult in general).

    • Could it be an overheating issue? (Have you checked your hardware's temps?)
    • Are you overclocking?
    • Did you run a RAM check (memory test)? A disk check (chkdsk)? A System File Check (sfc /scannow)?