I tried almost everything but I still get around 25 FPS — Guild Wars 2 Forums
Home

I tried almost everything but I still get around 25 FPS

Tayga.3192Tayga.3192 Member ✭✭✭✭
edited September 27, 2020 in Account & Technical Support

First things first, my system:
Laptop with relatively good cooling (Cleaned recently)
OS: Windows 10 version 1909 (up to date according to windows update, newest version is not supported yet)
CPU: Intel i7-7700HQ 2.80ghz
GPU: Nvidia Geforce 1050
Ram: 16 GB

My observations/additional info:

  • Game is not on an SSD.
  • I have dx12 thing (game is unplayable without it) and arcdps.
  • My power settings are configured properly, same goes for my nvidia settings (99% of them are default).
  • My drivers are up to date but with the driver my laptop manufacturer released recently.
  • My settings are everything on lowest setting possible, player model quality is on medium and player model count(?) is on low. Only animations are high and rendering thing on native.
  • I use highest FoV.
  • I get VERY low average fps in fractals especially (it's becomes like a powerpoint slide when it's crowded)
  • I actually have stable ~25-30 fps in WvW maps even when it's 10vs10. I don't know about the desert map since I don't play in that one.
  • I get low average fps in Heart of the Mists (around 10 fps) but for some reason I can get up to 60-80 fps in older PvP maps though.
  • I get pretty bad stutters. I guess it's because of background stuff but I don't even have that many things open, mostly only discord (with hardware acceleration).

Anything more I can do?

Comments

  • Hannelore.8153Hannelore.8153 Member ✭✭✭✭
    edited September 27, 2020

    With all that configuration you should be getting always 40-60 FPS on that system even with GW2's outdated engine. Just using dx12pxy or DXVK combined with turning Character Model Limit to Lowest should keep the game always very playable.

    Does the game run especially bad on Nightmare Fractal?

    It sounds like you're encountering a bad shader, or some other bugged object that only appears in certain areas. The first thing to do is to check the disk for errors with a full surface scan, since you said its not on an SSD. Then, fully defragment it (make sure 30%+ free space is available first) and run a repair on the game data. Finally, examine the game logs for anything suspicious.

    This is standard routine to fix any possible bad data, and keep loading as fast as possible.

    Using lower settings can make things worse. Modern video cards are not optimised for 2010 tech. Instead you need to set everything to highest and turn things down one at a time in a secluded area to find out what actually affects FPS on your setup.

    Try using DXVK instead of dx12pxy. Vulkan is a different hardware API and may not exhibit the same problem.

    Last ditch effort is to move the Gw2.dat file somewhere else and let it re-download the entire 40GB again, which will result in a completely clean file. Patching for years on end makes the entire datafile heavily fragmented, since it works similarly to a disk.

    Try the game on another computer and see if you have the same problem.

    Try another OS (such as Linux, with Lutris). Installing it isn't needed, since that's what makes most people shakey. There's some versions designed to boot into a full desktop with graphics acceleration from a CD, DVD or USB.

    Hannah | Daisuki[SUKI] Founder, Ehmry Bay, NA | 22 charas, 16k hours, 27k AP | ♀♥♀
    Mains Mariyuuna/Tempest & Alisha Kei/Druid(PvE), Terakura/Spellbreaker & Kitty Koume/Reaper(WvW)
    No need to be best, only good and kind.

  • Try turning hardware acceleration off for discord. It is a hog, but a bit less of a hog without hw accel.
    max fov? I would start there.
    1050 is a very anaemic card.
    also what do you consider 'configured properly'?

  • Blocki.4931Blocki.4931 Member ✭✭✭✭

    When did this start? Has it always been like this? It shouldn't be THAT bad. Have you done the annoying stuff like disabling Windows Game Mode and garbage like that? That used to completely destroy many frames.

    Clear your GW2 cache, under C:\Users\Name\Appdata\Local\Temp, the ones with "gw2cache" are fine to delete. Over time this adds up and can actually become a source of lag and long loading times.

    I rather choose death.

  • Tayga.3192Tayga.3192 Member ✭✭✭✭
    edited September 27, 2020

    @Blocki.4931 said:
    When did this start? Has it always been like this?

    I think it was better before but I'm not sure.

    It shouldn't be THAT bad. Have you done the annoying stuff like disabling Windows Game Mode and garbage like that? That used to completely destroy many frames.

    Yes I disabled it.

    Clear your GW2 cache, under C:\Users\Name\Appdata\Local\Temp, the ones with "gw2cache" are fine to delete. Over time this adds up and can actually become a source of lag and long loading times.

    I'll try this, thanks.


    @VAHNeunzehnsechundsiebzig.3618 said:
    Try turning hardware acceleration off for discord. It is a hog, but a bit less of a hog without hw accel.

    Okay I'll try this as well.

    max fov? I would start there.

    I am a PvP/WvW main so I can't change my camera settings sadly.

    1050 is a very anaemic card.

    No can do about my laptop for now.

    also what do you consider 'configured properly'?

    High Performance mode on windows, and I open gw2 with my gpu instead of that intel graphics thing.

  • Tayga.3192Tayga.3192 Member ✭✭✭✭
    edited September 27, 2020

    @Hannelore.8153 said:
    With all that configuration you should be getting always 40-60 FPS on that system even with GW2's outdated engine. Just using dx12pxy or DXVK combined with turning Character Model Limit to Lowest should keep the game always very playable.

    I'll try DXVK.

    Does the game run especially bad on Nightmare Fractal?

    Yes it's unplayable-level bad on nightmare and mai trin.

    It sounds like you're encountering a bad shader, or some other bugged object that only appears in certain areas. The first thing to do is to check the disk for errors with a full surface scan, since you said its not on an SSD. Then, fully defragment it (make sure 30%+ free space is available first) and run a repair on the game data. Finally, examine the game logs for anything suspicious.

    This is standard routine to fix any possible bad data, and keep loading as fast as possible.

    I'll try these, thanks.

    Using lower settings can make things worse. Modern video cards are not optimised for 2010 tech. Instead you need to set everything to highest and turn things down one at a time in a secluded area to find out what actually affects FPS on your setup.

    Yes I actually noticed it but I thought I was just biased, lol.

    Try using DXVK instead of dx12pxy. Vulkan is a different hardware API and may not exhibit the same problem.

    Yeah I'll try DXVK thing out.

    Last ditch effort is to move the Gw2.dat file somewhere else and let it re-download the entire 40GB again, which will result in a completely clean file. Patching for years on end makes the entire datafile heavily fragmented, since it works similarly to a disk.

    I guess yeah I can do a clean install, but my laptop is relatively new and I downloaded the game around last few LW4 episodes I think.

    Try the game on another computer and see if you have the same problem.

    I can't do that sadly :/

    Try another OS (such as Linux, with Lutris). Installing it isn't needed, since that's what makes most people shakey. There's some versions designed to boot into a full desktop with graphics acceleration from a CD, DVD or USB.

    I was thinking of dual boot stuff, I might test it if I have time.

  • maddoctor.2738maddoctor.2738 Member ✭✭✭✭

    Press CTRL+ALT+DEL, select task manager, go to performance tab, click on open resource monitor, go to CPU tab and check your core usage.
    On the performance tab you can also check GPU usage, make sure the correct GPU is working on Guild Wars 2, by checking the 1050 usage while running the game.

  • Greetings Tayga.3192
    It could be not your computer it could be where you are. There is a lot of internet problems today for some reason. Check this website and click on where you are. For instance Turkey currently has 223 website down.

    https://livemap.pingdom.com/

  • Tayga.3192Tayga.3192 Member ✭✭✭✭
    edited September 27, 2020

    So I did some stuff:

    • I did CHKDSK and defrag on my HDD, I don't think it changed anything much since I do automatic weekly defrag and chkdsk found no errors. I'll do a ram test if that's even a thing later.
    • I tried Vulkan addon, it didn't change much from no addon version so I changed back to dx912pxy.
    • I disabled hardware acceleration in discord, no idea if it had any affect (probably yes).
    • Best performance impact so far was increasing textures and environment to medium and disabling ambient occlusion. This gave me around 5 more fps so I am averaging at 30 right now instead of 25.
    • The game is still stuttering.

    @maddoctor.2738 said:
    Press CTRL+ALT+DEL, select task manager, go to performance tab, click on open resource monitor, go to CPU tab and check your core usage.
    On the performance tab you can also check GPU usage, make sure the correct GPU is working on Guild Wars 2, by checking the 1050 usage while running the game.

    Average 30%-40% CPU usage but sometimes it goes down to 15-20%. GPU usage is very volatile, it's around 30% usually (up to 35%ish) but sometimes goes down to 5%. I increased my environment and texture settings to medium though.

    @bpatrick.9635 said:
    Greetings Tayga.3192
    It could be not your computer it could be where you are. There is a lot of internet problems today for some reason. Check this website and click on where you are. For instance Turkey currently has 223 website down.

    https://livemap.pingdom.com/

    Funny how that's where I live, lol. However my problem is FPS not ping.

  • maddoctor.2738maddoctor.2738 Member ✭✭✭✭

    @Tayga.3192 said:
    Average 30%-40% CPU usage but sometimes it goes down to 15-20%. GPU usage is very volatile, it's around 30% usually (up to 35%ish) but sometimes goes down to 5%. I increased my environment and texture settings to medium though.

    You need to open Resource Monitor so you can see individual core usage. A "30% CPU usage" doesn't tell us anything Guild Wars 2 is very demanding on single core performance. So you'll see things like CPU 0, CPU 1, CPU 2, CPU 3 etc based on how many cores you have. Then find the core that is being "hammered" the most and note the usage. For example on my machine I rarely get above 30% CPU usage, but one of the cores (windows makes the assignment, it's not always the same) goes up to 80%+ usage.

    Best performance impact so far was increasing textures and environment to medium and disabling ambient occlusion.

    Ambient Occlusion is exclusively GPU demanding, since it had a performance effect it must be your GPU that is struggling.
    Do you see 2 GPUs or one on Task Manager? GPU 0, GPU 1 etc?
    Find the text called "Dedicated GPU memory" and see if the game goes near the limit, if your GPU has only 4 GB VRAM for example, it's quite possible to hit the limit, especially with Ambient Occlusion on.

  • Tayga.3192Tayga.3192 Member ✭✭✭✭
    edited September 27, 2020

    @maddoctor.2738 said:
    You need to open Resource Monitor so you can see individual core usage. A "30% CPU usage" doesn't tell us anything Guild Wars 2 is very demanding on single core performance. So you'll see things like CPU 0, CPU 1, CPU 2, CPU 3 etc based on how many cores you have. Then find the core that is being "hammered" the most and note the usage. For example on my machine I rarely get above 30% CPU usage, but one of the cores (windows makes the assignment, it's not always the same) goes up to 80%+ usage.

    One CPU core get around 80-90% and one of them gets 60-70%.

    Ambient Occlusion is exclusively GPU demanding, since it had a performance effect it must be your GPU that is struggling.

    Could be, yes.

    Do you see 2 GPUs or one on Task Manager? GPU 0, GPU 1 etc?

    Yes, GPU 0 as Intel graphics and GPU 1 as Nvidia. Intel one is 10 times of Nvidia gpu (20% vs 2-3%). Since I configured everything so GW2 runs on nvidia, I guess that's just because when I minimize the game I change back to intel graphics?

    Find the text called "Dedicated GPU memory" and see if the game goes near the limit, if your GPU has only 4 GB VRAM for example, it's quite possible to hit the limit, especially with Ambient Occlusion on.

    It's way below the limit. It uses less than 1 GB and I have up to 4 GB.

  • maddoctor.2738maddoctor.2738 Member ✭✭✭✭
    edited September 27, 2020

    @Tayga.3192 said:

    @maddoctor.2738 said:
    You need to open Resource Monitor so you can see individual core usage. A "30% CPU usage" doesn't tell us anything Guild Wars 2 is very demanding on single core performance. So you'll see things like CPU 0, CPU 1, CPU 2, CPU 3 etc based on how many cores you have. Then find the core that is being "hammered" the most and note the usage. For example on my machine I rarely get above 30% CPU usage, but one of the cores (windows makes the assignment, it's not always the same) goes up to 80%+ usage.

    One CPU core get around 80-90% and one of them gets 60-70%.

    Play with these settings: Shadows, Reflections, LOD, Model character limit, model character quality, as they affect the CPU the most. If they are already at lowest move on.

    Yes, GPU 0 as Intel graphics and GPU 1 as Nvidia. Intel one is 10 times of Nvidia gpu (20% vs 2-3%). Since I configured everything so GW2 runs on nvidia, I guess that's just because when I minimize the game I change back to intel graphics?

    No. Even if you switch to desktop, it should still show a high number for the nvidia gpu. Plus, it's a graph, you should see the nvidia gpu having a very high usage just before you alt-tab. Open Task Manager first, go to Performance tab and THEN launch the game. After you play a bit, alt-tab back to Task Manager and check the graph.

    Also, in your graphic settings switch to Fullscreen, if it's not set to that, because Windowed Fullscreen has the habit of not using the dedicated graphics card.

    Edit: 1GB of VRAM usage is normal for Windows

  • Tayga.3192Tayga.3192 Member ✭✭✭✭
    edited September 27, 2020

    @maddoctor.2738 said:
    Play with these settings: Shadows, Reflections, LOD, Model character limit, model character quality, as they affect the CPU the most. If they are already at lowest move on.

    Yes, GPU 0 as Intel graphics and GPU 1 as Nvidia. Intel one is 10 times of Nvidia gpu (20% vs 2-3%). Since I configured everything so GW2 runs on nvidia, I guess that's just because when I minimize the game I change back to intel graphics?

    No. Even if you switch to desktop, it should still show a high number for the nvidia gpu. Plus, it's a graph, you should see the nvidia gpu having a very high usage just before you alt-tab. Open Task Manager first, go to Performance tab and THEN launch the game. After you play a bit, alt-tab back to Task Manager and check the graph.

    Also, in your graphic settings switch to Fullscreen, if it's not set to that, because Windowed Fullscreen has the habit of not using the dedicated graphics card.

    Edit: 1GB of VRAM usage is normal for Windows

    Just tested another game, I am now 100% certain GW2 doesn't use my GPU and instead uses intel graphics. It says GW2 uses GPU-0 while that other game uses GPU-1.

    I'll try full screen.

    Edit: Still uses GPU-0. I also deleted my drivers with DDU and redownloaded OEM (?) drivers from my manufacturer's website yesterday but it also didn't affect anything.

    Edit 2: I tried a few other games, funny enough all of them uses GPU-1 while GW2 uses GPU-0 in full screen or in windowed full screen.

  • maddoctor.2738maddoctor.2738 Member ✭✭✭✭

    @Tayga.3192 said:

    @maddoctor.2738 said:
    Play with these settings: Shadows, Reflections, LOD, Model character limit, model character quality, as they affect the CPU the most. If they are already at lowest move on.

    Yes, GPU 0 as Intel graphics and GPU 1 as Nvidia. Intel one is 10 times of Nvidia gpu (20% vs 2-3%). Since I configured everything so GW2 runs on nvidia, I guess that's just because when I minimize the game I change back to intel graphics?

    No. Even if you switch to desktop, it should still show a high number for the nvidia gpu. Plus, it's a graph, you should see the nvidia gpu having a very high usage just before you alt-tab. Open Task Manager first, go to Performance tab and THEN launch the game. After you play a bit, alt-tab back to Task Manager and check the graph.

    Also, in your graphic settings switch to Fullscreen, if it's not set to that, because Windowed Fullscreen has the habit of not using the dedicated graphics card.

    Edit: 1GB of VRAM usage is normal for Windows

    Just tested another game, I am now 100% certain GW2 doesn't use my GPU and instead uses intel graphics. It says GW2 uses GPU-0 while that other game uses GPU-1.

    I'll try full screen.

    Edit: Still uses GPU-0. I also deleted my drivers with DDU and redownloaded OEM (?) drivers from my manufacturer's website yesterday but it also didn't affect anything.

    Edit 2: I tried a few other games, funny enough all of them uses GPU-1 while GW2 uses GPU-0 in full screen or in windowed full screen.

    Guild Wars 2 is notorious for using the IGPU instead of the dedicated graphics card on laptops, but I always thought switching to full screen fixed that.
    Check this out: https://www.reddit.com/r/Guildwars2/comments/7jsuxa/help_gw2_using_onboard_graphics_and_not_dedicated/

    You can actually force any game to use the dedicated graphics. Open the nVidia display settings panel and go to "Manage 3D settings", choose the "Program Settings" tab, pick GW2 from the list, and set "Preferred graphics processor" to "High performance nVidia processor". That should be it.

  • Tayga.3192Tayga.3192 Member ✭✭✭✭

    @maddoctor.2738 said:
    You can actually force any game to use the dedicated graphics. Open the nVidia display settings panel and go to "Manage 3D settings", choose the "Program Settings" tab, pick GW2 from the list, and set "Preferred graphics processor" to "High performance nVidia processor". That should be it.

    Yeah I had that before, just to be sure I redid it but it still uses integrated graphics. I'll open a ticket at this point, thanks for your help!

  • Hannelore.8153Hannelore.8153 Member ✭✭✭✭
    edited September 27, 2020

    @Tayga.3192 said:

    @maddoctor.2738 said:
    You can actually force any game to use the dedicated graphics. Open the nVidia display settings panel and go to "Manage 3D settings", choose the "Program Settings" tab, pick GW2 from the list, and set "Preferred graphics processor" to "High performance nVidia processor". That should be it.

    Yeah I had that before, just to be sure I redid it but it still uses integrated graphics. I'll open a ticket at this point, thanks for your help!

    Guild Wars 2 relaunches itself several times, which often messes up the logic that switches programs between GPUs. This is because the launcher, game, Trading Post, etc. are all in the same executable but also all separate programs as well. The problem is with Intel and NVIDIA using poorly designed software to do this, not in any fault of ArenaNet, especially considering GW predates such designs.

    You need to force dedicated graphics system wide while playing the game, not on a per -app basis. There's absolutely no reason to have the integrated graphics enabled unless you're on battery power or have improper cooling.

    Also, make sure the laptop is on a proper cooling pad and not just sitting on a table or something, because heat can also play a factor; modern CPUs and GPUs simply downclock (slow down) instead of giving you any kind of notice when their temperature thresholds are exceeded. This is especially vital as GW uses 1-2 CPUs heavily and will constantly push the machine into turbo mode (automatic overclock).

    It can also help to put the dx12pxy or DXVK shader cache on a high-performance flash memory device.

    Good luck!

    Hannah | Daisuki[SUKI] Founder, Ehmry Bay, NA | 22 charas, 16k hours, 27k AP | ♀♥♀
    Mains Mariyuuna/Tempest & Alisha Kei/Druid(PvE), Terakura/Spellbreaker & Kitty Koume/Reaper(WvW)
    No need to be best, only good and kind.

  • try to change the settings in nvidia control panel to optimize performance

  • Tayga.3192Tayga.3192 Member ✭✭✭✭
    edited September 27, 2020

    So I opened a ticket, and they said I should disable every overlay I have (they said discord, shadowplay etc but obviously this includes arcdps and dx912pxy as well). Now my game uses the Nvidia gpu, but the game is unplayable now because I lack discord and dx912pxy lol.

    Edit: I also read that directx12 has a feature that makes stuff use integrated intel gpu + normal gpu at the same time so that might be why it's freaking out, since the game doesn't natively support dx12.

  • Wrain.6792Wrain.6792 Member ✭✭
    edited September 27, 2020

    I'd be willing to bet money you are NOT using the geforce 1050 and your card is defaulting to "internal" intel graphics. You need to make sure you are FORCING the geforce card to run by going into nvidia control panel and selecting the Gw2 exe file, and selecting the GPU. That laptop will easily push the game on med at 60+ fps. Good luck

    ****you "may" try going to the laptop drivers for that vendor, and using the SUPPLIED graphics card drivers for it...I know they will be dated but if you are unable to figure out how to force the card 1050 to run..thats your only option."**** Sometimes the laptop vendors have funky locks /issues with driver codes to where you cannot use the newest nvidia drivers without it getting confused. At least this will let you play.

  • Tayga.3192Tayga.3192 Member ✭✭✭✭
    edited September 27, 2020

    @Wrain.6792 said:
    I'd be willing to bet money you are NOT using the geforce 1050 and your card is defaulting to "internal" intel graphics. You need to make sure you are FORCING the geforce card to run by going into nvidia control panel and selecting the Gw2 exe file, and selecting the GPU. That laptop will easily push the game on med at 60+ fps. Good luck

    That's pretty aggressive but you don't need to worry about that, I did that thing for every laptop I had and this is the only time I'm having issues.

    ****you "may" try going to the laptop drivers for that vendor, and using the SUPPLIED graphics card drivers for it...I know they will be dated but if you are unable to figure out how to force the card 1050 to run..thats your only option."**** Sometimes the laptop vendors have funky locks /issues with driver codes to where you cannot use the newest nvidia drivers without it getting confused. At least this will let you play.

    As I said, I'm using latest OEM drivers for nvidia instead of latest generic drivers.

    Thanks for your input anyway :smile:

  • If that is NOT your issue, and you have downloaded GPU-Z while running it in the background to make SURE the core is going up....then your power supply. Do you have the UPGRADED power supply for your laptop or were u given one of them "mini" sized ones. I've seen that before as well where the power supply provided was NOT adequate and they did this to save company money. aka 45w vs 65w, vs 80w. good luck hope you figure it out. (still think though if you download the gpuz- and watch it in the background..your gpu is not being used)

  • jokke.6239jokke.6239 Member ✭✭✭

    Either set dedicated GPU to prefered in nvidia CP or disable integrated GPU in BIOS

  • Holgarf.6581Holgarf.6581 Member ✭✭✭
    edited October 9, 2020

    @Tayga.3192 said:
    First things first, my system:
    Laptop with relatively good cooling (Cleaned recently)
    OS: Windows 10 version 1909 (up to date according to windows update, newest version is not supported yet)
    CPU: Intel i7-7700HQ 2.80ghz
    GPU: Nvidia Geforce 1050
    Ram: 16 GB

    My observations/additional info:

    • Game is not on an SSD.
    • I have dx12 thing (game is unplayable without it) and arcdps.
    • My power settings are configured properly, same goes for my nvidia settings (99% of them are default).
    • My drivers are up to date but with the driver my laptop manufacturer released recently.
    • My settings are everything on lowest setting possible, player model quality is on medium and player model count(?) is on low. Only animations are high and rendering thing on native.
    • I use highest FoV.
    • I get VERY low average fps in fractals especially (it's becomes like a powerpoint slide when it's crowded)
    • I actually have stable ~25-30 fps in WvW maps even when it's 10vs10. I don't know about the desert map since I don't play in that one.
    • I get low average fps in Heart of the Mists (around 10 fps) but for some reason I can get up to 60-80 fps in older PvP maps though.
    • I get pretty bad stutters. I guess it's because of background stuff but I don't even have that many things open, mostly only discord (with hardware acceleration).

    Anything more I can do?

    Oh, well, turn any hardware accelerated overlays off. Run the game in fullscreen mode. You may think your laptop is relatively cool but have you actually monitered your temps with HWInfo64? When gaming your laptop probably gets fairly warm and I would not at all be surprised if your CPU is throttling. Sorry but Laptops are meh. Highest FoV is not going to help (also fisheye sucks), as it just makes more of the environment present and that will have to be rendered. Make sure your laptop power settings are set to balanced.

    The main problem with newer maps is the donuts at Anet thought it'd be mighty funny to go bananas on particle effects... an option that is missing in settings. You cannot turn particle effects down, sadly. I have a Ryzen 3700X and a OC'd RX 580 and in certain maps the FPS is lower than it should be because of that overzealous use of particles (hello grothmar, dragonfall, etc). Turn animations to medium. Make sure reflections are set to off. Shadows, believe it or not are one of the most demanding settings of all (regardless of Medium, High or Ultra, they are not GPU rendered), so pick Low or Off. Really you should be getting better performance but that GPU is going to be weak as all hell and won't be the equivalent of a desktop 1050 version. Any sort of abundance of particles is going to tank FPS which may explain why WvW offers more performance compared to other content. Oh and others have pointed out, make sure your GPU is being used and not the integrated graphics on the Intel chip (check the Nvidia control panel to ensure GW2.exe is using the dedicated GPU).