High fps but games feels very bad... — Guild Wars 2 Forums
Home

High fps but games feels very bad...

Hello,
I have a major issue with experiencing GW2 running even remotly close to what I would call "smooth" on my PC. I have high fps but it does not feel like it. I don't know exactly what it is but I think I have: stutters, screen tearing, frametime spikes and in general the gameplay feels out of sync - as a whole it just feels awful to play the game. Most other online or offline games I play feels great and I don't experience anything close to what It feels playing gw2. However, I do notice that some games feels less smooth even at high fps for example monster hunter world.
PC:
windows 10
ryzen 3700x with noctua NH-U12 fan
rtx 2070 super
2x8gb 3200 ddr4
asus rog strix b450-f
Samsung SSD 970 EVO NVMe M.2
I use two monitors and my main monitors is a: 0,5ms, 144 Hz , G-sync. 1080p monitor

What have I tried?
-Using the d912pxy which gives me a crazy amout of frames but the game still feels stuttry and out of sync.
-Reinstall the game and my OS
-Different ram setting, xmp(on/off)
-3Dmark, furmark, cinebench, to check if hardware runs properly
-DDU driver uninstall and reinstalling drivers
-Using Amd chipset drivers
-Overclocking cpu to stable 4,3ghz frequency with lower than default voltage
-Turning off SMT
-Disabeling various windows settings such as game bar, HPET and other
-empty standby memory list
-checking latency with latencymon
-Disabling g-sync
-Using v-sync and g-sync
-Capping in game frames by different methods: geforce panel, RTTS, and ingame settings.
-Uninstalling MSI afterburner and RTTS
-Using only one monitor

Example of how my game runs in a T4-snowblind fractal with a full party:
Uncapped:
https://imgur.com/tQqfpSy
60fps cap:
https://imgur.com/a/MRkJd7o
V-sync enabled:
https://imgur.com/a/ZVpzoMo

Out of these 3 examples playing with v-sync makes for the best experience but I do feel the occasional input lag. Caping at 60fps feels horrible while it gives the most consistent frametime it just does not feel like 60fps at all - more like 30fps... I used to play GW2 on my old computer with a i5 7600K and gtx 1060 and while I had way lower framerates the game felt so much better to play. It felt responsive an I did not experience any visual stutters or desyncs at all.

I would appreciate and be thankful for any input or recommendation that you may have

Comments

  • KrHome.1920KrHome.1920 Member ✭✭✭✭
    edited October 1, 2020

    The game has horrible frametimes (stuttering, micro freezes...). I did not program the engine but I think it's the shader compilation at runtime which causes this. Compiling shaders at runtime is very flexible and ensures maximum compatibility but can cause CPU performance issues at the same time.

    D912PXY should adress this problem (at least for me it does definitely improve frametimes) as it changes the way the shaders are compiled ingame.

    Using the d912pxy which gives me a crazy amout of frames but the game still feels stuttry and out of sync.

    Did you try to cap your fps to 60 in the nvidia driver at this point? I am doing this too and in the fps cap I have good frametimes (a perfect 16.67ms), even without D912PXY. Of course when the game drops below 60, then the experience becomes horrible for me too.

    Disabling g-sync

    Do never ever disable adaptive sync! If you play the game with a fixed refresh rate you will just get the additional stuttering of such a display (always then, when your fps do not match your refresh rate) right on top of the GW2 issues. Nevertheless traditional VSync does improve frametimes a lot due to the nature of a render ahead queue. But the resulting input lag is huge. Long story short: you can not have everything at once in GW2.

    Your screens...
    ... show basically what I said.

    Uncapped you have a mess of frametime spikes. That's normal in GW2.

    Capped at 60 you have a nice 16.67ms line with only 3 frametime spikes caused by the game engine (probably shader compilation) - I guess you turned around 180 degrees in that moment you got the lag. That's also normal for the game.

    VSync enabled does not improve your frametimes because you are not in the VSync cap as your monitor refresh rate is too high. Try to set your refresh rate to 60 Hz and enable VSync. This should give you the smoothest experience possible, but unfortunately also a ton of input lag.

  • Mack.3045Mack.3045 Member ✭✭✭
    edited October 2, 2020

    @qweasdzx.9865 said:
    Hello,
    I have a major issue with experiencing GW2 running even remotly close to what I would call "smooth" on my PC. I have high fps but it does not feel like it. I don't know exactly what it is but I think I have: stutters, screen tearing, frametime spikes and in general the gameplay feels out of sync - as a whole it just feels awful to play the game. Most other online or offline games I play feels great and I don't experience anything close to what It feels playing gw2. However, I do notice that some games feels less smooth even at high fps for example monster hunter world.
    PC:
    windows 10
    ryzen 3700x with noctua NH-U12 fan
    rtx 2070 super
    2x8gb 3200 ddr4
    asus rog strix b450-f
    Samsung SSD 970 EVO NVMe M.2
    I use two monitors and my main monitors is a: 0,5ms, 144 Hz , G-sync. 1080p monitor

    What have I tried?
    -Using the d912pxy which gives me a crazy amout of frames but the game still feels stuttry and out of sync.
    -Reinstall the game and my OS
    -Different ram setting, xmp(on/off)
    -3Dmark, furmark, cinebench, to check if hardware runs properly
    -DDU driver uninstall and reinstalling drivers
    -Using Amd chipset drivers
    -Overclocking cpu to stable 4,3ghz frequency with lower than default voltage
    -Turning off SMT
    -Disabeling various windows settings such as game bar, HPET and other
    -empty standby memory list
    -checking latency with latencymon
    -Disabling g-sync
    -Using v-sync and g-sync
    -Capping in game frames by different methods: geforce panel, RTTS, and ingame settings.
    -Uninstalling MSI afterburner and RTTS
    -Using only one monitor

    Example of how my game runs in a T4-snowblind fractal with a full party:
    Uncapped:
    https://imgur.com/tQqfpSy
    60fps cap:
    https://imgur.com/a/MRkJd7o
    V-sync enabled:
    https://imgur.com/a/ZVpzoMo

    Out of these 3 examples playing with v-sync makes for the best experience but I do feel the occasional input lag. Caping at 60fps feels horrible while it gives the most consistent frametime it just does not feel like 60fps at all - more like 30fps... I used to play GW2 on my old computer with a i5 7600K and gtx 1060 and while I had way lower framerates the game felt so much better to play. It felt responsive an I did not experience any visual stutters or desyncs at all.

    I would appreciate and be thankful for any input or recommendation that you may have

    Hi , KrHome has given some good advice.

    I would try a clean install of the newly released d912pxy version 2.3 https://en-forum.guildwars2.com/discussion/110553/want-to-use-directx-12-dx12-for-gw2-heres-a-guide-on-using-the-d912pxy-on-windows-10#latest

    Shader compilation now uses multiple threads and you can tweak core allocation via the config file

    Old pck files are not supported due to the variability with shader implementation in the rendering pipeline in the new version.

    In the d912pxy discord channel a few users reported issues with GW2 and G-Sync.

    The solution was to run the game in Windowed Fullscreen mode and not Fullscreen. Try that with the new d912pxy version 2.3 and let me know how you go !

  • Thanks for all the helpful advice. Problem got solved by installing the new 2.3 d912pxy and playing around with some settings in the config file. The game now feels responsive and very smooth finally... The difference truly is night and day. Game went from borderline unplayable to running smoothly. Thanks!

  • Mack.3045Mack.3045 Member ✭✭✭

    @qweasdzx.9865 said:
    Thanks for all the helpful advice. Problem got solved by installing the new 2.3 d912pxy and playing around with some settings in the config file. The game now feels responsive and very smooth finally... The difference truly is night and day. Game went from borderline unplayable to running smoothly. Thanks!

    Awesome man great to hear :) Happy gw2ing !