HELP :( "Connection error(s) detected. Retrying..." — Guild Wars 2 Forums
Home

HELP :( "Connection error(s) detected. Retrying..."

Hey everyone,

I have been unable to play the game since the last Halloween Event weekend earlier this month. Everything was working fine as always, being able to play the game and whatnot but all of a sudden I wasn't able to log in anymore. When I launch the game it doesn't connect to the servers and this error "Connection error(s) detected. Retrying..." appears while download speed stays at 0 KB/s. I had not installed any new programs or made any changes to the system...

I have tryed EVERYTHING literally. I initially uninstalled the game and wiped the Temporal Files from the AppData>Roaming folder. When I tried to re-install the same error appeared...so I opened a ticket with Support. I have tried everything they suggested but nothing is working and they just told me they can't offer any more advice on how to fix this problem...

  • Uninstalled the game and deleted the Cache (temporal files) from AppData>Roaming
  • Made sure that the .exe file wasn't being blocked.
  • Used "netsh winsock reset" on cmd.exe
  • Uninstalled my Antivirus.
  • Turned off Windows Firewall
  • Portforwarded ports 80, 443 and 6112.
  • Made sure exceptions to this ports were open on Windows Firewall.
  • Used Google's DNS and used ipconfig /flushdns
  • Used a VPN

Out of frustration I tryed to install the game in another laptop using the same WiFi as my own laptop (where the game is not working), and it worked. So the issue is not in the network but in my PC.

Today I used a webpage to check if the ports where trully open or not. It appears as they are still closed so I checked again my Firewall exceptions, deleted the older rules and made them from scratch (Inbound and Outbound TCP&UDP rules for ports 80, 443 & 6112). The game is still not connecting to the game servers :'(

DOES ANYONE HAVE ANY SUGGESTIONS? :(

Comments

  • Healix.5819Healix.5819 Member ✭✭✭✭

    The error means it can't connect to the patch server for whatever reason. Assuming you're having the somewhat common problem of connecting to a bad server, you have to...

    Search the start menu for notepad, right click it and run it as an administrator. Open:
    C:\Windows\System32\drivers\etc\hosts

    At the bottom, at the following line, then save:
    52.206.178.33 assetcdn.101.arenanetworks.com

    Now start the launcher. Remove the line once you're done, since the IP will eventually change and cause this problem.

    (normally you'd do this by using the -assetsrv option, but it's been broken for months)

  • THANK YOU!

    Wow, I can NOT believe that after 10 days emailing back and forth with Support they could not think of this and you just solved my problem like a walk in the park. For real, you don't know how much I appreciate your help :D