Ranger longbow bug in Sparking the Flame. — Guild Wars 2 Forums

Ranger longbow bug in Sparking the Flame.

theOmegaAlex.4863theOmegaAlex.4863 Member ✭✭
edited October 22, 2017 in Bugs: Game, Forum, Website

Unable to select longbow after using short bow at the start of Pursuing the Herald of Balthazar in PoF. Happened at 0736 10/22/17 on 64bit MAC client.

i.imgur.com/9oPkCIg.png

Comments

  • nottsgman.8206nottsgman.8206 Member ✭✭✭
    edited October 22, 2017

    have you tried dismounting?

    edit to add: mounting is classed as a transform, and just like all other transforms, your profession is overwritten by it. so no weapons can be equipped while transformed, unless the transform can use said weapon. that's how I understand it anyway.

    70 'mains' and waiting for more slots
    | 61 Asura | 6 Charr | 1 Norn | 1 Human | 1 Sylvari |

  • theOmegaAlex.4863theOmegaAlex.4863 Member ✭✭
    edited December 30, 2017

    I wasn't mounted when it initially happened. This was after the fight when I was able to grab a screenshot. So, yes, I tried it both mounted and not mounted.

©2010–2018 ArenaNet, LLC. All rights reserved. Guild Wars, Guild Wars 2, Heart of Thorns, Guild Wars 2: Path of Fire, ArenaNet, NCSOFT, the Interlocking NC Logo, and all associated logos and designs are trademarks or registered trademarks of NCSOFT Corporation. All other trademarks are the property of their respective owners.