Launcher doesn't Launch — Guild Wars 2 Forums
Home

Launcher doesn't Launch

Hello, I'be been playing GW2 since July without any trouble until this week... the Launcher simply won't launch
I just try to open it and nothing shows up, not even a crash message on the 64 bit Exe, but in the Task Manager I see the game "running" and eating 25% of my CPU, let it be for like 1 hour and then forced it to end the task, tried again with no new results (repeated times)

I then tried to run the 32 Bits client and it throws a crash error, like kitten? Nevermind, let's try to use the " - repair" adition to the link, nothing changes... then again I thought "Ok, let's download again the Client and try to install it clean in a new folder", guess what? Nothing happens, or better said, the same happens, it is like downloading few files in the Installer folder without showing a single thing/screen/patcher/client but after those files are downloaded (like 29 Mb only) it stays as a running process hidden in the background that can only be detected by the Task Manager and I need to finish it (after hours of letting it trying to download stuff)

At this point I have no idea on what to do, my PC is a I5 8400 with a nVidia GTX 750 TI and I didn't update the OS (Win10) neither the Drivers, both the OS and the Game are in an almost new 240 Crucial SSD so there shouldn't be any trouble with it

I have no idea what is happening, is there anything I can do to provide useful info about it? Do you need the 32 Bit crash report? Since I always played with the 64 Bit client I don't even know if the crash message is normal for it or old or whatever since I never launched it, but I have no clue on how to solve this and I want to play please =/

I already searched on the forums and googled it (there is where I got the -repair command which didn't work) but I didn't found any more useful info, so I ask for your help and sorry about wasting your time but I will be grateful on any answer (even the trolling ones, at this point I am taking it with laughs)

Comments

  • Linken.6345Linken.6345 Member ✭✭✭✭

    Do you use arcdps?
    If so try remove 3d39.dll from your gw2 bin64 folder and try the launcher again.

  • @Linken.6345 said:
    Do you use arcdps?
    If so try remove 3d39.dll from your gw2 bin64 folder and try the launcher again.

    Nope, don't have that and just in case I searched for the file in the whole folder/disk with no results, so I am clean I suppose (?)
    Also like I said, I tried to install it all over again in a new folder and even the installer does the same...

  • Linken.6345Linken.6345 Member ✭✭✭✭
    edited February 13, 2021

    You probabely are yes.

    Out of curiosity are you installing it?
    D : \games\gw2
    The reason I ask is some folders are not good to install gw2 into like for example progam86 windows folder.

  • @Linken.6345 said:
    You probabely are yes.

    Out of curiosity are you installing it?
    D : \games\gw2
    The reason I ask is some folders are not good to install gw2 into like for example progam86 windows folder.

    Nope, I installed it in C:/GuildWars2 in the root of the SSD hahaha, and as I said, it worked without trouble until.... Wednesday I think or Tuesday, then this happened, tried few days to solve it alone but couldn't do it so I am asking here for help

  • Linken.6345Linken.6345 Member ✭✭✭✭

    Any update to antivirus that might block gw2 connection to the net?

  • @Linken.6345 said:
    Any update to antivirus that might block gw2 connection to the net?

    Always inactive, I use Linux mainly, only boot on Windows to Play GW2 and some BNet games =/
    Firewall deactivated as well

  • Inculpatus cedo.9234Inculpatus cedo.9234 Member ✭✭✭✭
    edited February 13, 2021

    Using any programs that might have an overlay? Such as Discord, etc.?
    Tried launching in Safe Mode (with internet capabilities)?

    If you continue to have issue, you can contact the Tech CS Team via the 'Support' link above/below and 'Submit a Ticket' for assistance.

    Good luck.