Guild Mission Rewards not dropping — Guild Wars 2 Forums
Home

Guild Mission Rewards not dropping

This is the second weekend in a row that we have done guild missions and not gotten the rewards. We get the credit for the guild the points for favor increase the personal and guild icons change to reflect completion. No reward chest is spawned or dropped in the right hand reward panel area for our characters. We have, since 2020, noticed a much loner wait time for the chests to drop. But now they are not even dropping.

For those of us still working on the HoT guild weapon skins this BLOCKS PROGRESS as the commendations are not able to be collected. Please fix it soon or post what can be done to resolve or work around the problem.

I would like to suggest that the guild rewards and the commendations be added to a chest in the guild hall that guild members can go to and open up when they are done for their rewards. Just a thought.

Thank You

Comments

  • Wolfb.7025Wolfb.7025 Member ✭✭✭

    Two things you have to consider:

    1.- Make sure you're representing the guild you're doing Guild Missions with.
    2.- Trek and Race Guild missions randomly gives you the chest right after you complete the first of several objectives, this is probably your case, you get the bouncy chest before completing the guild mission (getting 1 or 2 treks or someone completing the race when you have gotten past at least one checkpoint) and you accept it without being aware of what it is, but when the guild mission is done, you don't get any other bouncy chests, then get confused and start blaming the system.

    In the Guild Panel check the guild missions tab, and see if the chests are open for you (that means you're already claimed the reward of said mission),

    Years just pass like trains
    I wave but they don't sloow dooown~ don't slow doown~♪

  • @Wolfb.7025 said:

    1- Not an issue
    2- Not an issue as stated the guild received the favor therefore the mission was completed!
    3- As per my post but again not an issue, they were closed. Then once we completed the mission they were opened with the glowy icon in the chest and the glowy shield for the guild mission. Again, NO REWARD.

    This happened for Trek, bounty and race, though race was completed before we arrived, and we (more than one account) did not receive rewards for any.

    Thanks for trying. The best I'm hoping is they are working on guild missions for EoD. Worst we won't get credit again this weekend and there needs to be a ticket that won't get fixed. Like my last 2 tickets. "we will have to wait until we can assign a developer" (i.e. NEVER going to happen)

    The post was made to see if others were having similar issues. Why? Well when we did our missions 2 weeks prior others were complaining about this very issue. We told them we had not had any problems and we received our rewards then for Trek, Race, and Bounty. The next weekend no rewards, then again last weekend no rewards. Again it's taken up to a full minute to receive them the last few weeks we did the missions. Would be nice to know I won't be wasting my time this weekend but.....

  • Linken.6345Linken.6345 Member ✭✭✭✭

    My guild have no problem getting rewarded for the guild missions ever so far.

    Since chest is opned appeared pretty sure you got reward just dident notice it.

  • It could be worth it to check if the same thing happens with another guild, using the same character(s). If not, then there may be something wrong with your guild's data on the servers.

  • Seth Moonshadow.2710Seth Moonshadow.2710 Member ✭✭✭
    edited February 25, 2021

    @kumiponi.6047 said:
    It could be worth it to check if the same thing happens with another guild, using the same character(s). If not, then there may be something wrong with your guild's data on the servers.

    Good suggestion!
    How is that going to work? We tried our other 2 guilds that needed the same credit. They did get the favor, but due to the 1 reward/per account/per guild/day (or week really)? We have all 5 guilds full and 3 (or is it 2 I forgot) of those guilds are maxed. So we mostly only work on our remaining guilds. But yes we tried that and while the guild received credit, we did not get our reward.

    So the only way to check your theory now would be to leave one of our guilds and try it with another not owned buy us. Is that what you would think? That could rule out that it is a guild issue and show an account issue instead. Since both of us did not get our rewards.

    This weekend we will know for sure as it will be our 3rd time not getting them.

  • YAY!!! We normally do our GM on Sunday mornings, but we chose to do them today. I don't know if it was that change or if they did something directly to fix it or not or if it was the patch that dropped recently. But either way we are back to getting our guild mission rewards! This is not the first time this kind of thing has happened to us. Given the weekly nature it goes unnoticed sometimes. But it's back to working and that's what matters.

    THANK YOU! ArenaNet staff

    Thank You Wolf & Kumiponi for you input :)

    I'm just glad I didn't have to file a ticket wipes sweat off forehead