BUG: Collection can't be completed, sub-achievement not unlocking — Guild Wars 2 Forums
Home Bugs: Game, Forum, Website

BUG: Collection can't be completed, sub-achievement not unlocking

Hello,

I’m writing here after not receiving an adequate solution through support ticket. It seems there’s a bug with Nicabar achievement in the Icebrood saga content.

Nicabar achievement needs several items to finish, one of them the "Experimentation" item which is rewarded after mining 30 eternal ice (i.e. 10 eternal ice nodes). The problem is this requirement is finished, but I didn't get the "Experimentation" unlock on Nicabar collection (I never received the ítem), so I can't finish this collection.

If I go mining, I still receive more “Eternal ice powder” from nodes, but don't get the reward needed for the collection. It seems bugged.

You can see in the image that I have the “Experimentation” achievement completed but it shows as not finished at Nicabar achievement.

Apparently the misssing item (the one the achievement gives and it's needed for collection) can't be mailed in-game as far as I know. After talking to the support team, they asked me to post here, so here I am. I would be glad if there’s anything that can be done with this, as it’s blocking progress (and I am that achievement hunter kind of player).

Thank you for your support.

P.D: the collection is compled except for that only item (15/16).

Comments

  • Inculpatus cedo.9234Inculpatus cedo.9234 Member ✭✭✭✭

    Probably a long shot, but have you tried a -repair of the client, in case of corrupted file(s)?

    Good luck.

  • I did it, with no luck. Also tried mining with another character.

  • Knight.6914Knight.6914 Member
    edited April 1, 2021

    Sorry to bump, but anyone else had this problem with this collection? Or any other for the case. If so, any idea about how to solve it or when it will get patched?

  • WindBlade.8749WindBlade.8749 Member ✭✭✭

    For this type of thing contact the support

  • I did it, and they recommended to come here and ask.