Today's latest build locks my computer when loading. — Guild Wars 2 Forums
Home

Today's latest build locks my computer when loading.

Anyone else having this problem. This never happened before.

Comments

  • The latest installer lock my system to.

  • same for me

  • Infusion.7149Infusion.7149 Member ✭✭✭✭

    You might want to list your specs and check your windows update and driver history.

  • @Infusion.7149 said:
    You might want to list your specs and check your windows update and driver history.

    Everything was working fine when I got the new build notice. Everything is up to date. Then I logged out and it went to download the update then it locked up. It lock up trying the /repair also. I disabled the video card and plugged the monitor into the onboard graphics. The installer loaded but wouldn't accept the folder I have GW2 in. I deleted the folder At least it isn't locking up now. I will know when the Gw2.dat finishes downloading.

  • Ashantara.8731Ashantara.8731 Member ✭✭✭✭
    edited March 26, 2021

    By "is locking my computer" you mean that, as soon as you launch the game, the system freezes and you have to reboot?

  • Fueki.4753Fueki.4753 Member ✭✭✭✭
    edited March 27, 2021

    @Ashantara.8731 said:
    By "is locking my computer" you mean that, as soon as you launch the game, the system freezes and you have to reboot?

    I sometimes have the problem that GW2 causes my Screen to brighten (possibly to my ingame gamma settings), which it always does when starting the game, but the game doesn't actually start.
    In those cases, I have to shut off the PC via the power button and restart it. Not even Task Manager works when that happens.

    It's possible that Carnius Magius.8091 is referring to the same issue.

  • Cristalyan.5728Cristalyan.5728 Member ✭✭✭
    edited March 27, 2021

    I have problems too.
    Yesterday, after the update I observed that after any action of leaving the game interface (switching to an explorer for example, or for desktop, while GW still active) resulted in a system freeze. Not even Alt+Ctrl+Del worked. Then, I observed the same thing when leaving GW2 - logout/exit to desktop/switch character. The only solution was to restart the system.
    I repaired the client. I even deleted the game and loaded an older version. After a loooong update the game is not even starting - the entire system freeze after the command "Login". Again, the only solution is the restart of the system.
    Bleah !! At least, yesterday, I was able to login :#

    Until the last update I had no problems. I have a laptop / i7/16 Gb Ram / SSD + HDD / GTX 950M. And Win 10.

  • @Ashantara.8731 said:
    By "is locking my computer" you mean that, as soon as you launch the game, the system freezes and you have to reboot?

    Yes. Something was hosed in the GW2 folder. The installer wouldn't let me use that folder to install until the folder was empty. So gw2.exe wouldn't even do a repair. All is fine now that I did a fresh install.

  • Ashantara.8731Ashantara.8731 Member ✭✭✭✭

    @Carnius Magius.8091 said:

    @Ashantara.8731 said:
    By "is locking my computer" you mean that, as soon as you launch the game, the system freezes and you have to reboot?

    Yes. Something was hosed in the GW2 folder. The installer wouldn't let me use that folder to install until the folder was empty. So gw2.exe wouldn't even do a repair. All is fine now that I did a fresh install.

    Never install non-system-related stuff in the Program Files directories, if you can avoid it. Better create a separate directory for them, e.g. "Games" (and preferably on a separate partition, too).