Screenshot folder full - can't fix - [Merged] — Guild Wars 2 Forums
Home

Screenshot folder full - can't fix - [Merged]

Heibi.4251Heibi.4251 Member ✭✭✭
edited March 29, 2021 in Account & Technical Support

I just received the "screenshot folder is full" message.". I moved everything out of the folder and it still won't let me take any screenshots. Any ideas?

Henge of Denravi Commander
CA/CH/HOD/AIR

Comments

  • Inculpatus cedo.9234Inculpatus cedo.9234 Member ✭✭✭✭

    Here's a result using the 'Search' feature; you may find more:

    https://en-forum.guildwars2.com/discussion/comment/1314868/#Comment_1314868

  • Heibi.4251Heibi.4251 Member ✭✭✭

    I don't use Yolomouse. Thanks though.

    Henge of Denravi Commander
    CA/CH/HOD/AIR

  • Linken.6345Linken.6345 Member ✭✭✭✭

    @Heibi.4251 said:
    I don't use Yolomouse. Thanks though.

    Maybe read the whole thread?

  • Demonhead.7584Demonhead.7584 Member ✭✭
    edited March 27, 2021

    The screenshot function suddenly stopped working, giving me an error message in the chat saying that the file is full. I actively clear out the screenshots in the folder and organize them elsewhere for keep-sake. This issue seems to have occurred immediately after the patch yesterday.

    Been here since the Prophecies were first told.

  • Heibi.4251Heibi.4251 Member ✭✭✭

    So I'm not the only one this is happening to

    Henge of Denravi Commander
    CA/CH/HOD/AIR

  • Ashantara.8731Ashantara.8731 Member ✭✭✭✭

    I had this happen in the past. The solution was to add the YoloMouse installation folder to my antivirus's list of exceptions (my GW2 game folder was already added).

    I imagine other addons might cause the same issue, so adding those as well could solve the problem for you.

  • @Heibi.4251 said:
    So I'm not the only one this is happening to

    omg another person also having this issue! Hopefully it gets resolved sooner, rather than later...

    @Ashantara.8731 said:
    I had this happen in the past. The solution was to add the YoloMouse installation folder to my antivirus's list of exceptions (my GW2 game folder was already added).

    I imagine other addons might cause the same issue, so adding those as well could solve the problem for you.

    I'm not running any other add-ons to GW2, so I'm not sure what's causing the issue. What's the YoloMouse thing?

    Been here since the Prophecies were first told.

  • Aenaos.8160Aenaos.8160 Member ✭✭✭
    edited March 27, 2021

    Same.
    Not running any add ons.

  • Ashantara.8731Ashantara.8731 Member ✭✭✭✭

    @Demonhead.7584 said:
    I'm not running any other add-ons to GW2, so I'm not sure what's causing the issue.

    Have you added the GW2 installation folder to your antivirus's list of exceptions?
    Have you installed GW2 in a separate Games folder outside of Windows' Program Files?

    What's the YoloMouse thing?

    https://dragonrisegames.com/yolomouse/about

  • Avast seemed to be causing the issue on my end. I just had to go to my Avast Antivirus, then I went to Settings, then I went to Blocked & Allowed Apps, and then I added GW2 to the "List of all allowed apps."

  • Inculpatus cedo.9234Inculpatus cedo.9234 Member ✭✭✭✭
    edited March 28, 2021

    Huh. Avast stopped me from logging in, as I had to give permission to change 'Third-party Software - Read Me' folder in GW2 folder, today. And yet, the last change to that folder was 2 days ago.
    Very odd.

  • MadKakerlaken.7846MadKakerlaken.7846 Member ✭✭
    edited March 28, 2021

    Hi guys,
    two days ago I had that issue with screenshot folder being "too full" and had to allow GW2 on Avast. Everything worked out fine until today - when starting the game, the usual Windows message about admin privileges pops out. I could start the log-in screen afterwards, but... the Heart of Thorns log in screen shows with a pop-up window sayying: "You do not have sufficient privileges to patch the file at this location. Please log in as an administrator and try again.". I only have one account on this device and yes, I tried running it as admin, but the problem still appears.

    EDIT: Ok, so I moved the GW2 folder from Program FIles - and it worked. BUT! avast stepped in once again saying, that GW2.exe wants to change/delete the THIRDPARTYSOFTWARE readme file.

  • @Ashantara.8731 said:

    @Demonhead.7584 said:
    I'm not running any other add-ons to GW2, so I'm not sure what's causing the issue.

    Have you added the GW2 installation folder to your antivirus's list of exceptions?

    Yep

    Have you installed GW2 in a separate Games folder outside of Windows' Program Files?

    Nope

    Been here since the Prophecies were first told.

  • Demonhead.7584Demonhead.7584 Member ✭✭
    edited March 28, 2021

    Found a solution:

    Removed all Gw2 related exceptions from antivirus and put them back in. I put both the Screenshot folder as well as the installation folder paths as exceptions. Close and re-open GW2, and it worked!

    Been here since the Prophecies were first told.

  • Ashantara.8731Ashantara.8731 Member ✭✭✭✭
    edited March 28, 2021

    @Demonhead.7584 said:

    Have you installed GW2 in a separate Games folder outside of Windows' Program Files?

    Nope

    Then that might be the source of your problem. Never install anything that isn't system-related in there.

    To avoid something like this from happening again, create your own Games folder outside of Program Files, preferably on a separate partition, and move the GW2 installation folder there. Don't forget to delete the Local.dat after you moved the files, and also delete the GW2 temp folders from the Temp directory.

  • @Ashantara.8731 said:

    @Demonhead.7584 said:

    Have you installed GW2 in a separate Games folder outside of Windows' Program Files?

    Nope

    Then that might be the source of your problem. Never install anything that isn't system-related in there.

    To avoid something like this from happening again, create your own Games folder outside of Program Files, preferably on a separate partition, and move the GW2 installation folder there. Don't forget to delete the Local.dat after you moved the files, and also delete the GW2 temp folders from the Temp directory.

    This wasn't the issue at all, I've posted the issue + solution above.

    Been here since the Prophecies were first told.

  • i had this problem, also went into antivirus and readded it as an exception, didnt even need to reopen the game and it was working instantly.

    It doesn't matter how long it takes to achieve something, its not the end result that matters, its the journey you take to get there.

    Whiteside Ridge (EU), Achievement Hunter

  • Ashantara.8731Ashantara.8731 Member ✭✭✭✭

    @Demonhead.7584 said:
    This wasn't the issue at all, I've posted the issue + solution above.

    I read it before responding, and I am still recommending you follow my advice to avoid future issues.

  • Heibi.4251Heibi.4251 Member ✭✭✭

    I'm still getting this screen shot is full message. Working with ANET but nothing has worked. I have GW2 set as an exception through my anti-virus and I have no screenshots in the folder at all.

    Henge of Denravi Commander
    CA/CH/HOD/AIR

  • @Illumine Sparkler.6019 said:
    i had this problem, also went into antivirus and readded it as an exception, didnt even need to reopen the game and it was working instantly.

    Cool :D then the solution works better than otherwise thought!

    Been here since the Prophecies were first told.

  • Heibi.4251Heibi.4251 Member ✭✭✭

    Somehow the problem resolved itself. No idea why it stopped working and now works again.

    Henge of Denravi Commander
    CA/CH/HOD/AIR

  • Smeerlap.2698Smeerlap.2698 Member ✭✭✭

    There is a screenshot folder in the DOCUMENTS folder also (WIN10) - that's the one that is in use - so probably the one you should copy or clean out.

    C:\Users\PLAYER\Documents\Guild Wars 2\Screens

  • Smeerlap.2698Smeerlap.2698 Member ✭✭✭

    @Heibi.4251 said:
    I just received the "screenshot folder is full" message.". I moved everything out of the folder and it still won't let me take any screenshots. Any ideas?

    There is a screenshot folder in the DOCUMENTS folder also (WIN10) - that's the one that is in use - so probably the one you should copy or clean out.

    C:\Users\PLAYER\Documents\Guild Wars 2\Screens

  • Ashantara.8731Ashantara.8731 Member ✭✭✭✭

    Just follow these rules and you won't have any issues in the future:

    1. Never install anything in Program Files or Program Files (x64), unless it's system-related. Create your own Games folder on the drive's root directory (even better if on another, separate partition than the Windows one).
    2. Always add GW2 as well as any add-on installation folders outside of the GW2 directory to your antivirus's list of exceptions.
  • Heibi.4251Heibi.4251 Member ✭✭✭

    @Ashantara.8731 said:
    Just follow these rules and you won't have any issues in the future:

    1. Never install anything in Program Files or Program Files (x64), unless it's system-related. Create your own Games folder on the drive's root directory (even better if on another, separate partition than the Windows one).
    2. Always add GW2 as well as any add-on installation folders outside of the GW2 directory to your antivirus's list of exceptions.

    Strange part is it had been working just fine for years and then suddenly said it was full event though it wasn't. After a bunch of efforts to fix it it decided to work again all on its own.

    Henge of Denravi Commander
    CA/CH/HOD/AIR

  • Ashantara.8731Ashantara.8731 Member ✭✭✭✭

    @Heibi.4251 said:
    Strange part is it had been working just fine for years and then suddenly said it was full event though it wasn't. After a bunch of efforts to fix it it decided to work again all on its own.

    On a computer system, nothing "works again on its own." You can be certain that it will happen again at some point unless you change something according to previous advice.