Issues with High lag and rendering — Guild Wars 2 Forums
Home

Issues with High lag and rendering

Hey Y'all
Since yesterday iv been experiencing very slow rendering and high lag in highly populated areas.
Iv been running verius diagnostics and I cant find the root to the problem and it seems like its only with GW2 i have these problems.
My graphic card is a Nvidia Geforce GTX 1650 Ti.
Any idears to what i can do to fix this problem?

Comments

  • Inculpatus cedo.9234Inculpatus cedo.9234 Member ✭✭✭✭

    You can try a VPN that takes a different path to the servers.
    You can try changing your graphics options.

  • I have tried and turning my graphics down and it gets better.
    But I didnt make any changes to the graphics prior to the issues.

  • I have the same issue since the 06.04.2021 patch.

  • Tony.8659Tony.8659 Member ✭✭✭

    Just right now it happened while in SAB lag spikes all over up to and over 2000 ping. What's going on Anet? My connection is rock solid on FiOS here, did a speedtest I get 7ms ping so the issue is clearly on your side other online games I play are fine I just tested a few.

  • Link.6157Link.6157 Member ✭✭

    Better get used to it, been having lagg/pingspikes for a year or so now, they just can't seem to fix it completely. Weekends are better but after work hours, gl. Makes alot of harder content very frustrating. SAB in tribulation now is just ... blocks hitting me way out of their range, sudden deaths where no dying spots are etc.
    I'm still hesitant to use a VPN tbh, but i fear it's going to be that and the third expansion or nothing, because i gess it will only get worse with more players..

  • Tony.8659Tony.8659 Member ✭✭✭

    These spikes are very rare on my side, I had to wait a bit over an hr to see the pings return to normal, 20,30,40 around those pings I normally get and some under 20. So it seems for us the problem is on Anet's side. I would avoid any SAB modes during very high pings that is not fun :)

  • crepuscular.9047crepuscular.9047 Member ✭✭✭✭

    OP isn't imagining things, there's something wrong with the SAB update, I have been getting stutters since the patch, checked my GPU usage it was constantly hitting 100% even at low pop area, and I'm running a 1080Ti, which is very overkill for GW2.

    fyi I have disable all addons like arcdps and Taco to verify the high GPU usage is not cause by them; I have experienced in the past that an outdate arcdps can cause the game to stutter.

    [RIP Fashion Wars 2005-2018]     [TTS] [KA] [SI]     [RIP Fashion Wars 2005-2018]
    Praise the Inevitable Eternal Transcendent King Palawa Ignacious Joko, the Beloved and Feared Undying Eternal Monarch of All !!!
    ... til Aurene ate him for dessert 😭