Unable to verify the Guild Wars 2 executable — Guild Wars 2 Forums

Unable to verify the Guild Wars 2 executable

Hi, I'm trying to install GW2 on an old laptop, just to try if I'll be able to play it with my brother, before buying a new PC. But I get the message:
“Unable to verify the Guild Wars 2 executable. Please try again. If the problem persists, uninstall and reinstall the application, or contact customer support.”
I found several threads suggesting to rename the file GW2.tmp into GW2.exe and other things. The problem is that I don't even have a GW2 folder. I get this message from the launcher, during my very first installation.
Any tips?
Thanks

Comments

  • Healix.5819Healix.5819 Member ✭✭✭✭

    By default, it installs to Program Files/Guild Wars 2, or if it's an older version, the %temp% folder.

    To install it manually, you can simply rename Gw2Setup.exe to Gw2.exe, place it where you want it, then run it, which will begin installing to its current folder. If you don't have Gw2Setup.exe, download and rename either Gw2-64.exe (for 64-bit) or Gw2.exe (for 32-bit), which are direct from the patch server.

  • Urud.4925Urud.4925 Member ✭✭✭
    edited November 17, 2017

    You are a GENIUS! I sent a ticket to support and they sent me the Game Advisor tool to check my system/network. But your reply came faster and you understood the problem :)
    I renamed the "Gw2Setup.exe" to "Gw2.exe". Although I got the same error, this finally created 2 new files, a "gw2.dat" and a "gw2.tmp". I renamed this "gw2.tmp" to "gw2.exe" and the launcher started.
    I still get the message "you lost connection with the server" but at least it's now downloading the full game properly.
    Thank you Healix!

  • Hi, on august 29 I was trying to login in to the game , when the client tried to update and I got a message "unable to verify game executable " . I tried all the solutions mentioned with no success. To note that I was playing normally before that date. I sent to technical support and I am still waiting for response , I even uninstalled the whole game and tried to reinstall with no success, still getting the same error.

  • Urud.4925Urud.4925 Member ✭✭✭
    edited September 3, 2018

    Support is probably very busy at the moment. Some weeks ago they replied to a ticket that I sent 30 days before, with apologies. Anyway, about this particular issue, when it happened to me, they told me to download the Game Advisor, launch it and send them the log (in case you want to spare some days and send it before they reply).
    They said that my laptop wasn't good enough to run the game, although recently I decided to format my HD and reinstall Windows, and I didn't get this message anymore (the laptop is indeed too crappy to play GW2, but the problem was in some network setting on my side).
    In case you want to try, I found something on reddit and on the old forum (basically they suggest to rename gw2.exe to gw2old.exe and gw2.tmp to gw2.exe).

    EDIT: for some reason, I'm not able to embed the link of the Game Advisor: us.ncsoft.com/gameadvisor

  • This trick fixed it for me today, changing "gw2-64.exe" to "gw2-64.exe.old" then changing "gw2-64.tmp" to "gw2-64.exe". It then needed to repair my data archive, this took some time, but finally got me running again.

©2010–2018 ArenaNet, LLC. All rights reserved. Guild Wars, Guild Wars 2, Heart of Thorns, Guild Wars 2: Path of Fire, ArenaNet, NCSOFT, the Interlocking NC Logo, and all associated logos and designs are trademarks or registered trademarks of NCSOFT Corporation. All other trademarks are the property of their respective owners.