Low FPS / Lag Issues [MERGED] - Page 7 — Guild Wars 2 Forums

Low FPS / Lag Issues [MERGED]

123457

Comments

  • Blocki.4931Blocki.4931 Member ✭✭✭✭

    It probably won't help anybody here, but I found another cause of lag recently and that is the Windows 10 Feature of having multiple desktops. Windows + Tab, check the top left corner if you only have 1 window showing up there. I must have accidentally created another one at some point and it caused my severe FPS issues until a couple weeks ago where I discovered it.

    Smugly chuckling forever.
    My sentence doesn't make sense? Well, I probably forgot to write half of it before posting.

  • Emprer.7256Emprer.7256 Member ✭✭✭

    Been getting lag spikes lately. Located in Hong Kong. Stable internet and doesn’t happen on other things that use internet.

  • fixit.7189fixit.7189 Member ✭✭
    edited October 8, 2018

    All I know is that whenever they switched servers and their locations my ping has gone up.

  • glumz.1874glumz.1874 Member
    edited November 25, 2018

    I do not understand what happened to gw2? My computer became much stronger (i7-7700, 1050ti, ssd, 8gb), but lags appeared. FPS drops to 7-9 frames per second, and then increases again. I reinstalled the driver, set the settings to a minimum, but the FPS drops from 60 to 7, and then grows again. What happened to the optimization? Help!
    The game began to hang with alt + tab, only a full restart helps
    My region - Russia, bursts start immediately after client installation (I returned to the game after 3 years break)

  • Menzo.2185Menzo.2185 Member ✭✭✭

    Is it just me or more people are having high ping issues this week and DC'ing from WvW?

  • I am having issues with really high ping/bad lag. It does seem to occur in any mode but I am particularly noticing it in the PvE maps and when attempting the Beetle Races. It seems to be spiking on these maps (up to 3-4k) but overall doesn't seem like my "normal" ping.

  • I'm having these same issues. It's at random intervals and sometimes fixes itself and then comes back again. I never had this before and only seems to be happening in GW2

  • Same for me...

  • Master Ketsu.4569Master Ketsu.4569 Member ✭✭✭✭

    Ping is over 200 since last update when normally around 85.

    Ran latency tests to various servers and confirmed it is 100% not the fault of my internet connection. One of the node hops in Anets network is likely faulting.

  • Same here, ping sometimes goes over 4000, heard people complaning about ping in the map chat, and now i ran into it by myself =\

  • Leyn.7908Leyn.7908 Member
    edited December 1, 2018

    Same thing for me, logged in today and went to dragon's stand for the daily, but get over 3000 ping, even if I switch to another map afterwards.

    Edit: at some point I also got disconnected from the server randomly

  • coro.3176coro.3176 Member ✭✭✭✭

    Been getting 30-40ms higher ping in WvW. It's really noticeable.

    I'm normally at ~95-100. Currently averaging 135

  • Im having hard ping issue too. But on mostly all maps, included PvP maps.
    Im having from 400 to 900 ping when i used to have 150/200 ar max.
    Its the only game i having ping(i mean, i double and triple checked its not my conection)
    Any idea what could be?

    I dont want to sound like a bad person but i feel a bit of relief someone is also having same issue

  • I am not currently playing GW2 a lot, but have massive issues at the moment when connecting to NA servers from EU to play MS2. So I checked my GW2 accounts (EU and NA) and I'm seeing pretty much the same picture. Servers for both games are running on AmazonAWS and it seems that connections from EU to servers in NA suffer from major latency issues at the moment. Around +200ms higher ping than usual plus lag spikes of more than 3000 ms every now and then.

  • folk.8190folk.8190 Member ✭✭

    i cant play, in wvwvw ping over 400. in fractals around 250-300 openworld 100-400. I'm normally at 60-75

  • Since latest season episode came out this game is unplayable! Freezes, black screen, ping, now even in Raids, every 2-3 minutes! Maybe Gw2 needs better PC, but 6 months ago I played pretty good, had no problems, even in WvW.
    Anet kitten up something very very badly! I just watch the Raid lfg and 60% fewer ppl on it, that means lots of people can't play this game anymore, or won't play it it's so kitten up atm!

  • I've been playing almost every day for the past 2 months. From Australia so ping is usually at 280ms on NA servers. Its been at 350ms for about the past 2 weeks. In WvW it's become impossible to play when big fights are happening because the ping will go to 3-5k just getting close to the fight. In the last two or three days, however, I can't even play anymore. I can log into the game, select character and load any map. Once in it kills the game within 10 seconds. (TC Server, not sure if it matters)

    Getting the WvW itch real bad...
    I'm having withdrawals

  • folk.8190folk.8190 Member ✭✭

    and again. today ping is "awesome" 400-800

  • Tashigi.3159Tashigi.3159 Member ✭✭✭

    It's been a rollercoaster for me as well. Granted, my connection is pretty darn good compared to most and I am relatively close to the servers. My normal ping for over 4+ years of playing this game is between 40-60. Over this last week, it's beeen anywhere from 80-170, with sudden spikes to 400-500.

  • Yeah, I also have a good connection and since update that the game is pratically unplayable for me. It's really THAT bad, other than the daily logins chests I would have no reason to log in at all since I can't do anything anywhere :/

  • same here, im from south asia so my ping is already pretty high but recently its just unplayable, cant even do my dailies properly

  • Reporting from the Middle East. I play on NA servers and since the last patch, latency has been crazy.
    Certain sPvP games are totally unplayable while certain maps in PvE are also terribly laggy. The worst part is- it is not consistent. I cannot predict which game will go good or which one will be an absolute mess.

    What is the solution?

  • Tashigi.3159Tashigi.3159 Member ✭✭✭

    I changed my client settings a bit and reset it almost back to default, but the only change that seems to have affected this on that regards is removing admin rights from the client (I had added it years ago). This somehow helped lower the ping from 100-150 to 70-80. But it was still spiking randomly.
    A friend suggested making the client high priority under task manager, so I did and surprisingly, this stopped the spikes.
    I'll report later if this holds.

  • Okay, this is getting out of hand.
    I cannot even introduce this game to my friends without embarrassment given how much it lagging a lot lately.
    The least ArenaNet can do is acknowledge the matter and address it whether it's a client side or server side issue.

  • Unless there is complaints from US players, OCX/SEA and others plea only falls on deaf ears.

  • when do we get a big patch that fixes the performange :( it really is a great game but if it runs so bad with decent specs on your hardware it is just super annoying

  • Jimbru.6014Jimbru.6014 Member ✭✭✭

    I don't usually have lag problems on GW2, but today for some reason I've lagged out of Iron Marches several times. Something's rotten in Ascalon...

  • well... it seems lag gets worse with every intel specre/meltdown patch...

  • Tashigi.3159Tashigi.3159 Member ✭✭✭

    @Sleepwalker.1398 said:
    Unless there is complaints from US players, OCX/SEA and others plea only falls on deaf ears.

    Almost every single US player I've asked about this has reported higher than normal ping and slower TP since some of the recent patches. The problem is that they don't report it, because it's still playable to them. It's a 20-60 increment, when their ping was 40-60 before.

  • Been getting really bad ping spikes. Normally 70 ping. When spikes hit it's anywhere between 300-1000. Getting rather annoyed. Keeps happening. Please fix it. Thanks.

  • The spikes over last few days have been awful and at weird times. For example: when using tp and when swimming in water- anywhere. As soon as I’m back on land I stop yoyo-ing. The tp is awful.

  • you should try playing Thief in PVP now, i'm dead before i even know what hit me...RIP my ranked dreams

  • suddenly i have this similar problem since the christmas patch.... how to fix this

  • yeah 10 min in game, thats winter days for now, no problems til patch, no , as soon a fight is in sight, theres no difference from the game to a photography.

  • @johnny galgos.9832 said:
    suddenly i have this similar problem since the christmas patch.... how to fix this

    Try removing ArcDPS. After the christmas patch I had like 5 fps and really high ping but removing ArcDPS resolved my issue.

  • I'm in the same boat. After Christmas patch my fps is unplayable. I don't run addons. Also, this especially stings because I hate Christmas. Please fix.

  • how do u remove arcdps

  • is anyone else having any FPS issues atm? I was parked in Rata Sum and was getting anywhere between 2-3fps and 5-8 in Divinity's Reach

  • Update: Apparently ARCDPS might be causing it, found some info on reddit on how to remove, here's a link:
    https://www.reddit.com/r/Guildwars2/comments/8rx6b4/how_do_i_remove_arc_dps/

  • For the past month I've been encountering a strange lag. I would get really high ping that wouldn't go away. If I kept relogging (just going back to character screen and back), eventually I would fix it. What's strange is our house have 2 people playing with the same connection. I would lag but he would be fine. So it doesn't seem like it's our internet. What's more strange is if we relog enough times, it fixes itself, BUT if we reinstance, then it's like an RNG where we get the lag back or not. it's been very annoying. I've been having to reenter raid instances or fractal instances several times until i get a "good" login which fixes the lag. The lag is persistent as well so there is no way to wait it out. One more perculiarity is the lag is almost like I'm running on borrowed time. So on my screen it would see like the boss was still alive when it has been dead for 3-4 minutes. Eventually "I" catch up to the real time and boss is dead (even though it's been dead for several minutes). Anyone else encounter similar issues? This seems to be gw2 specific as nothing else is affected. Also, I'm from oceanic region if that matters.

  • Tashigi.3159Tashigi.3159 Member ✭✭✭

    @Steve Tad.4931 said:
    Update: Apparently ARCDPS might be causing it, found some info on reddit on how to remove, here's a link:
    https://www.reddit.com/r/Guildwars2/comments/8rx6b4/how_do_i_remove_arc_dps/

    Not it my man.
    ARCDPS/GW2Hook installed or not, it still happens. The spikes happen suddenly and can range from a mere 200-300 ping to all the way up to 1000+ ping. My normal ping stays around 70-90 (Which in itself is pretty high compared to before; used to be 40-50).

  • Been struggling with the same issues since christmas patch, without arcdps or any other addons. Please help

  • Emprer.7256Emprer.7256 Member ✭✭✭

    I noticed sea ping increased from on avg 200 to 350+ with FREQUENT lag spikes at 1000-3000 ping every 10 minutes since last patch but the whole higher ping began at least 3 weeks ago. Anet can you fix your server?

  • Fluxxar.3692Fluxxar.3692 Member ✭✭
    edited December 18, 2018

    In the last 2-3 hours I have an avg. ping of 600-800ms which makes the game unplayable. Everything else (different game, streaming, speed test) is fine so the issue shouldnt be my internet. I am playing on Eu (Abaddons Mouth) and I am from Germany. Hope this will be fixed soon no matter what the exact issue is.

    Didnt want to open a new discussion for this since one already exists.

    EDIT: Still the same issue, avg Ping 300-400 with spikes up to ~700.

    Edit Day 3: I played for about 2 hours today without any bigger problems besides some lag spikes even though they seem to be my own internet issues. Still dont think the 2 days before today were my internet issues since everything else worked fine.

    Edit Day 4: It gets worse again, higher avg Ping but less spikes or atleast not as high as before. Somewhat playable if you want to get killed by trashmobs a lot of the time and don't want to do anything fun. I was stuck in FFYL for about 30 seconds before I finally died. It is so much fun to "play" like this.

  • @Tashigi.3159 said:

    @Steve Tad.4931 said:
    Update: Apparently ARCDPS might be causing it, found some info on reddit on how to remove, here's a link:
    https://www.reddit.com/r/Guildwars2/comments/8rx6b4/how_do_i_remove_arc_dps/

    Not it my man.
    ARCDPS/GW2Hook installed or not, it still happens. The spikes happen suddenly and can range from a mere 200-300 ping to all the way up to 1000+ ping. My normal ping stays around 70-90 (Which in itself is pretty high compared to before; used to be 40-50).

    Same! It's just so annoying, I've tried EVERYTHING, nothing helps

  • Tashigi.3159Tashigi.3159 Member ✭✭✭

    Getting worse, if that's even possible. This was my average tonight, I am in AZ. Before, I'd rarely see my ping reach higher than 70.
    https://i.ibb.co/y4kSvPD/image.png

  • Same here. Where I usually play with an average ping of 190/200 (from Brazil), my average now is 500/700, with 2 or 3k spikes. It is unplayable. This happened before, and I had to miss the ENTIRE haloween event because of it. I quit the game for about 2/3 weeks, and when I tried again, it was fine. But now it started again. Am I going to miss the Christmass event as well? Please, Anet, this is a SERIOUS issue with your new servers, and this HAS to be fixed NOW.

    PS.: I asked on general chat and a lot more people were experiencing it from other parts of the world (Russia, France, etc).

  • Naxos.2503Naxos.2503 Member ✭✭✭
    edited December 18, 2018

    I froze this Morning immediately on logging in to get my chest today : had a ping of 358, where I usually get 50. I opened my inventory to see if I received my laurels, since my chest was open, but had not disappeared, and I did not. Then a good 3 minutes later, the laurel finally popped in my inventory, the chest disappeared and my ping normalized at 58, while npcs/players around me teleported to where they were supposed to be.
    I'm in France, connecting to the Vabbi server, so this not just an US server issue, it affects EU. I also use No third program of any sort, and this was the first application I launched after my computer booted (no other process is using bandwidth. This is a server to client issue.

    This has been going on since last patch, and makes all high end content and competitive content impossible to play reliably.

  • Azjaqir.9436Azjaqir.9436 Member ✭✭
    edited December 18, 2018

    I play on EU and connecting from Middle East. I have problem loading to instances that start with IP 18.x.x.x. (getting stuck at server_stat_wait)

    The problems started way back when they moved to AWS servers (pre PoF, yeah it's been like that for a year and half) and recently it's much better since they seem added new servers (3.x.x.x) which are fine. 35.x.x.x - 52.x.x.x both are okay for me.

    I don't have latency issues but have problem connecting to 18.x.x.x IPs. Yeah sure VPN can help but it's not reliable for me, not one bit (Disconnects, interruptions and much higher latency).

    I have tried many different DNS servers which helped on some cases like loading time and reducing skills delay, -clientport 443 or 80, run as admin, disabling overlays, port forwarding, changing route and etc... .

    Have submitted tickets before and only gotten responses like, "yeah go ahead and just use that VPN".

    It gets really tiring at this point.

    Edit: Again it's much better since I even had bizarre problems like sudden black screen which probably was a disconnect with game failing to show error message but I hope these servers with IP 18 get sorted out.
    Also it's only guild wars 2 I have these kind of problems with.

    Edit 2: today it seems some of 18.x.x.x instances are working for me and some don't.

  • More than 10 discconections in less than 15 min and 5 at the end of the jp at Divinity's Reach D:
    Please fix it. It's literally impossible to play with +2000 ping. I can't do anything at the game. I play on EU and connecting from Spain.

©2010–2018 ArenaNet, LLC. All rights reserved. Guild Wars, Guild Wars 2, Heart of Thorns, Guild Wars 2: Path of Fire, ArenaNet, NCSOFT, the Interlocking NC Logo, and all associated logos and designs are trademarks or registered trademarks of NCSOFT Corporation. All other trademarks are the property of their respective owners.