Black Screen Randomly No Crash or Error Code — Guild Wars 2 Forums

Black Screen Randomly No Crash or Error Code

Lately I have been getting black screens randomly while playing, still hearing some ambient music, no menus are visible, but I don't get a crash or error code and have to close GW2 from either task manager or the Windows menu bar. The only thing I've changed from the last time I've played without experiencing this was a driver update on an Nvidia GTX 1080. Hoping its just a driver issue but the game was patched a few times since playing on my desktop. Was playing on my laptop with the same drivers on a different graphics card and it had no issues (sli 755m)

Comments

  • If rolling back your drivers doesn't alleviate the issue, you can contact the Tech CS Team via the 'Support' link below, and 'Submit a Ticket' for assistance.
    Also, you can try disabling/removing any 3rd-party programs you might be using.

    Good luck.

  • I had an old computer that did that a few times. I just got a diff computer.

  • Healix.5819Healix.5819 Member ✭✭✭✭

    There's a type of black screen where GW2 basically thinks you're disconnected, but you're actually not, so it doesn't display the connection error message. On this type of black screen, you can press F12 to open the logout menu, showing that it's still actually running. This can be caused by packet loss or anything else interfering with your connection. Try running the game on port 80 or 443 (Gw2.exe -clientport 80) or using a VPN.

    For the GPU type of black screens, either your monitor would turn off / lose its signal, or your entire screen would go black for a few seconds as Windows tries to recover.

  • New updates and new drivers seem to have stopped this issue for me. Haven't tried playing 3+ hours like when I was trying and having the issue, but it was limited to GW2 since other games I marathon and had no issues. Hopefully the conflict between the game and drivers/card are gone for now.

  • Sorry to post again in a row but just did guild missions and it happened 4 times in 45 minutes. Kind of frustrating when my laptop works fine but my desktop is having issues. I just wish it would throw an error code XD I'll try the port.

  • DeWolfe.2174DeWolfe.2174 Member ✭✭✭

    Been having a similar issue since, as best as I can recall, mid April when the Windows 10 creators update came out. There was also the 4/18 game update too and that was the earliest recorded issue in the windows event viewer. Didn't get any help from the dev's and it seems no one knows exactly what causes this. It's an Nvidia driver/Windows/GW2 issue that'll we'll have to wait for them to fix.

    I'll just copy and paste from another thread:
    Download the new Nvidia drivers and have them ready, then use DDU to uninstall Nvidia Drivers. You can google how to use DDU and where to download it.
    After the video drivers are done, delete the audio drivers. Try out the windows drivers to run the audio.
    Then clear the GW2 cache by deleting the GW2cache folder in (C:>Users>your windows account name>AppData>Local>Temp>gw2cache)
    Next is the local.dat file by going to (C:>Users>your windows account name>AppData>Roaming>Guild Wars 2>local.dat)
    Note: When you start GW2 you will have to type in your user name and password in the GW2 launcher again. Also, reset some user preferences in GW2. Most are saved in the cloud.

    You can also try turning down the clock on the 1080. I'm going to guess you have it OC'd or factory OC'd. Turning it down slightly may help. I turned mine OC down by just 50mhz and it helped. I used EVGA Precision since it's an EVGA card. Use whatever tuning software your vendor gave you with the card purchase.

  • Hello,

    I have the same Issues but only if I select a Character being on a map from HoT or PoF.
    Tried nearly everything and the Eventlock says:

    Failed to Load \Driver\WUDFRd for Device ACPI\PNP0A0A\2&daba3ff&0

    This should be a mainboard Issue and I tried to solve the problems with the help of other forums, but haven't to manage solve the problem.

    What I've done so far:

    2x Clean Win 10 64Bit installation
    Memory Tests and MHz reduction
    Bios Update
    CPU Limitation 2 Cores and frequency
    Old Graphiccards driver installed
    turn off Hibernation and pagefile
    GPU-Z and CPU-Z temperature check (everything is fine)
    GPU underclocking

    My System:

    Windows 10 Pro build: 15063
    Intel(R) Xeon(R) CPU E3-1241 v3 @ 3.50GHz Intel586
    ATI MSI Radeon R9 290x
    8Gb Kingson HyperX
    Thermaltake Smart SE 730W
    Asus ROG MAXIMUS VII RANGER
    256GB SSD and 3x 2TB SATA HDD (Installed it on all other Harddrives, but same error)

    But sometimes I managed to select a Character being on maps from the addons... Thats the case in about 1/30 times and than I can play the game like 30 minutes- 3 hours without crashing.

  • "It's an Nvidia driver/Windows/GW2 issue that'll we'll have to wait for them to fix."

    No, it isn't. I've been running the Windows 10 [64 bit] creators edition since before it was even a public release. I have a Gigabyte factory overclocked Nvidia GTX 1060 (3 GB). I'm running the Nvidia 382.53 drivers. I have dual 1080P monitors, but I only use one for gaming. I run the GW2 graphics settings all on highest with the following exceptions:

    Shadows: Low
    Reflections: Terrain and Sky only
    Character Model Limit: Low
    Character Model Quality: Low
    Light Adaptation: Off

    I can play GW2 for hours. I have no crashes, no black screens, no shut-downs - ever - with GW2 or any other game. BTW, if you have to down-clock your GPU to make your system stable - you have a hardware failure problem.

  • DeWolfe.2174DeWolfe.2174 Member ✭✭✭

    @abomally.2694 said:
    "It's an Nvidia driver/Windows/GW2 issue that'll we'll have to wait for them to fix."

    No, it isn't. I've been running the Windows 10 [64 bit] creators edition since before it was even a public release. I have a Gigabyte factory overclocked Nvidia GTX 1060 (3 GB). I'm running the Nvidia 382.53 drivers. I have dual 1080P monitors, but I only use one for gaming. I run the GW2 graphics settings all on highest with the following exceptions:

    Shadows: Low
    Reflections: Terrain and Sky only
    Character Model Limit: Low
    Character Model Quality: Low
    Light Adaptation: Off

    I can play GW2 for hours. I have no crashes, no black screens, no shut-downs - ever - with GW2 or any other game. BTW, if you have to down-clock your GPU to make your system stable - you have a hardware failure problem.

    You can play it with an entirely different rig! Sure, I can run my computer on every other piece of software for hours on end without the slightest issue too. It's only playing GW2 on my OC'd Nvidia card that a hiccup occurs. Tuning the OC down to a slightly less of an OC is not a "hardware failure" either. Especially when I can jack it up further on every other piece of software I've tried. If you Google the issue you'll find it's been happening on and off for almost a decade. Solutions are mostly around properly uninstalling/installing drivers to changing the power management setting in the Nvidia Control panel to maximum performance or adding some voltage.

    For GW2, memory leaks are a known issue and causes crashing too. That's why clearing out the cache is a good idea from time to time.

    For mentioning Windows 10 Creators update, that's because it can trigger windows into installing the latest drivers. Those drivers may be incompatible with the combination of components in our computers. So it's important to look back and see when updates occurred.

  • No. Windows 10 has been out long enough that the drivers are stable, provided that your hardware isn't 10 years old. In fact, that's one thing Windows 10 got right. Yes, sometimes graphics drivers have issues, but Nvidia is pretty good about including that information in the release notes.

    If the problem was caused by a combination of incompatible drivers, the system would crash as soon as they were installed - not cause random black screens. A "bad" audio or network driver won't cause this. The Nvidia errors in the log files are a dead giveaway that it's the GPU failing.

    Good luck.

  • "Failed to Load \Driver\WUDFRd for Device ACPI\PNP0A0A\2&daba3ff&0"

    This is probably just a Windows timeout error and can be safely ignored. You can test this by setting the computer to sleep or hibernate. If sleep/hibernate work - then the ACPI driver and associated hardware is working.

  • Did Brosef's problem ever get fixed? I have exactly the same problem, tried divers, repairing the data file, turning off antivirus and firewall, nothing helped.

  • Hi all, I'm also having the same issue but I'm on a Mac. Any help would be appreciated.

  • It's been happening to me and I suspect it's a network issue mainly because I usually have issues logging back in after such a black screen. It goes to character select and then as soon as I choose a character it kicks me out.

  • This issue has been happening to me since April 2016, a random blackscreen with the environment music as background. I have tryed way too many options without any success, for example:

    I tryed fixing the game with the fix command.
    I tryed reinstalling the game
    I uninstalled, cleaned and fully reinstalled the game
    I updated my Graphics Card drivers (It was an AMD back then)
    I updated my Windows drivers
    I did port forwarding for ports 80 443 6112 and 6600
    I reduced the firewall security options
    I disabled the firewall
    I got a new Graphics Card, even from a different brand (Nvidia 1070)
    I got a new processor
    I updated and got more RAM
    I changed my router
    I even changed my Internet Service Provider for a different company

    After 2 long and annoying years, that have ruinned every little piece of interest I had in GW2, none of the above have helped or fixed the issue.

    I contacted GW2 Support which was a total waste of time, they answer tickets too slow, 1 week for a basic response that only shows that the help desk engineer does not even try to read and understand the case, only getting predetermined answers.

    I've lost any hope in Anet as a company, they just don't care about their customers, and after all what I have attempted, I'm confident that the issue is not on my end, but I am also sure that Anet team wont try to do anything as well.

  • Nilo.7309Nilo.7309 Member ✭✭
    edited May 15, 2018

    same issue here too.
    I bought gw2 in pre-release, love this game. I decided to come back to gw2 with some new friends (new players in free to play) this year and I cant play with then becouse of this bug.
    I format and reinstall gw2
    change monitor, cables
    tried network fix, tcp ports open, disable firewall, etc
    take off my gtx770 and run game onboard, same issue

    and still the same problem. couple of minutes of gameplay and monitor lose signal, but can still listen the game running.
    wanna play this awsome game but I cant...

  • Having same issue, it seem like this issue is not uncommon? It's been on going for years, but no solution?
    Been playing fine without any issue for a couple of years and suddenly, keep having black screen, but music playing on background and mouse cursor moving.
    Tried all above solutions, none worked.
    Sent complain to arena net, no reply, no response. Who should we go to? What can we do if no solution /guide being given?
    We would like to continue playing this game, becuase we like it, and this is ruining our gaming experience... At least an administrator reply to this thread please?

  • Inculpatus cedo.9234Inculpatus cedo.9234 Member ✭✭✭✭

    Did you submit a ticket to the Tech CS Team via the web-form accessed through the 'Support' link above/below?
    Do be aware, due to high volume ticket responses are running longer than usual.

  • Yes I have, indeed I have submitted through game as well :(

  • Nilo.7309Nilo.7309 Member ✭✭
    edited May 16, 2018

    Ticket for bugs like this one they ignore or say the problem is hardware or os...bunch of people with this problem since 2014 and they do nothing

  • SlippyCheeze.5483SlippyCheeze.5483 Member ✭✭✭✭

    @Nilo.7309 said:
    Ticket for bugs like this one they ignore or say the problem is hardware or os...bunch of people with this problem since 2014 and they do nothing

    Well, in fairness, people have had broken computers, and dodgy networks, since 2014 as well, so ... you may be describing the apparent response to these, but it would also describe the behaviour of a company that have correctly identified that they can't solve broken computers in software.

    Anyway, I'm very sorry you have this problem, and that you can't find a solution. I hope you can find another game that you enjoy equally.

  • Nilo.7309Nilo.7309 Member ✭✭
    edited May 16, 2018

    @SlippyCheeze.5483 said:

    @Nilo.7309 said:
    Ticket for bugs like this one they ignore or say the problem is hardware or os...bunch of people with this problem since 2014 and they do nothing

    Well, in fairness, people have had broken computers, and dodgy networks, since 2014 as well, so ... you may be describing the apparent response to these, but it would also describe the behaviour of a company that have correctly identified that they can't solve broken computers in software.

    Anyway, I'm very sorry you have this problem, and that you can't find a solution. I hope you can find another game that you enjoy equally.

    Do you read only this last post right? I bought new GPU, cabe, run onboard, tried all network fix, firewall, Format Pc... Is this kind of behavior that you have that make us angry. U and anet dont even try to read all history, try to understand, think i'm a Noob. This problem is so old in foruns and in my Pc, If im telling u is becouse I tried EVERYTHING before came here

  • SlippyCheeze.5483SlippyCheeze.5483 Member ✭✭✭✭

    @Nilo.7309 said:

    @SlippyCheeze.5483 said:

    @Nilo.7309 said:
    Ticket for bugs like this one they ignore or say the problem is hardware or os...bunch of people with this problem since 2014 and they do nothing

    Well, in fairness, people have had broken computers, and dodgy networks, since 2014 as well, so ... you may be describing the apparent response to these, but it would also describe the behaviour of a company that have correctly identified that they can't solve broken computers in software.

    Anyway, I'm very sorry you have this problem, and that you can't find a solution. I hope you can find another game that you enjoy equally.

    Do you read only this last post right? I bought new GPU, cabe, run onboard, tried all network fix, firewall, Format Pc... Is this kind of behavior that you have that make us angry. U and anet dont even try to read all history, try to understand, think i'm a Noob. This problem is so old in foruns and in my Pc, If im telling u is becouse I tried EVERYTHING before came here

    I did read your post, yes. We seem to be talking about different things: if ANet support seem to be treating this like it might be a hardware problem, that is most likely because their experience says it is a hardware problem.

    Anyway, if you tried literally everything already, I have nothing further to offer -- obviously -- so I wish you the very best of luck.

  • Me too Nilo, I tried a lot of things before coming here :(
    I changed my ISP - not fixed
    Changed my router settings - not fixed
    Get a new router - not fixed
    DDU all driver and reinstall drivers - not fixed
    Updated drivers - not fixed
    Get a new graphic card - not fixed
    Windows 10 update - not fixed
    Reinstall the game- not fixed
    delete .dat and re-patched -not fixed
    use -repair on my gw2.exe - not fixed
    use -windowed on my gw2.exe -not fixed
    use -port 80 - not fixed
    connect through VPN- not fixed
    Open up my PC and give a vacuum blow - not fixed
    updated and got more RAM - not fixed
    disabled fire wall - not fixed
    get a new anti virus - not fixed

    having said so, whenever I can login (for 10 - 15 minutes windows before the crash) I try to play and enjoy the game.
    If i'm lucky i get to finish 1 ranked pvp, or else I crash and lose ratings... now my rating drop down to 1560? to 1580? ish :(
    People in my team keep saying I'm win trading because I keep dc due to this black screen, and couldn't convince them that I wasn't.
    This sesason is finishing and I'm looking forward to be in the top 100 but doesn't seem to be possible now i think...sigh!
    Even looking forward to the monthly tournament too....

  • Heartless.8320Heartless.8320 Member
    edited May 25, 2018

    Same problem and anything can't solve that kitten.
    I've done everything you're made too

  • Nothing from Anet them self on this?

  • Ashantara.8731Ashantara.8731 Member ✭✭✭✭

    @aandiarie.7195 said:
    I had an old computer that did that a few times. I just got a diff computer.

    Buying a new computer upon every encounter of an issue cannot be regarded as a solution. ;)

    "What good is battle prowess when you are too dead to make use of it?" - Draco Ud Verik (Human Ranger) | Guild: Order of the Ebon [Hand]
    . My GW2 content charts: (1) LWS 4, (2) PoF , (3) Personal story (pre-Claw Island/Orr) , (4) LWS 2 , (5) HoT, (6) Orr campaign , (7) LWS 3

  • aandiarie.7195aandiarie.7195 Member ✭✭✭

    After you installed everything did you update the drivers properly? Also are you a 32 or 62 bit client and are you set to max settings for visual stuff in game?

  • after a Windows 10 update, about a week ago, every time I try to launch the game, I would get a tab that would say , Untitled, but it is after I log in and the ready tab is clicked. I did the reair option, turn off the Nvidia capture option, and uninstalled and reinstall the game couple of times, and still have that same problem. any suggestions?

  • If you have the issue where you get a sudden black screen but you can still open menus, specifically the F12 log out dialogue, then it's a network issue. I get the issue from time to time, usually for a month or so and then it disappears for a long while. Either it's instability in connection on Anet's end or something on my end, likely Windows Updates or wireless interference that cause it.

    One solution is to set your client port to 80 or 443, as someone else mentioned. Another is to try going to an ethernet connection if you're on wireless, if possible.

    Another is to check for updated network adapter drivers.

    This is a different issue to losing a monitor entirely, that's a graphics card problem. Either driver or hardware related.

  • Does anyone else notice that when the screen goes black it makes the sound like it’s going into a cut scene?

  • cobbah.3102cobbah.3102 Member ✭✭✭

    I had similar problems repaired client and it seemed to have fixed that and disconns

  • @slay.7582 said:
    This issue has been happening to me since April 2016, a random blackscreen with the environment music as background. I have tryed way too many options without any success, for example:

    I tryed fixing the game with the fix command.
    I tryed reinstalling the game
    I uninstalled, cleaned and fully reinstalled the game
    I updated my Graphics Card drivers (It was an AMD back then)
    I updated my Windows drivers
    I did port forwarding for ports 80 443 6112 and 6600
    I reduced the firewall security options
    I disabled the firewall
    I got a new Graphics Card, even from a different brand (Nvidia 1070)
    I got a new processor
    I updated and got more RAM
    I changed my router
    I even changed my Internet Service Provider for a different company

    After 2 long and annoying years, that have ruinned every little piece of interest I had in GW2, none of the above have helped or fixed the issue.

    I contacted GW2 Support which was a total waste of time, they answer tickets too slow, 1 week for a basic response that only shows that the help desk engineer does not even try to read and understand the case, only getting predetermined answers.

    I've lost any hope in Anet as a company, they just don't care about their customers, and after all what I have attempted, I'm confident that the issue is not on my end, but I am also sure that Anet team wont try to do anything as well.

    ive been having this issue across 2 entirely different systems too. super annoying. this literally ONLY happens with gw2. can play any other game or software with no issue at all. i don't get it :(

    event viewer says it might be an issue with ntdll.dll in system32... but ive tried all fixes for that too and still have the issue. the crashes make me quit playing this game so often

  • Aigleborgne.2981Aigleborgne.2981 Member ✭✭
    edited July 31, 2018

    @Healix.5819 said:
    There's a type of black screen where GW2 basically thinks you're disconnected, but you're actually not, so it doesn't display the connection error message. On this type of black screen, you can press F12 to open the logout menu, showing that it's still actually running. This can be caused by packet loss or anything else interfering with your connection. Try running the game on port 80 or 443 (Gw2.exe -clientport 80) or using a VPN.

    For the GPU type of black screens, either your monitor would turn off / lose its signal, or your entire screen would go black for a few seconds as Windows tries to recover.

    This is exactly what I am getting with my average connection in my holidays house. Black screen but F11 or F12 still works.
    I know my connection is bad, very bad location for internet.
    When I use my phone shared connection, no more black screen ! And my phone is only in H+ on this location.

©2010–2018 ArenaNet, LLC. All rights reserved. Guild Wars, Guild Wars 2, Heart of Thorns, Guild Wars 2: Path of Fire, ArenaNet, NCSOFT, the Interlocking NC Logo, and all associated logos and designs are trademarks or registered trademarks of NCSOFT Corporation. All other trademarks are the property of their respective owners.