Can you please fix the client failure — Guild Wars 2 Forums

Can you please fix the client failure

Egrimm Van Horstmann.7921Egrimm Van Horstmann.7921 Member ✭✭✭
edited December 3, 2017 in Account & Technical Support

Every NVidia update and the GW2.exe cannot be found? And yet every time I start it from the file location it has to reload all 440,000 files. From all the sources I've found online, it has to do with your end that this is a constant nuisance. This will be the third time in a 4 week period I have to reload the 440,000 file client. It's not just mind numbing it's downright frustrating that for massive amounts of time I have no access the game at all.

Comments

  • Illconceived Was Na.9781Illconceived Was Na.9781 Member ✭✭✭✭
    edited December 3, 2017

    First, regardless of anything you learn here, start a support ticket. You'll get individual attention from the folks at ANet who can actually help and potentially do something about any issue.

    Second, you say this is a problem on GW2's end, but I've gotten NVidia updates and not had this trouble. Could you be more specific about what steps you take just prior to encountering this issue? What are the sources that claim it's an issue on ANet's end? How are they sure it's not specific to certain computers or to NVIDIA?

    Or if you want to skip that:

    • In what folder is your GW2.exe located?
    • Is it possible you have more than one folder?
    • What do you use to start up GW2? A shortcut? The windows menu?
    • Have you tried eliminating all the existing shortcuts and creating a pristine one using your main installation folder?
    • Have you tried clearing out your cache and/or repairing your client?

    Hype is the path to the dark side. Hype leads to unfulfilled expectations. Disappointment leads to anger. Anger leads to disgust. Disgust leads to "oh, new shinies! I'm back!"

  • Basically the app, shortcut, and even going directly to the file all give me an error (that file has moved or app needs a version for your computer). Every time this happens, NVidia has a driver update. After updating driver running the Gw2.exe downloads the whole client all over again. File was located in C:

    Didn't have this problem until about three months ago, ever since any Nvidia update requires a downloading the whole client. Given every other app and program never encounters this problem, it actually makes sense something with the client is at fault. The only GW2 file that can run is Setup. Have to scrap old shortcut to create a new one for the current working client.

  • Healix.5819Healix.5819 Member ✭✭✭✭

    So after updating your NVidia drivers, GW2's shortcut becomes invalid? Have you tried looking in the folder where GW2 was installed and tried searching for Gw2.dat before running Gw2Setup?

    GW2 isn't deleting itself, nor should a standard NVidia driver update. If you're running Windows update or causing a system restore, it'll move certain executables. If you're installing GW2 to a temporary folder, it'll always be deleted, eventually.

    For a simple test, create a "Guild Wars 2" folder right on your desktop, place Gw2Setup.exe into it and rename Gw2Setup.exe to Gw2.exe. Running Gw2.exe will cause it to install directly to this folder. You can move Gw2.dat from your current install location to this folder to speed things up. After your next NVidia update, look in this folder. If there's no Gw2.exe, rename Gw2Setup.exe and put it back. If there's no Gw2.dat, you have bigger problems. If Gw2.dat exists, but the game is fully downloading, something is either corrupting the file or your drive could be failing.

  • GW2.dat wasn't in the Temp folder, strangely the shortcut creates as a temp no matter where it's put and I can't seem to change it's type.

    For a little clarity even going to the client directly avoiding the shortcut, I was getting the error that the computer can't run the program without the right app. And no this was not a tagged as a temp file or in the temp folder.

    Also there is only one copy of the file as far as I can tell. Next time I'll run the repair, but it's loaded and running now. My computer is really good, I don't have much on it beyond the normal security measures.

  • I think you should start by doing some malware/virus scans - something very strange is going on with your system.

  • I do those every day. Wouldn't do anything online without them.

©2010–2018 ArenaNet, LLC. All rights reserved. Guild Wars, Guild Wars 2, Heart of Thorns, Guild Wars 2: Path of Fire, ArenaNet, NCSOFT, the Interlocking NC Logo, and all associated logos and designs are trademarks or registered trademarks of NCSOFT Corporation. All other trademarks are the property of their respective owners.