Game adds English US keyboard layout — Guild Wars 2 Forums
Home Bugs: Game, Forum, Website

Game adds English US keyboard layout

Hello

I have a strange problem which i haven't run into with ANY other program/game i've used in my computer and it's quite frustrating. Whenever i launch the game, it keeps adding an English (US) keyboard and EVERYTIME i have to go into the Windows settings and delete it. I used an English (UK) keyboard layout and this game messes up things whenever i want to write since i tend to switch between English and Greek (my mother tongue).

I had asked help from the technical support in the past (opened a ticket etc) but i was told that it's my Windows 10 installation that kept doing it and that the game uses the default language that is installed in it.

Well, i reinstalled Windows 10, the UK version and the problem STILL EXISTS.

Does anybody have the same problem with me and if yes, is there a proper solution to this?

Thank you in advance

Comments

  • There have been some other posts/threads about this issue. You might be able to find them with the 'Search' function; I don't remember if there was a solution posted.

    Good luck.

  • The search option doesn't link anything that's useful actually :(

  • Orimidu.9604Orimidu.9604 Member ✭✭✭

    In Windows 10, by default, pressing CTRL+SHIFT (or for some ALT+SHIFT) will cycle through any keyboard layouts that you might have mapped and it's surprisingly easy to do this by mistake.

    If you keep pressing CTRL+SHIFT (or whatever you might have changed it to) then soon you should get back to the correct setting. (alternatively reboot which is what I did first time ;-) )

    You can disable this default keyboard action as follows:

    Control panel > Language > Advanced settings > Switching input methods > Change language bar hot keys

    Be warned, the above doesn't always work - Restarts and Sleep mode can both change keyboard default (usually to US) - I've found no cast-iron solution though creating a new profile can help, though not a particularly satisfactory answer IMHO.

    ~~Copied from https://superuser.com/questions/976947/keyboard-language-keeps-changing-in-windows-10

  • I'm having the same issue - I've disabled the option to swap keyboard layouts, but the main thing that's annoying is that even though I can set the Notification off, it keeps turning it back on.

  • I have the same problem as you. It's quite frustrating because I'm already switching between french keyboard layout and Japanese for my work. Whenever I'm playing and exiting Guild Wars 2, I have to restart my computer so I don't get annoyed with another keyboard layout.
    My guild wars 2 game is in english so maybe that's why it's doing this.. I don't know !

    Whatever, I hope there is a solution to this problem.

  • I just emailed technical support about this they told me to submit a bug report to the forums. Bit ridiculous how it has been happening for so long though.

  • Any updates on this?

  • Any updates on this?

  • @SomeT.7892 said:
    Any updates on this?

    It's a windows problem, not GW2. You can change the settings in Windows to remove any keyboard shortcut for adjusting the keyboard option. It is one of the first things I do with any new computer.

    Hype is the path to the dark side. Hype leads to unfulfilled expectations. Disappointment leads to anger. Anger leads to disgust. Disgust leads to "oh, new shinies! I'm back!"

  • It is not a Windows problem, if it is please provide evidence of this? I do not have USA English installed at all on my system what so ever, and I refuse to have it forced upon my system.

  • I agree it isn't a Windows problem (though Windows exacerbates the issue).

    GW2 is installing a en-US keyboard when it's launched (from my testing, once you pass the character selection screen), which adds the language bar etc. Most of the language bar functionality and settings can probably be hidden through settings, though to hide the item from my task bar I have to turn on a 'desktop switcher' which I can't see, so I don't really know what I'm doing there. Instead I leave it in the tray, as at least it's a known quantity.

    The reason Windows (10 anyway) makes this worse is there's an unremovable binding for "WIN+SPACE" to switch system languages, which means once GW2 has added en-US, that key combination will swap you between it and your preferred language (en-GB in my case). A "workaround" which uses an AutoHotKey application is described here (https://superuser.com/questions/1000678/disable-winspace-keyboad-layout-switch-in-windows-10?rq=1) but I haven't tried it, as from my understanding it needs to be constantly running to intercept the hotkey to prevent it doing anything.

  • Shikigami.4013Shikigami.4013 Member ✭✭✭
    edited December 29, 2018

    If GW2 did install this every time it launched everybody would have this problem. They don't.
    There are a total of 7 PCs having GW2 installed in my house and only one of them has Win10, and that was the only one it ever happened on. I was annoyed by the useless language icon in the taskbar so I uninstalled the US keyboard layout and it was gone - and never returned.

    I did not have to use any workaround or permanent program, nor do I ever use any windowskey combination because I hate the windowskey and several of my keyboards are ancient and do not even have one for that reason.

    Also, if it wasn't a windows issue, pages like the following link wouldn't exist, I think this one is a lot more helpful than the link above my post:
    https://superuser.com/questions/1103532/how-to-hide-the-eng-language-icon-in-notification-area-windows-10

    YouTube “L2villagejester”.
    People using belittling wording like whining/qqing" are not taken seriously by me
    Same for people posting only to tell others not to post (“deal with it”-posts)

  • I don't think modifying windows is the way to go imo, this is a issue with GW2 and it needs sorting, I advise we post on the bug report I posted to gain the right attention for it to be fixed: https://en-forum.guildwars2.com/discussion/64138/bug-report-see-this-forum-post-been-going-on-for-a-long-time#latest

  • Merging threads

  • edited January 3, 2019

    Please do not create a new post, but update the existing thread to request an update.

  • Ashantara.8731Ashantara.8731 Member ✭✭✭✭

    Have you tried setting the language options for both, text and audio, to your desired language, then remove the English keyboard layout from your Windows settings?

  • SomeT.7892SomeT.7892 Member ✭✭

    @Ashantara.8731 said:
    Have you tried setting the language options for both, text and audio, to your desired language, then remove the English keyboard layout from your Windows settings?

    Yes I have tried this and it still does not work.

  • Reviving this old thread to post a solution I was able to come up with, after struggling with this problem for a long time.

    Navigate to your GW2 installation folder and create a new empty text file. Name it KBDUS.dll. Make sure the extension actually changed.
    Next, right click the file and go to Properties > Security > Advanced > Disable Inheritance, and pick Remove all inherited permissions from this object. The goal here is removing every user's permissions from accessing the file at all.

    Here's an example screenshot.

    After all that's done, start GW2 again. It shouldn't add the US keyboard layout anymore.

    If you ever need to delete that KBDUS.dll file, you will have to restore the file's permission inheritance first (follow the same steps, the button to disable inheritance will have changed to enable inheritance).

  • 7 years, 4 months and 6 days. Give this human a medal!

  • Dante.1763Dante.1763 Member ✭✭✭✭

    @Foxgod.1038 said:
    7 years, 4 months and 6 days. Give this human a medal!

    Whats sad is nobody including anet came up with an answer in that time.

    Is there someway to get this stickied or put in the FAQ page of support?

    Amana Silentchild; My Main
    Ember Wandertooth; The Kingslayer, Kianda Redpaw; The Blazing Light
    Why GW is Called Guildwars

  • Has Win10 been out 7 years 4 months and 6 days?

  • Sorry to resurrect an old thread but I installed GW2 yesterday and I'm having the same problem, I live in the UK and use a UK keyboard and Windows 10 is set to use UK language, and after exiting the game I noticed it had put the switch input methods icon on the taskbar. I used to play GW1 and it did the same thing in that game too. I would have thought that someone would have fixed this by now.

  • Adding an empty KBDUS.dll works fine to solve this issue. Just beware that it will reset your keybindings in game.

  • @Zeeg.7340 said:
    Adding an empty KBDUS.dll works fine to solve this issue. Just beware that it will reset your keybindings in game.

    Thank you, I will give that a try, I'm not too worried about the keybindings as I've not played it much yet as I wanted to see if I could solve this problem first.