Is anybody else experiencing API difficulties following the 1/9 patch? — Guild Wars 2 Forums

Is anybody else experiencing API difficulties following the 1/9 patch?

I'm a bit confused. I use GW Efficiency to monitor my trading post activity via my API key. It's only picking up listings placed prior to the 1/9 patch and nothing more recent. Is this happening to anyone else?

Comments

  • Tanner Blackfeather.6509Tanner Blackfeather.6509 Member ✭✭✭✭
    edited January 12, 2018

    It shows listings from today just fine for me...

  • Wanze.8410Wanze.8410 Member ✭✭✭

    same problem here, current transactions and transaction history was last updated on the 9th for me.

  • On a second check - no something is wonky, it's missing some of my sell listings from the last few hours!

  • Have you tried posting in the API sub-forum? That used to be watched pretty closely by the API Dev.

  • My new buy orders aren’t showing either.

    Be careful what you ask for
    ANet might give it to you.

    Forum Guides: Images. Text

  • Khisanth.2948Khisanth.2948 Member ✭✭✭✭

    Looks fine to me. Just added a buy order to check 6 minutes ago and now it has appeared. Checking on gw2bltc.com

  • Neutra.6857Neutra.6857 Member ✭✭✭
    edited January 12, 2018

    I am also having the same problem. Though things are showing up in my delivery box, the current transactions are not showing properly. Some of my buy orders that have already been completed are still showing up in my current transaction buy order list. (It is funny since the current price is lower then what I bought it at).

  • Update: I'm still having this issue. I've cross-posted to the API forum in hopes of getting an Anet Dev response. The GW Efficiency team is convinced this is an API key problem and not on their end.

  • shopt.1730shopt.1730 Member ✭✭
    edited January 14, 2018

    I've hit the API directly and reproduced the bug. It's definitely happening in the GW2 API and not any downstream consumers.

  • @shopt.1730 & @Wanze.8410 : Thanks for looking into it, and for bumping the post in the API forum. I'm not very tech-savvy, so I'm pretty helpless when my toys break. I enjoy crafting and playing the market most of all in MMORPGs, and the lack of nifty e-tools to manage my GW2 trading post empire is seriously cramping my style. :P

  • Khisanth.2948Khisanth.2948 Member ✭✭✭✭

    Maybe it's specific to the EU side? Mine is on NA.

  • Neutra.6857Neutra.6857 Member ✭✭✭

    @Khisanth.2948 said:
    Maybe it's specific to the EU side? Mine is on NA.

    Nope I am NA and having an issue.

  • Update: I filed a support ticket trying to get some help on this, and I just received the following response:

    Hello,
    Thanks for contacting Guild Wars 2 Support!
    I would recommend you post your issue to the API development forum here: https://en-forum.guildwars2.com/categories/api-development
    The API developers as well as other players read this forum daily resolving issues and providing API support! :)

    If you have any questions or need further assistance let us know!
    🐦 SQUAWK! 🐦
    Regards,

    GM Griffon
    Guild Wars 2 Support Team

    I'd already done this at @Inculpatus cedo.9234 's helpful suggestion. Could anyone who hasn't already putter down to the thread on the API forum and wave at the devs so they see there's a whole group of us?
    https://en-forum.guildwars2.com/discussion/24380/api-issue-following-1-9-patch#latest

©2010–2018 ArenaNet, LLC. All rights reserved. Guild Wars, Guild Wars 2, Heart of Thorns, Guild Wars 2: Path of Fire, ArenaNet, NCSOFT, the Interlocking NC Logo, and all associated logos and designs are trademarks or registered trademarks of NCSOFT Corporation. All other trademarks are the property of their respective owners.