Ordnance-Outpost-Event chain - BUGGED — Guild Wars 2 Forums
Home Bugs: Game, Forum, Website

Ordnance-Outpost-Event chain - BUGGED

Outside of the fact this event rarely completes because so few folks are ever available when I've been trying to complete this event, tonight it was even worse. The bomb parts portion is bugged. From what folks were saying in chat, it seems this part never gets finished because of the issue with it either not having enough time to get all the parts to the npc or he refuses to accept said parts like tonight. Drop them at his feet and he just does not pick them up....never accepts the parts.

So Anet, how are we supposed to obtain this one item for the legendary collection Nevermore I: Ravenwood Branch when we can never complete the event? This is something I think you need to revisit and see about fixing. It would also be a good idea to review the problems inherent with the event being so cumbersome that we run out of time for the bomb parts and never finish it because of bugs like this. There really needs to be a way for this drop to be available in another way. Having it gated behind a single meta event and having that last bomb part fail consistently, is poor design.

Please fix this problem. I'll never be able to advance to the next collection segment because I can't obtain this one drop. My discussion on this topic is here: https://en-forum.guildwars2.com/discussion/29248/ordnance-outpost-event-chain-to-destroy-the-blighted-tree-in-the-corpse-grove-bugged/p1?new=1



  • Update: Oh this is really ridiculous...Anet, I just found out that one of my guild mates actually experienced this very same bug 2 years ago>>>Two Years? How have you not fixed this yet?

    He stated: "I ran into the same issues when I was working on that collection. (Like 2 years ago) There didn't seem to be any indicator of when that NPC bug would happen, or why sometimes after a bit some people would be able to turn in the items. "

  • Can we please have an Anet post on this problem? I would like to be able to progress to the next stage in my acquiring of Nevermore, but can't because of this last item in the first segment being impossible to obtain with the current bugs in the event. I really would appreciate someone at Anet dropping in to offer help with getting this problem resolved.

  • I am asking about this today. I may not get an immediate reply, but the question is with the QA Team and I feel sure they'll get back to me -- or will post -- when there's info to share.

    Gaile Gray
    Communications Manager: ArenaNet
    Fansite & Guild Relations; In-Game Events; Community Showcase Live

  • lynspottery.6529lynspottery.6529 Member ✭✭✭
    edited February 26, 2018

    Thank you very much for your response. I am hopeful issues with this can be resolved in a way that makes obtaining this single drop for Nevermore 1: Ravenswood Branch much better, in order to proceed with this legendary staff collection.

  • Did this with group a couple of days ago. Three people couldn't turn materials into the guy unless we tried multiple times (Throwing it at him generally didn't do anything). On another account I was able to turn in bomb parts 100%. It's a fun event but definitely don't think it would be easy to solo or do with a few friends.

  • Bloodstealer.5978Bloodstealer.5978 Member ✭✭✭✭
    edited February 26, 2018

    I did it today.. got achievs an all.. cant believe I missed them so long ago.. so went back and got it without any hassles.
    The only issue is Belly the scrap supplies chap can be a pain to talk to you and hand the parts in.. but he does switch from greet to talk, just have to be patient with him.

    Life is what YOU make it... NOT what others tell you!

  • That npc was not friendly to my attempts to turn parts into him every time I attempted this, therefore, I have left it alone and bugged it. I am hopeful the devs are able to get this fixed so that we don't have to "hope" he will take the parts given to him.

  • Ayrilana.1396Ayrilana.1396 Member ✭✭✭✭

    The NPC does eventually accept your parts if you keep trying.

  • @Ayrilana.1396 said:
    The NPC does eventually accept your parts if you keep trying.

    "Eventually" being the operative word. Every time I tried this event, we ran out of time because of the issue with the npc not accepting parts. So the time is what eventually caused the failure of the event even when we were trying to throw parts at this npc...

  • edited February 27, 2018

    I promised an update, and here it is: This bug has been reviewed and confirmed. It now officially is on the "To Be Fixed" List, and the team will be addressing it as soon as they're able to do so.

    Thank you very much for the reports. Also, thanks to those of you who shared the idea for people to try again, because it's good to know that sometimes, that sometimes works! However, that is not the optimal situation and this bug will be corrected so that NPC doesn't act coy about making exchanges. :D

    Gaile Gray
    Communications Manager: ArenaNet
    Fansite & Guild Relations; In-Game Events; Community Showcase Live

  • Thank you very much.

  • lynspottery.6529lynspottery.6529 Member ✭✭✭
    edited March 4, 2018

    Ok, I finally was able to obtain the branch just a few moments ago. I had to stand on the npc's feet in order for him to actually accept the parts I was trying to give to him. I think he accepted maybe 1/2 of the parts I tried to fling at his feet. Other folks in this event today were really salty...cussing is a mild explanation to what I was hearing. lol

    Got my fingers crossed this gets fixed really soon for all those that still need it.

  • Kilamanjaro.2705Kilamanjaro.2705 Member ✭✭✭

    Thanks for the update. I didnt find this thread til I had already commented elsewhere, but do hope this is SOON. I rage logged over this. may log back in now

  • Moz.3452Moz.3452 Member ✭✭

    This bug is still there. How on earth is anyone ever able to get this done for Legendary weapons (in my case Chuka and Chumpawat)? The map is pretty much dead anyway but when you do eventually get a few people it just bugs out, so frustrating.
    Tbh If I'd known about this before investing time, gold and mats to get to this stage I would never have started :angry: