"Screenshot folder full" even when folder is empty — Guild Wars 2 Forums
Home

"Screenshot folder full" even when folder is empty

When I try to take a sceenshot I get the message "Your screenshot folder is full." even after I emptied the folder. I have tried to delete the folder and it gets recreated but I still get the same message. I got about 90 GB free space on the harddrive.
I have tested to repair game files and to delete temporary files from AppData\Local\Temp and local.dat but I still get the same error.
Anyone got any advice on how to reset this?

Comments

  • What version of windows are you running, and if you run windows 10, which build?
    The reason I am asking is that in windows 10, your my documents is defeault shared with one drive. If your one drive is full, you can get this error. In the latest build, they added a check mark to disable the sync.

  • Windows 10 -64bit - Version 1709 - build 16299.192
    I disabled One drive over a year ago but maybe a newer build doesn't like when it is disabled? Last screenshot I did was two weeks ago and I think the computer did an update after that.

  • Looks like it might have been something with windows. I installed the latest updates on the computer yesterday and now screenshots work again.

  • I've had this issue reoccurring for 2 weeks now. I have deleted the local files for gw2 and reinstalled, emptied the folder, emptied my cache, and nothing. It went away for 2 days, and it's back again. I have 0 screens in my folder or anywhere else.

  • Ashantara.8731Ashantara.8731 Member ✭✭✭✭
    edited April 22, 2018

    Have you looked up the correct path for your screenshot folder? --> C:\Users\ [username] \Documents\Guild Wars 2\Screens\

    Also, do you have proper rights to delete files in your user folder(s)?

  • I have followed the path and it shows up empty, I am the only user on my pc so there's no permission issues there.

  • The Greyhawk.9107The Greyhawk.9107 Member ✭✭✭✭

    Also having this issue, moved everything out of the folder and it still says "Folder is Full" when I try to do a screenshot.

    Hate Is Fuel.

  • Ashantara.8731Ashantara.8731 Member ✭✭✭✭
    edited April 24, 2018

    @Prophet.6519 said:
    I have followed the path and it shows up empty, I am the only user on my pc so there's no permission issues there.

    You can be the only user and still have restricted permissions if your account has no administrator privileges. I don't know about Windows X's policy, but in previous Windows versions you had to explicitly give an account one those privileges. Normal user accounts have restrictions.

  • Sindariel.2354Sindariel.2354 Member ✭✭✭

    Are you sure you're in the right folder?
    In Win 10, you can change the default path for screenshots to your OneDrive share. If your OneDrive account is full, than you can't save any more screenshots.

  • Ashantara.8731Ashantara.8731 Member ✭✭✭✭
    edited August 16, 2020

    @Sindariel.2354 said:
    Are you sure you're in the right folder?
    In Win 10, you can change the default path for screenshots to your OneDrive share. If your OneDrive account is full, than you can't save any more screenshots.

    I am not connected to OneDrive, yet I am getting the same error message after upgrading my system. :(

    Any ideas?

    P.S. I completely removed OneDrive and other unwanted programs from my system using Windows 10 Debloater. I had done that before on my old system as well and never ran into this screenshor folder issue. It is only a thing since the upgrade I mentioned (new mainboard, CPU, RAM, SSD).

  • Nokomis.5076Nokomis.5076 Member ✭✭✭

    If you rename the folder C:\Users\ [username] \Documents\Guild Wars 2 and then start Guild Wars and try to make a screen again, does the game even recreate the Guild Wars 2 folder?

    Was I able to help you or give you a hint? Click on Helpful and/or Thumbs up, I would appreciate it alot!
    When you encounter a bug ingame, at first you should file a ticket via the ingame command /bug, as only this way the devs will know exactly where you were, when the bug happened.

  • Ashantara.8731Ashantara.8731 Member ✭✭✭✭

    @Nokomis.5076 said:
    If you rename the folder C:\Users\ [username] \Documents\Guild Wars 2 and then start Guild Wars and try to make a screen again, does the game even recreate the Guild Wars 2 folder?

    Yes, and the same error message keeps popping up.

  • Ashantara.8731Ashantara.8731 Member ✭✭✭✭
    edited August 19, 2020
  • Ashantara.8731Ashantara.8731 Member ✭✭✭✭
    edited August 19, 2020

    Solution:

    Hey folks and @Jozo.2630,

    Forget what I wrote yesterday, here is the actual solution (at least for me):

    • Open your anti-virus's settings
    • Add these two directories to the list of exceptions:
      (installation path) \YoloMouse\ *
      C:\Users\ (username) \AppData\Local\YoloMouse\ *

    Remove the spaces (including the one before the asterisk) and replace the Windows user name with your actual user name and installation path with the exact location on your drive(s).

    Et voilà, the error no longer occurs! :)

  • Is it only YoloMouse users that have this issue with the screenshot folder?

  • Ashantara.8731Ashantara.8731 Member ✭✭✭✭
    edited August 19, 2020

    @Inculpatus cedo.9234 said:
    Is it only YoloMouse users that have this issue with the screenshot folder?

    That would indeed be interesting to learn. I can imagine it happening with various overlays.

  • None of the suggestions worked.
    My solution: I deleted Avast - with just Windows Defender or Avira everything was fine.

  • Linken.6345Linken.6345 Member ✭✭✭✭

    @efeu.9037 said:
    None of the suggestions worked.
    My solution: I deleted Avast - with just Windows Defender or Avira everything was fine.

    You were running multiple anti virus programs at once?

  • had the same issure few days ago, followinig worked for me:

    -> turned off antivirus, took a screenshot (now worked)
    -> turned antivirus back on, took a screen (worked until i turned off hud or had a loadingscreen, video or something)
    -> added the whole installation folder of GW2 as an exception in my antivirus, now screenshots are working again (had to set the exception twice, first time the error was up on the 2nd time i did it after i took the two testing screens while turning off and on antivirus than it worked)

  • Arozok.4083Arozok.4083 Member
    edited April 13, 2021

    Thanks to everyone who pointed to antivirus and Avast. Here is the solution I found:
    Open Avast > Menu > Settings > Blocked & Allowed Apps > Allow your GW2.exe for Ransomware Shield
    I guess that shield protects from any online changes to the Documents folders even JPGs?
    Once that is allowed, Avast will not block screenshots. At least that works for some. Hope this helps.

  • Dawdler.8521Dawdler.8521 Member ✭✭✭✭
    edited April 14, 2021

    @Inculpatus cedo.9234 said:
    Is it only YoloMouse users that have this issue with the screenshot folder?

    I dont use Yolomouse and I dont have Avast.

    I thought it was related to GW2 randomly assigning F6 to screenshot (secondary) but nope unassigning and cleaning the folder wasnt that. I use AVG and added the GW2 documents folder to exceptions but that didnt take either. Will try the full game folder too. Havent had to do it before and I have used AVG for years.

    Edit: Yep that worked.

    gaggle - /ˈɡaɡ(ə)l/ - noun
    A disorderly group of Asura.
    "The gaggle of Asura tried to agree on whether a phase-shifted thermonuclear energy matrix was sufficiently powerful for a device capable of heating bread"

  • Ashantara.8731Ashantara.8731 Member ✭✭✭✭

    @Dawdler.8521 said:
    I dont use Yolomouse and I dont have Avast.

    Doesn't matter. What I said in another thread and here goes for any add-on and antivirus.

  • Inculpatus cedo.9234Inculpatus cedo.9234 Member ✭✭✭✭

    Since this thread spans 3 years, it seems different issues have occurred at times.