Sound — Guild Wars 2 Forums
Home

Sound

I have downloaded the game and purchased both HoT and PoF, and have enjoyed many hours playing through the content and PvPing. However, recently when I try to play, the game doesn't have any sound on the character select screen. "Alright" I thought, "probably just a bug." But sure enough, all sound inside the actual game world and instances etc aren't working. I tried resetting to default sound settings and playing with the different sound settings in game, and checked my master volume/sound mixer to make sure Guild Wars was turned up, and running it as admin just to see if it would work all to no avail. Everything seems normal and in their right place, and all the other games/music/videos I play seem to play their sounds with absolutely no problem at all. Does anyone have any idea on how I can help fix this problem and get the sound working again?

Comments

  • Inculpatus cedo.9234Inculpatus cedo.9234 Member ✭✭✭✭
    edited March 4, 2018

    Have you tried a -repair of the client, in case of corrupted file(s)?
    Instructions found in the Knowledge Base accessed via the 'Support' link above/below and 'Search - Repair'.

    Also, make sure your OS audio settings and your in-game audio settings match your physical audio equipment.

    Good luck.

  • Thank you for taking the time to reply, however running the repair did not seem to do anything, and my OS/in-game audio settings/sources all match up. Any other ideas? I'd prefer to avoid a total reinstall if possible.

  • Inculpatus cedo.9234Inculpatus cedo.9234 Member ✭✭✭✭

    You can contact the Tech CS Team via the 'Support' link above/below and 'Submit a Ticket' for assistance.
    You can try disabling any 3rd-party programs; graphics/voip/etc., as well.

    Good luck.

  • Healix.5819Healix.5819 Member ✭✭✭✭

    Reinstalling is a placebo. The only thing it's actually good for is shrinking Gw2.dat. Everything else can be done by copying Gw2.dat to check the drive's state, running -repair to verify it's not corrupted and deleting the %temp%/gw2cache, %appdata%/Guild Wars 2/ and Documents/Guild Wars 2/ folders.

    You can try deleting %appdata%/Guild Wars 2/Local.dat, and if it exists, Documents/Guild Wars 2/Local.dat, which will reset your hardware-related settings.

    Ensure you're not using the -nosound option and that GW2 is playing on the proper output device and isn't muted. It should appear under the volume mixer. Ensure that your speakers are configured properly, otherwise GW2 may be trying to play on a channel/speaker that you don't actually have. If you're using any additional audio mixing software, you must also ensure that it's configured properly. One of them was causing problems a while back with muting GW2, Razer maybe.

  • Having the same issue was fine when I logged of about 24 hours ago, Now after the update no sound anywhere. Checked 3 other games all fine, video streaming also fine. GW2 setting are fine, and its not muted in the Windows controller. There are also no other audio based programs running. I also tried deleting the local.dat file with no change. I've submitted a ticket, but the last issue it took 5 days to get back to me. Anyone find a fix?

  • DarkLord.2619DarkLord.2619 Member
    edited April 7, 2018

    Same here, i tried all solutions found in this forum. Also filed a ticket to tech support and submit the result of Game Advisor Results and still no reply coming from them for a "MONTH". Any of you experience the same issue? How did you fix it? Please share it here so me and other players out there can fix the issue. Thank you so much :)

  • Sako.7609Sako.7609 Member ✭✭

    Have you tried changing the "default audio device" from GW2 sound options to something else?

  • DarkLord.2619DarkLord.2619 Member
    edited April 8, 2018

    @Sako.7609 said:
    Have you tried changing the "default audio device" from GW2 sound options to something else?

    Yeah im using realtek high definition audio - speaker in Audio Manager and checking volume mixer GW2 is there but still there's no sounds :/

  • I've also had a very similar problem. Played the game fine this morning; then tonight all sound was gone, starting from main menu. I've rebooted my computer, checked the volume mixer, tried both in-game audio device options as well as using headphones, reinstalled drivers (only GW2 has problems anyways), uninstalled/reinstalled GW2, repaired the local client, and deleted the Local.dat file. Still nothing, very confusing to say the least.

  • SOLVED! Here are the steps that worked for me (on Windows 10):

    1. From your desktop, click the start button in the bottom-left, then select Settings (the gear icon).
    2. Select Apps.
    3. From Apps, scroll down to the one that matches your audio driver (if you don't know which one that is, go to Device Manager from the search bar, and see what it says under Sound, Video, and Game Controllers). For example, I had "Realtek High Definition Audio Driver".
    4. Select your audio driver and uninstall it. Reboot your computer (you may also need to reboot again, after your system automatically reinstalls the driver upon bootup).

    After the driver has been reinstalled and your system rebooted, open the game. Hopefully it should work now!

  • @Svenman.7354 said:
    SOLVED! Here are the steps that worked for me (on Windows 10):

    1. From your desktop, click the start button in the bottom-left, then select Settings (the gear icon).
    2. Select Apps.
    3. From Apps, scroll down to the one that matches your audio driver (if you don't know which one that is, go to Device Manager from the search bar, and see what it says under Sound, Video, and Game Controllers). For example, I had "Realtek High Definition Audio Driver".
    4. Select your audio driver and uninstall it. Reboot your computer (you may also need to reboot again, after your system automatically reinstalls the driver upon bootup).

    After the driver has been reinstalled and your system rebooted, open the game. Hopefully it should work now!

    THANKYOU MAN COOLEST GUY EVER IT FIX IT FOR ME

  • Linken.6345Linken.6345 Member ✭✭✭✭

    @odessa.1287 said:

    @Svenman.7354 said:
    SOLVED! Here are the steps that worked for me (on Windows 10):

    1. From your desktop, click the start button in the bottom-left, then select Settings (the gear icon).
    2. Select Apps.
    3. From Apps, scroll down to the one that matches your audio driver (if you don't know which one that is, go to Device Manager from the search bar, and see what it says under Sound, Video, and Game Controllers). For example, I had "Realtek High Definition Audio Driver".
    4. Select your audio driver and uninstall it. Reboot your computer (you may also need to reboot again, after your system automatically reinstalls the driver upon bootup).

    After the driver has been reinstalled and your system rebooted, open the game. Hopefully it should work now!

    THANKYOU MAN COOLEST GUY EVER IT FIX IT FOR ME

    Glad it worked for you and kudos for using the search feature