Playing Guild Wars 2 on Linux - Performance optimizations and more. - Page 16 — Guild Wars 2 Forums
Home

Playing Guild Wars 2 on Linux - Performance optimizations and more.

11416181920

Comments

  • @ArmoredVehicle.2849 said:
    EDIT:

    A bit of a small announcement for you all. I've updated the package to v1.9.0. This brings with it some major changes.

    Thank you for your continuous hard work on this! :)

  • @ArmoredVehicle.2849 said:

    @EagleDelta.4726 said:

    @EagleDelta.4726 said:
    @ArmoredVehicle.2849 Anyone note the issue where the game will crash if you try and modify dynamic HUD settings while logged into a Character? It works fine when on the character select, but crashes if changes are made after selecting a character

    So looks like with the latest build the crashing when changing dynamic HUD settings has stopped.

    When you say the latest build, are you referring to a game update or the Linux package update I've recently released? :)

    Yes ;)

  • EagleDelta.4726EagleDelta.4726 Member ✭✭✭
    edited December 13, 2019

    @ArmoredVehicle.2849 is there anyway to get the wine fork you build for this available as a tarball or on Github? I want to create a Lutris installer for your version and want to submit your build as a Lutris wine version

    NEVERMIND: Looks like most of the patches you use are included in the lutris-4.21 build of WINE.

  • @EagleDelta.4726 said:
    @ArmoredVehicle.2849 is there anyway to get the wine fork you build for this available as a tarball or on Github? I want to create a Lutris installer for your version and want to submit your build as a Lutris wine version

    NEVERMIND: Looks like most of the patches you use are included in the lutris-4.21 build of WINE.

    The wine build in my package is a straight off Wine + Staging patches applied, my own stuff are the various scripts and the pre-configured prefix, hope that clears it up :)

  • @ArmoredVehicle.2849 said:

    @EagleDelta.4726 said:
    @ArmoredVehicle.2849 is there anyway to get the wine fork you build for this available as a tarball or on Github? I want to create a Lutris installer for your version and want to submit your build as a Lutris wine version

    NEVERMIND: Looks like most of the patches you use are included in the lutris-4.21 build of WINE.

    The wine build in my package is a straight off Wine + Staging patches applied, my own stuff are the various scripts and the pre-configured prefix, hope that clears it up :)

    That's what I figured. I will be updating the installers I have with your arcdps and radial script(s) for post installation runs, but other than that, it's mostly the same just with the play.sh replaced by the traditional execing wine + game exe since Lutris can handle the env vars.

  • Package updated to 1.9.1 with D9VK 0.40.1, thanks ;)

  • Ok is updated to 1.9.1

  • Ok the next update need swith D9VK to DXVK https://github.com/doitsujin/dxvk/commit/54ed8f0bb0f0859e05b7b406b7e95fa71900ba40
    Now D9VK and DXVK is same project !
    That help me for my works ^^

  • @04D95143-7F7C-4289-8567-88D4F26CEEF9.2615 said:
    Ok the next update need swith D9VK to DXVK https://github.com/doitsujin/dxvk/commit/54ed8f0bb0f0859e05b7b406b7e95fa71900ba40
    Now D9VK and DXVK is same project !
    That help me for my works ^^

    What coming here to say the same thing.

    @ArmoredVehicle.2849 - D9VK is no longer a standalone project. It has been merged into DXVK as of DXVK 1.5

  • I read the news regarding the merge this morning, I'm glad they got to this point :)

    In regards to GW2 it seems this is it for this year, hopefully fsync will be more accessible to everyone next year, I'm sure it can squeeze out a little more frames in this game.

  • Hi,

    As always thank you for the great work that helped me greatly over the past ~two years!

    I have come across an issue that prevents me from running the game for some reason. I have included the information posted right after I run debug.sh
    It used to run just fine, however, I have tinkered in the past few weeks with my default wine prefix to run a certain game. However, I thought it shouldn't affect GW2 since it runs on a separate contained pre-fix.

    Any insight is highly appreciated. Thanks! :)

    ./debug.sh 000b:fixme:winediag:start_process Wine Staging 4.21 is a testing version containing experimental patches. 000b:fixme:winediag:start_process Please mention your exact version when filing bug reports on winehq.org. Wine cannot find the ncurses library (libncurses.so.5). 0009:fixme:heap:RtlSetHeapInformation 0x20000 0 0x22fcd0 4 stub 0009:fixme:heap:RtlSetHeapInformation 0x730000 0 0x22fcb0 4 stub 0009:fixme:heap:RtlSetHeapInformation 0x730000 1 (nil) 0 stub 002d:fixme:ver:GetCurrentPackageId (0x142fda0 (nil)): stub 0009:fixme:ntdll:NtQuerySystemInformation info_class SYSTEM_PERFORMANCE_INFORMATION 0009:err:winediag:wined3d_dll_init Setting multithreaded command stream to 0. ATTENTION: default value of option vblank_mode overridden by environment. ATTENTION: default value of option mesa_glthread overridden by environment. 0009:fixme:gameux:GameExplorerImpl_VerifyAccess (0000000000FF6D20, L"C:\\GW2\\GW2.exe", 000000000022F140) 0042:fixme:msctf:ThreadMgr_ActivateEx Unimplemented flags 0x4 [[email protected] GW2]$ 0047:fixme:heap:RtlSetHeapInformation 0x20000 0 0x22fcd0 4 stub 0047:fixme:heap:RtlSetHeapInformation 0x730000 0 0x22fcb0 4 stub 0047:fixme:heap:RtlSetHeapInformation 0x730000 1 (nil) 0 stub 0048:fixme:ver:GetCurrentPackageId (0x142fda0 (nil)): stub 0047:fixme:ntdll:NtQuerySystemInformation info_class SYSTEM_PERFORMANCE_INFORMATION 0047:err:winediag:wined3d_dll_init Setting multithreaded command stream to 0. ATTENTION: default value of option vblank_mode overridden by environment. ATTENTION: default value of option mesa_glthread overridden by environment. 0047:fixme:gameux:GameExplorerImpl_VerifyAccess (0000000000FF62E0, L"C:\\GW2\\GW2.tmp", 000000000022F140) 0058:fixme:heap:RtlSetHeapInformation 0x20000 0 0x22fcd0 4 stub 0058:fixme:heap:RtlSetHeapInformation 0x730000 0 0x22fcb0 4 stub 0058:fixme:heap:RtlSetHeapInformation 0x730000 1 (nil) 0 stub 0059:fixme:ver:GetCurrentPackageId (0x142fda0 (nil)): stub 0058:fixme:ntdll:NtQuerySystemInformation info_class SYSTEM_PERFORMANCE_INFORMATION 0058:err:winediag:wined3d_dll_init Setting multithreaded command stream to 0. ATTENTION: default value of option vblank_mode overridden by environment. ATTENTION: default value of option mesa_glthread overridden by environment. 0058:fixme:gameux:GameExplorerImpl_VerifyAccess (0000000000FF6C00, L"C:\\GW2\\GW2.exe", 000000000022F140) 006e:fixme:msctf:ThreadMgr_ActivateEx Unimplemented flags 0x4 006e:fixme:sync:NtQueryInformationJobObject stub: 0x2b0 2 0x2f1db80 64 (nil) 006e:fixme:sync:NtQueryInformationJobObject stub: 0x2b0 9 0x2f1dbc0 144 (nil) 0075:fixme:heap:RtlSetHeapInformation (nil) 1 (nil) 0 stub 0075:fixme:heap:RtlSetHeapInformation (nil) 1 (nil) 0 stub 0075:fixme:nls:GetThreadPreferredUILanguages 00000038, 0x32f6e4, (nil) 0x32f6e0 0075:fixme:nls:get_dummy_preferred_ui_language (0x38 0x32f6e4 (nil) 0x32f6e0) returning a dummy value (current locale) 0075:fixme:nls:GetThreadPreferredUILanguages 00000038, 0x32f6e4, 0x2e0bb60 0x32f6e0 0075:fixme:nls:get_dummy_preferred_ui_language (0x38 0x32f6e4 0x2e0bb60 0x32f6e0) returning a dummy value (current locale) 0075:fixme:winsock:WSALookupServiceBeginW (0x32f750 0x00000ff0 0x32f798) Stub! 0075:fixme:iphlpapi:NotifyAddrChange (Handle 0x32f628, overlapped 0x2e16d08): stub 0075:fixme:win:RegisterDeviceNotificationW (hwnd=0x1007a, filter=0x32f808,flags=0x00000000) returns a fake device notification handle! 0075:fixme:win:RegisterDeviceNotificationW (hwnd=0x1007a, filter=0x32f808,flags=0x00000000) returns a fake device notification handle! 0075:fixme:ntdll:NtQuerySystemInformation info_class SYSTEM_PERFORMANCE_INFORMATION 0084:fixme:ntdll:EtwRegisterTraceGuidsW (0x495320, 0x24ef248, {3dada31d-19ef-4dc1-b345-037927193422}, 1, 0x24a4f04, (null), (null), 0x24ef260): stub 0084:fixme:ntdll:EtwRegisterTraceGuidsW register trace class {00000000-0000-0000-0000-000000000000} 0075:fixme:winsock:WSALookupServiceBeginW (0x32dc60 0x00000ff0 0x32dca8) Stub! 008f:fixme:heap:RtlSetHeapInformation (nil) 1 (nil) 0 stub 008f:fixme:heap:RtlSetHeapInformation (nil) 1 (nil) 0 stub 008f:fixme:ntdll:EtwRegisterTraceGuidsW (0x495320, 0x24ef248, {3dada31d-19ef-4dc1-b345-037927193422}, 1, 0x24a4f04, (null), (null), 0x24ef260): stub 008f:fixme:ntdll:EtwRegisterTraceGuidsW register trace class {00000000-0000-0000-0000-000000000000} 008f:fixme:gdi:GdiInitializeLanguagePack stub 0086:fixme:winsock:WSALookupServiceBeginW (0x3fff5d4 0x00000ff0 0x3fff61c) Stub! 0086:fixme:winsock:WSALookupServiceBeginW (0x3fff5d4 0x00000ff0 0x3fff61c) Stub! 00ba:fixme:ntdll:NtLockFile I/O completion on lock not implemented yet 0075:fixme:win:UnregisterDeviceNotification (handle=0xcafeaffe), STUB! 0075:fixme:win:UnregisterDeviceNotification (handle=0xcafeaffe), STUB! 0075:fixme:iphlpapi:CancelIPChangeNotify (overlapped 0x2e16d08): stub 0075:fixme:ntdll:EtwUnregisterTraceGuids deadbeef: stub 006e:fixme:wbemprox:wbem_services_CreateInstanceEnum unsupported flags 0x00000030 006e:fixme:wbemprox:enum_class_object_Next timeout not supported 006e:fixme:ddraw:ddraw7_Initialize Ignoring guid {00000000-0008-0000-0000-000000000000}. 006e:err:winediag:MIDIMAP_drvOpen No software synthesizer midi port found, Midi sound output probably won't work. 006e:fixme:wtsapi:WTSRegisterSessionNotification Stub 0000000000040062 0x00000000 006e:fixme:msctf:ThreadMgr_ActivateEx Unimplemented flags 0x4 00cc:fixme:seh:dwarf_get_ptr unsupported encoding 9b 00cc:fixme:seh:dwarf_get_ptr unsupported encoding 0e 00cc:fixme:seh:dwarf_get_ptr unsupported encoding 0e 00cc:fixme:seh:dwarf_get_ptr unsupported encoding b5 00cc:fixme:seh:execute_cfa_instructions 0: unknown CFA opcode 28 00cc:fixme:seh:dwarf_get_ptr unsupported encoding 9b 00cc:fixme:seh:dwarf_get_ptr unsupported encoding 0e 00cc:fixme:seh:dwarf_get_ptr unsupported encoding 0e 00cc:fixme:seh:dwarf_get_ptr unsupported encoding b5 00cc:fixme:seh:dwarf_get_ptr unsupported encoding 9b 00cc:fixme:seh:dwarf_get_ptr unsupported encoding 0e 00cc:fixme:seh:dwarf_get_ptr unsupported encoding 0e 00cc:fixme:seh:dwarf_get_ptr unsupported encoding b5 00cc:fixme:seh:execute_cfa_instructions 0: unknown CFA opcode 28 00cc:fixme:seh:dwarf_get_ptr unsupported encoding 9b 00cc:fixme:seh:dwarf_get_ptr unsupported encoding 0e 00cc:fixme:seh:dwarf_get_ptr unsupported encoding 0e 00cc:fixme:seh:dwarf_get_ptr unsupported encoding b5 002a:err:clipboard:convert_selection Timed out waiting for SelectionNotify event 002a:err:clipboard:convert_selection Timed out waiting for SelectionNotify event

    Basic PC info
    OS: Manjaro Linux x86_64 Kernel: 5.3.12-1-MANJARO Packages: 1304 (pacman) Shell: bash 5.0.11 Resolution: 2560x1440 DE: Plasma WM: KWin Theme: Breath [GTK2/3] Icons: maia [GTK2/3] Terminal: konsole CPU: AMD Ryzen 5 2600 (12) @ 3.400GHz GPU: AMD ATI Radeon RX 470/480/570/570X/580/580X/590 Memory: 4693MiB / 16002MiB

    Thanks again, and happy holidays ^^

  • With Wintersday here and orphan routes to follow, any news on getting TaCo to work on Linux, @ArmoredVehicle.2849?

  • ArmoredVehicle.2849ArmoredVehicle.2849 Member ✭✭✭
    edited December 17, 2019

    @Barabeam.4638 said:
    Hi,

    As always thank you for the great work that helped me greatly over the past ~two years!

    I have come across an issue that prevents me from running the game for some reason. I have included the information posted right after I run debug.sh
    It used to run just fine, however, I have tinkered in the past few weeks with my default wine prefix to run a certain game. However, I thought it shouldn't affect GW2 since it runs on a separate contained pre-fix.

    Any insight is highly appreciated. Thanks! :)

    Hmm, From that log I can't quite tell what could be the issue. Since you were able to run the game in the past, could you please try this package: ftp://jrugia.com:1025/wine_gw2_1.8.5_intel_amd.tar.xz (you may need to copy the link as text and paste in a new tab manually).

    Let me know if it changes anything.

  • @ArmoredVehicle.2849 said:

    @Barabeam.4638 said:
    Hi,

    As always thank you for the great work that helped me greatly over the past ~two years!

    I have come across an issue that prevents me from running the game for some reason. I have included the information posted right after I run debug.sh
    It used to run just fine, however, I have tinkered in the past few weeks with my default wine prefix to run a certain game. However, I thought it shouldn't affect GW2 since it runs on a separate contained pre-fix.

    Any insight is highly appreciated. Thanks! :)

    Hmm, From that log I can't quite tell what could be the issue. Since you were able to run the game in the past, could you please try this package: ftp://jrugia.com:1025/wine_gw2_1.8.5_intel_amd.tar.xz (you may need to copy the link as text and paste in a new tab manually).

    Let me know if it changes anything.

    Thank you for your input. I tried the supplied package, it did not change anything.

    What happens when I click play, is the screen resolution changes to the highest the monitor can handle, and the screen freezes with nothing advancing. I end up killing the task by using the alt+ctl+F2 console. When I kill it the resolution persists on the highest setting, so I need to readjust it manually everytime I run it. I also tried deleting the .dat file to have a fresh install/download of the game data just in case it was a configuration issue. But I will continue to dig for clues, thanks a lot! :+1:

  • @Barabeam.4638 said:

    @ArmoredVehicle.2849 said:

    @Barabeam.4638 said:
    Hi,

    As always thank you for the great work that helped me greatly over the past ~two years!

    I have come across an issue that prevents me from running the game for some reason. I have included the information posted right after I run debug.sh
    It used to run just fine, however, I have tinkered in the past few weeks with my default wine prefix to run a certain game. However, I thought it shouldn't affect GW2 since it runs on a separate contained pre-fix.

    Any insight is highly appreciated. Thanks! :)

    Hmm, From that log I can't quite tell what could be the issue. Since you were able to run the game in the past, could you please try this package: ftp://jrugia.com:1025/wine_gw2_1.8.5_intel_amd.tar.xz (you may need to copy the link as text and paste in a new tab manually).

    Let me know if it changes anything.

    Thank you for your input. I tried the supplied package, it did not change anything.

    What happens when I click play, is the screen resolution changes to the highest the monitor can handle, and the screen freezes with nothing advancing. I end up killing the task by using the alt+ctl+F2 console. When I kill it the resolution persists on the highest setting, so I need to readjust it manually everytime I run it. I also tried deleting the .dat file to have a fresh install/download of the game data just in case it was a configuration issue. But I will continue to dig for clues, thanks a lot! :+1:

    If you haven't done so already, can you try to run the game in a virtual desktop? You can do this by running the 'wine_settings.sh' file. Try setting it to a small resolution first such as 1280x720.

  • Barabeam.4638Barabeam.4638 Member ✭✭
    edited December 18, 2019

    @ArmoredVehicle.2849 said:

    @Barabeam.4638 said:

    @ArmoredVehicle.2849 said:

    @Barabeam.4638 said:
    Hi,

    As always thank you for the great work that helped me greatly over the past ~two years!

    I have come across an issue that prevents me from running the game for some reason. I have included the information posted right after I run debug.sh
    It used to run just fine, however, I have tinkered in the past few weeks with my default wine prefix to run a certain game. However, I thought it shouldn't affect GW2 since it runs on a separate contained pre-fix.

    Any insight is highly appreciated. Thanks! :)

    Hmm, From that log I can't quite tell what could be the issue. Since you were able to run the game in the past, could you please try this package: ftp://jrugia.com:1025/wine_gw2_1.8.5_intel_amd.tar.xz (you may need to copy the link as text and paste in a new tab manually).

    Let me know if it changes anything.

    Thank you for your input. I tried the supplied package, it did not change anything.

    What happens when I click play, is the screen resolution changes to the highest the monitor can handle, and the screen freezes with nothing advancing. I end up killing the task by using the alt+ctl+F2 console. When I kill it the resolution persists on the highest setting, so I need to readjust it manually everytime I run it. I also tried deleting the .dat file to have a fresh install/download of the game data just in case it was a configuration issue. But I will continue to dig for clues, thanks a lot! :+1:

    If you haven't done so already, can you try to run the game in a virtual desktop? You can do this by running the 'wine_settings.sh' file. Try setting it to a small resolution first such as 1280x720.

    I just tried that, the game crashed and gave me a detailed log this time.

    I solved the problem though :D

    the libraries: d3dl10, d3d10_1, d3d10core, d3d11, d3d9, and dxgi were set to native (windows).
    I tried changing them to builtin (wine). And it worked like a charm. I will do more testing now and check out how the performance goes :). Will also update again to your most recent patch

    Thanks a lot!

    Edit2: Well, not like a charm, it has performance stutters and a glitchy map. but now I understand that my crash problems was due to DLLs, I will try to mingle with that. maybe enable them all as native, then switching them out one by one to see which one was responsible for not running as intended :). I will post my results as it may help others with similar problems ^^

  • ArmoredVehicle.2849ArmoredVehicle.2849 Member ✭✭✭
    edited December 18, 2019

    @Barabeam.4638 said:

    @ArmoredVehicle.2849 said:

    @Barabeam.4638 said:

    @ArmoredVehicle.2849 said:

    @Barabeam.4638 said:
    Hi,

    As always thank you for the great work that helped me greatly over the past ~two years!

    I have come across an issue that prevents me from running the game for some reason. I have included the information posted right after I run debug.sh
    It used to run just fine, however, I have tinkered in the past few weeks with my default wine prefix to run a certain game. However, I thought it shouldn't affect GW2 since it runs on a separate contained pre-fix.

    Any insight is highly appreciated. Thanks! :)

    Hmm, From that log I can't quite tell what could be the issue. Since you were able to run the game in the past, could you please try this package: ftp://jrugia.com:1025/wine_gw2_1.8.5_intel_amd.tar.xz (you may need to copy the link as text and paste in a new tab manually).

    Let me know if it changes anything.

    Thank you for your input. I tried the supplied package, it did not change anything.

    What happens when I click play, is the screen resolution changes to the highest the monitor can handle, and the screen freezes with nothing advancing. I end up killing the task by using the alt+ctl+F2 console. When I kill it the resolution persists on the highest setting, so I need to readjust it manually everytime I run it. I also tried deleting the .dat file to have a fresh install/download of the game data just in case it was a configuration issue. But I will continue to dig for clues, thanks a lot! :+1:

    If you haven't done so already, can you try to run the game in a virtual desktop? You can do this by running the 'wine_settings.sh' file. Try setting it to a small resolution first such as 1280x720.

    I just tried that, the game crashed and gave me a detailed log this time.

    I solved the problem though :D

    the libraries: d3dl10, d3d10_1, d3d10core, d3d11, d3d9, and dxgi were set to native (windows).
    I tried changing them to builtin (wine). And it worked like a charm. I will do more testing now and check out how the performance goes :). Will also update again to your most recent patch

    Thanks a lot!

    That's mighty weird, those dlls are set to native so it uses DXVK/D9VK instead of Wine's Opengl. I will test them on my end maybe I missed something (no AMD card though).

    For the record, do you play any other games that use DXVK or Vulkan?

    EDIT:
    I just tested the v1.8.5 package I linked you yesterday and it works fine on my end.

    @Barabeam.4638 said:

    Edit2: Well, not like a charm, it has performance stutters and a glitchy map. but now I understand that my crash problems was due to DLLs, I will try to mingle with that. maybe enable them all as native, then switching them out one by one to see which one was responsible for not running as intended :). I will post my results as it may help others with similar problems ^^

    Those stutters occur due to the shader cache being freshly built. The game becomes much smoother with subsequent runs as the shaders are saved to the game's folder (appropriately named 'shader cache'). With DXVK this is less noticeable due to faster compilation, Wine's built in D3D is much slower.


    From the looks of it so far it seems something is odd/missing with your Vulkan support.

    Make sure you have at least these packages installed in your system (Manjaro): vulkan-radeon and vulkan-icd-loader

    Another note regarding those set of DLL's: Some of them are meant to be used together for example dxgi.dll and d3d9.dll. In the case of GW2 you can forgive not using d3d10* and d3d11 ones but the other files must work together.

  • @ArmoredVehicle.2849 said:

    @Barabeam.4638 said:

    @ArmoredVehicle.2849 said:

    @Barabeam.4638 said:

    @ArmoredVehicle.2849 said:

    @Barabeam.4638 said:
    Hi,

    As always thank you for the great work that helped me greatly over the past ~two years!

    I have come across an issue that prevents me from running the game for some reason. I have included the information posted right after I run debug.sh
    It used to run just fine, however, I have tinkered in the past few weeks with my default wine prefix to run a certain game. However, I thought it shouldn't affect GW2 since it runs on a separate contained pre-fix.

    Any insight is highly appreciated. Thanks! :)

    Hmm, From that log I can't quite tell what could be the issue. Since you were able to run the game in the past, could you please try this package: ftp://jrugia.com:1025/wine_gw2_1.8.5_intel_amd.tar.xz (you may need to copy the link as text and paste in a new tab manually).

    Let me know if it changes anything.

    Thank you for your input. I tried the supplied package, it did not change anything.

    What happens when I click play, is the screen resolution changes to the highest the monitor can handle, and the screen freezes with nothing advancing. I end up killing the task by using the alt+ctl+F2 console. When I kill it the resolution persists on the highest setting, so I need to readjust it manually everytime I run it. I also tried deleting the .dat file to have a fresh install/download of the game data just in case it was a configuration issue. But I will continue to dig for clues, thanks a lot! :+1:

    If you haven't done so already, can you try to run the game in a virtual desktop? You can do this by running the 'wine_settings.sh' file. Try setting it to a small resolution first such as 1280x720.

    I just tried that, the game crashed and gave me a detailed log this time.

    I solved the problem though :D

    the libraries: d3dl10, d3d10_1, d3d10core, d3d11, d3d9, and dxgi were set to native (windows).
    I tried changing them to builtin (wine). And it worked like a charm. I will do more testing now and check out how the performance goes :). Will also update again to your most recent patch

    Thanks a lot!

    That's mighty weird, those dlls are set to native so it uses DXVK/D9VK instead of Wine's Opengl. I will test them on my end maybe I missed something (no AMD card though).

    For the record, do you play any other games that use DXVK or Vulkan?

    EDIT:
    I just tested the v1.8.5 package I linked you yesterday and it works fine on my end.

    @Barabeam.4638 said:

    Edit2: Well, not like a charm, it has performance stutters and a glitchy map. but now I understand that my crash problems was due to DLLs, I will try to mingle with that. maybe enable them all as native, then switching them out one by one to see which one was responsible for not running as intended :). I will post my results as it may help others with similar problems ^^

    Those stutters occur due to the shader cache being freshly built. The game becomes much smoother with subsequent runs as the shaders are saved to the game's folder (appropriately named 'shader cache'). With DXVK this is less noticeable due to faster compilation, Wine's built in D3D is much slower.


    From the looks of it so far it seems something is odd/missing with your Vulkan support.

    Make sure you have at least these packages installed in your system (Manjaro): vulkan-radeon and vulkan-icd-loader

    Another note regarding those set of DLL's: Some of them are meant to be used together for example dxgi.dll and d3d9.dll. In the case of GW2 you can forgive not using d3d10* and d3d11 ones but the other files must work together.

    THANK YOU!

    Turns out I had vulkan-radeon-git facepalm. It never occurred to me when I installed it that there would be such a huge difference between the one supported by manjaro and the git version. I uninstalled it, installed the regular vulkan-radeon, and now it is working great!

    I may have changed to the git version while tinkering for another game. never again.

    And btw, in reference to other games that run vulkan, I tried Dota2, but that one runs natively on linux/steam, so I am not sure it is a valid comparison. It worked fine even while I was still on the git version.
    Now if there is anything you would like me to test for you, feel free to work me out :) and thanks for sticking with me and for your stream of knowledge.

  • @Barabeam.4638 said:

    @ArmoredVehicle.2849 said:

    @Barabeam.4638 said:

    @ArmoredVehicle.2849 said:

    @Barabeam.4638 said:

    @ArmoredVehicle.2849 said:

    @Barabeam.4638 said:
    Hi,

    As always thank you for the great work that helped me greatly over the past ~two years!

    I have come across an issue that prevents me from running the game for some reason. I have included the information posted right after I run debug.sh
    It used to run just fine, however, I have tinkered in the past few weeks with my default wine prefix to run a certain game. However, I thought it shouldn't affect GW2 since it runs on a separate contained pre-fix.

    Any insight is highly appreciated. Thanks! :)

    Hmm, From that log I can't quite tell what could be the issue. Since you were able to run the game in the past, could you please try this package: ftp://jrugia.com:1025/wine_gw2_1.8.5_intel_amd.tar.xz (you may need to copy the link as text and paste in a new tab manually).

    Let me know if it changes anything.

    Thank you for your input. I tried the supplied package, it did not change anything.

    What happens when I click play, is the screen resolution changes to the highest the monitor can handle, and the screen freezes with nothing advancing. I end up killing the task by using the alt+ctl+F2 console. When I kill it the resolution persists on the highest setting, so I need to readjust it manually everytime I run it. I also tried deleting the .dat file to have a fresh install/download of the game data just in case it was a configuration issue. But I will continue to dig for clues, thanks a lot! :+1:

    If you haven't done so already, can you try to run the game in a virtual desktop? You can do this by running the 'wine_settings.sh' file. Try setting it to a small resolution first such as 1280x720.

    I just tried that, the game crashed and gave me a detailed log this time.

    I solved the problem though :D

    the libraries: d3dl10, d3d10_1, d3d10core, d3d11, d3d9, and dxgi were set to native (windows).
    I tried changing them to builtin (wine). And it worked like a charm. I will do more testing now and check out how the performance goes :). Will also update again to your most recent patch

    Thanks a lot!

    That's mighty weird, those dlls are set to native so it uses DXVK/D9VK instead of Wine's Opengl. I will test them on my end maybe I missed something (no AMD card though).

    For the record, do you play any other games that use DXVK or Vulkan?

    EDIT:
    I just tested the v1.8.5 package I linked you yesterday and it works fine on my end.

    @Barabeam.4638 said:

    Edit2: Well, not like a charm, it has performance stutters and a glitchy map. but now I understand that my crash problems was due to DLLs, I will try to mingle with that. maybe enable them all as native, then switching them out one by one to see which one was responsible for not running as intended :). I will post my results as it may help others with similar problems ^^

    Those stutters occur due to the shader cache being freshly built. The game becomes much smoother with subsequent runs as the shaders are saved to the game's folder (appropriately named 'shader cache'). With DXVK this is less noticeable due to faster compilation, Wine's built in D3D is much slower.


    From the looks of it so far it seems something is odd/missing with your Vulkan support.

    Make sure you have at least these packages installed in your system (Manjaro): vulkan-radeon and vulkan-icd-loader

    Another note regarding those set of DLL's: Some of them are meant to be used together for example dxgi.dll and d3d9.dll. In the case of GW2 you can forgive not using d3d10* and d3d11 ones but the other files must work together.

    THANK YOU!

    Turns out I had vulkan-radeon-git facepalm. It never occurred to me when I installed it that there would be such a huge difference between the one supported by manjaro and the git version. I uninstalled it, installed the regular vulkan-radeon, and now it is working great!

    I may have changed to the git version while tinkering for another game. never again.

    And btw, in reference to other games that run vulkan, I tried Dota2, but that one runs natively on linux/steam, so I am not sure it is a valid comparison. It worked fine even while I was still on the git version.
    Now if there is anything you would like me to test for you, feel free to work me out :) and thanks for sticking with me and for your stream of knowledge.

    Glad you solved it :)

    If you could test the v1.9.1 package for me that would be great. That one is using a newer version of Wine (4.21) and any feedback from non debian users is always welcome.

  • Barabeam.4638Barabeam.4638 Member ✭✭
    edited December 19, 2019

    @ArmoredVehicle.2849 said:

    @Barabeam.4638 said:

    @ArmoredVehicle.2849 said:

    @Barabeam.4638 said:

    @ArmoredVehicle.2849 said:

    @Barabeam.4638 said:

    @ArmoredVehicle.2849 said:

    @Barabeam.4638 said:
    Hi,

    As always thank you for the great work that helped me greatly over the past ~two years!

    I have come across an issue that prevents me from running the game for some reason. I have included the information posted right after I run debug.sh
    It used to run just fine, however, I have tinkered in the past few weeks with my default wine prefix to run a certain game. However, I thought it shouldn't affect GW2 since it runs on a separate contained pre-fix.

    Any insight is highly appreciated. Thanks! :)

    Hmm, From that log I can't quite tell what could be the issue. Since you were able to run the game in the past, could you please try this package: ftp://jrugia.com:1025/wine_gw2_1.8.5_intel_amd.tar.xz (you may need to copy the link as text and paste in a new tab manually).

    Let me know if it changes anything.

    Thank you for your input. I tried the supplied package, it did not change anything.

    What happens when I click play, is the screen resolution changes to the highest the monitor can handle, and the screen freezes with nothing advancing. I end up killing the task by using the alt+ctl+F2 console. When I kill it the resolution persists on the highest setting, so I need to readjust it manually everytime I run it. I also tried deleting the .dat file to have a fresh install/download of the game data just in case it was a configuration issue. But I will continue to dig for clues, thanks a lot! :+1:

    If you haven't done so already, can you try to run the game in a virtual desktop? You can do this by running the 'wine_settings.sh' file. Try setting it to a small resolution first such as 1280x720.

    I just tried that, the game crashed and gave me a detailed log this time.

    I solved the problem though :D

    the libraries: d3dl10, d3d10_1, d3d10core, d3d11, d3d9, and dxgi were set to native (windows).
    I tried changing them to builtin (wine). And it worked like a charm. I will do more testing now and check out how the performance goes :). Will also update again to your most recent patch

    Thanks a lot!

    That's mighty weird, those dlls are set to native so it uses DXVK/D9VK instead of Wine's Opengl. I will test them on my end maybe I missed something (no AMD card though).

    For the record, do you play any other games that use DXVK or Vulkan?

    EDIT:
    I just tested the v1.8.5 package I linked you yesterday and it works fine on my end.

    @Barabeam.4638 said:

    Edit2: Well, not like a charm, it has performance stutters and a glitchy map. but now I understand that my crash problems was due to DLLs, I will try to mingle with that. maybe enable them all as native, then switching them out one by one to see which one was responsible for not running as intended :). I will post my results as it may help others with similar problems ^^

    Those stutters occur due to the shader cache being freshly built. The game becomes much smoother with subsequent runs as the shaders are saved to the game's folder (appropriately named 'shader cache'). With DXVK this is less noticeable due to faster compilation, Wine's built in D3D is much slower.


    From the looks of it so far it seems something is odd/missing with your Vulkan support.

    Make sure you have at least these packages installed in your system (Manjaro): vulkan-radeon and vulkan-icd-loader

    Another note regarding those set of DLL's: Some of them are meant to be used together for example dxgi.dll and d3d9.dll. In the case of GW2 you can forgive not using d3d10* and d3d11 ones but the other files must work together.

    THANK YOU!

    Turns out I had vulkan-radeon-git facepalm. It never occurred to me when I installed it that there would be such a huge difference between the one supported by manjaro and the git version. I uninstalled it, installed the regular vulkan-radeon, and now it is working great!

    I may have changed to the git version while tinkering for another game. never again.

    And btw, in reference to other games that run vulkan, I tried Dota2, but that one runs natively on linux/steam, so I am not sure it is a valid comparison. It worked fine even while I was still on the git version.
    Now if there is anything you would like me to test for you, feel free to work me out :) and thanks for sticking with me and for your stream of knowledge.

    Glad you solved it :)

    If you could test the v1.9.1 package for me that would be great. That one is using a newer version of Wine (4.21) and any feedback from non debian users is always welcome.

    Thank you ^^

    I tested the 1.9.1 version with the following setup:
    Hardware: (CPU = AMD Ryzen 5 2600), (GPU = AMD Radeon RX 580), (Ram = 16 GB DDR4), (both OS and game installed on m.2 SSD)
    OS: Manjaro, kernel 5.3.15-1-MANJARO

    In-game settings:
    (Resolution = 1920x1080), (Animation =high), (Antialiasing = SMAA High), (Env. = high), (LOD Dist. = high), (Reflections = none), (Texture = high), (Render Sampling= native), (Shaders = high), (Post Processing = high), (Char. limit = med), (Char. Quality = med), (Ambient occ. = yes), (Best Texturing filter = yes), (Depth Blur = yes), (Effect LOD = yes), (High res. char. text. = yes), (Light Adaptation = yes).

    I have played quite a bit through different situation and here is my input:

    • Solo/party instances > once cached I can get ~110 fps
    • maps not crowded and not complicated ~ 70-80 fps
    • maps not crowded but has sophisticated elements ~ 40-60 fps. I noticed after a while the fps increases (probably due to caching, but takes more time than less sophisticated locations.
    • Very crowded meta ~ 20-40 fps, mostly averaging on the 30 fps.

    Note: The performance settings of my PC for both the CPU and GPU are still automated by the system. I still haven't figured out how to set them manually on performance mode, that may add to the performance. (It was easier to manage these on intel/nvidia on ubuntu). Once I figure out how to manually set them to performance I will provide inputs as necessary.

    Conclusion: There is a very noticeable improvement in performance compared to what I recall in the past. Optimizing the in-game settings will definitely give even higher fps.

    If there is any other specifics you would like me to check or try let me know ^^

  • ArmoredVehicle.2849ArmoredVehicle.2849 Member ✭✭✭
    edited December 20, 2019

    @Barabeam.4638 said:

    @ArmoredVehicle.2849 said:

    @Barabeam.4638 said:

    @ArmoredVehicle.2849 said:

    @Barabeam.4638 said:

    @ArmoredVehicle.2849 said:

    @Barabeam.4638 said:

    @ArmoredVehicle.2849 said:

    @Barabeam.4638 said:
    Hi,

    As always thank you for the great work that helped me greatly over the past ~two years!

    I have come across an issue that prevents me from running the game for some reason. I have included the information posted right after I run debug.sh
    It used to run just fine, however, I have tinkered in the past few weeks with my default wine prefix to run a certain game. However, I thought it shouldn't affect GW2 since it runs on a separate contained pre-fix.

    Any insight is highly appreciated. Thanks! :)

    Hmm, From that log I can't quite tell what could be the issue. Since you were able to run the game in the past, could you please try this package: ftp://jrugia.com:1025/wine_gw2_1.8.5_intel_amd.tar.xz (you may need to copy the link as text and paste in a new tab manually).

    Let me know if it changes anything.

    Thank you for your input. I tried the supplied package, it did not change anything.

    What happens when I click play, is the screen resolution changes to the highest the monitor can handle, and the screen freezes with nothing advancing. I end up killing the task by using the alt+ctl+F2 console. When I kill it the resolution persists on the highest setting, so I need to readjust it manually everytime I run it. I also tried deleting the .dat file to have a fresh install/download of the game data just in case it was a configuration issue. But I will continue to dig for clues, thanks a lot! :+1:

    If you haven't done so already, can you try to run the game in a virtual desktop? You can do this by running the 'wine_settings.sh' file. Try setting it to a small resolution first such as 1280x720.

    I just tried that, the game crashed and gave me a detailed log this time.

    I solved the problem though :D

    the libraries: d3dl10, d3d10_1, d3d10core, d3d11, d3d9, and dxgi were set to native (windows).
    I tried changing them to builtin (wine). And it worked like a charm. I will do more testing now and check out how the performance goes :). Will also update again to your most recent patch

    Thanks a lot!

    That's mighty weird, those dlls are set to native so it uses DXVK/D9VK instead of Wine's Opengl. I will test them on my end maybe I missed something (no AMD card though).

    For the record, do you play any other games that use DXVK or Vulkan?

    EDIT:
    I just tested the v1.8.5 package I linked you yesterday and it works fine on my end.

    @Barabeam.4638 said:

    Edit2: Well, not like a charm, it has performance stutters and a glitchy map. but now I understand that my crash problems was due to DLLs, I will try to mingle with that. maybe enable them all as native, then switching them out one by one to see which one was responsible for not running as intended :). I will post my results as it may help others with similar problems ^^

    Those stutters occur due to the shader cache being freshly built. The game becomes much smoother with subsequent runs as the shaders are saved to the game's folder (appropriately named 'shader cache'). With DXVK this is less noticeable due to faster compilation, Wine's built in D3D is much slower.


    From the looks of it so far it seems something is odd/missing with your Vulkan support.

    Make sure you have at least these packages installed in your system (Manjaro): vulkan-radeon and vulkan-icd-loader

    Another note regarding those set of DLL's: Some of them are meant to be used together for example dxgi.dll and d3d9.dll. In the case of GW2 you can forgive not using d3d10* and d3d11 ones but the other files must work together.

    THANK YOU!

    Turns out I had vulkan-radeon-git facepalm. It never occurred to me when I installed it that there would be such a huge difference between the one supported by manjaro and the git version. I uninstalled it, installed the regular vulkan-radeon, and now it is working great!

    I may have changed to the git version while tinkering for another game. never again.

    And btw, in reference to other games that run vulkan, I tried Dota2, but that one runs natively on linux/steam, so I am not sure it is a valid comparison. It worked fine even while I was still on the git version.
    Now if there is anything you would like me to test for you, feel free to work me out :) and thanks for sticking with me and for your stream of knowledge.

    Glad you solved it :)

    If you could test the v1.9.1 package for me that would be great. That one is using a newer version of Wine (4.21) and any feedback from non debian users is always welcome.

    Thank you ^^

    I tested the 1.9.1 version with the following setup:
    Hardware: (CPU = AMD Ryzen 5 2600), (GPU = AMD Radeon RX 580), (Ram = 16 GB DDR4), (both OS and game installed on m.2 SSD)
    OS: Manjaro, kernel 5.3.15-1-MANJARO

    In-game settings:
    (Resolution = 1920x1080), (Animation =high), (Antialiasing = SMAA High), (Env. = high), (LOD Dist. = high), (Reflections = none), (Texture = high), (Render Sampling= native), (Shaders = high), (Post Processing = high), (Char. limit = med), (Char. Quality = med), (Ambient occ. = yes), (Best Texturing filter = yes), (Depth Blur = yes), (Effect LOD = yes), (High res. char. text. = yes), (Light Adaptation = yes).

    I have played quite a bit through different situation and here is my input:

    • Solo/party instances > once cached I can get ~110 fps
    • maps not crowded and not complicated ~ 70-80 fps
    • maps not crowded but has sophisticated elements ~ 40-60 fps. I noticed after a while the fps increases (probably due to caching, but takes more time than less sophisticated locations.
    • Very crowded meta ~ 20-40 fps, mostly averaging on the 30 fps.

    Note: The performance settings of my PC for both the CPU and GPU are still automated by the system. I still haven't figured out how to set them manually on performance mode, that may add to the performance. (It was easier to manage these on intel/nvidia on ubuntu). Once I figure out how to manually set them to performance I will provide inputs as necessary.

    Conclusion: There is a very noticeable improvement in performance compared to what I recall in the past. Optimizing the in-game settings will definitely give even higher fps.

    If there is any other specifics you would like me to check or try let me know ^^

    Thanks for checking it out, thats' more info than I expected and I'm glad the update to a newer Wine version didn't break anything. :)

  • edited December 22, 2019

    @ArmoredVehicle.2849 I need to speak with you when you have time to rework a little the project have see many compatibility errors.
    If you have time to speak with me have a possible solutions for help the project.
    Discord : https://discord.gg/dE9yn78
    Riot : https://riot.im/app/#/room/#linuxosfr:matrix.org

  • @Barabeam.4638 said:

    Note: The performance settings of my PC for both the CPU and GPU are still automated by the system. I still haven't figured out how to set them manually on performance mode, that may add to the performance.

    as root:
    echo performance > /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor

    for cpu

    for gpu install radeon-profile, run the daemon, set your card up any way you want

  • @VAHNeunzehnsechundsiebzig.3618 said:

    @Barabeam.4638 said:

    Note: The performance settings of my PC for both the CPU and GPU are still automated by the system. I still haven't figured out how to set them manually on performance mode, that may add to the performance.

    as root:
    echo performance > /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor

    for cpu

    for gpu install radeon-profile, run the daemon, set your card up any way you want

    Thank you!
    For the CPU I tried the line you provided and it didn't work, I got > bash: /sys/devices/system/cpu/cpu/cpufreq/scaling_governor: ambiguous redirect
    I googled it a bit and found this line which worked like a charm:
    echo performance | sudo tee /sys/devices/system/cpu/cpu
    /cpufreq/scaling_governor
    I had the radeon-profile installed, but I was missing the daemon, and totally forgot to set it up. got it up and running ^^.

    Now while the max fps is not much higher, I noticed the gameplay in general is smoother! Cheers

  • @04D95143-7F7C-4289-8567-88D4F26CEEF9.2615 said:
    @ArmoredVehicle.2849 I need to speak with you when you have time to rework a little the project have see many compatibility errors.
    If you have time to speak with me have a possible solutions for help the project.
    Discord : https://discord.gg/dE9yn78
    Riot : https://riot.im/app/#/room/#linuxosfr:matrix.org

    Hey, just dropping by to say thanks for the message, I'm currently a bit stuck with work and all the new year stuff but will get in touch at some point :)

  • @Barabeam.4638 said:

    @VAHNeunzehnsechundsiebzig.3618 said:

    @Barabeam.4638 said:

    Note: The performance settings of my PC for both the CPU and GPU are still automated by the system. I still haven't figured out how to set them manually on performance mode, that may add to the performance.

    as root:
    echo performance > /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor

    for cpu

    for gpu install radeon-profile, run the daemon, set your card up any way you want

    Thank you!
    For the CPU I tried the line you provided and it didn't work, I got > bash: /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor: ambiguous redirect
    I googled it a bit and found this line which worked like a charm:

    I am not using bash, that might have been the reason ;)

    echo performance | sudo tee /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor
    

    I had the radeon-profile installed, but I was missing the daemon, and totally forgot to set it up. got it up and running ^^.

    Now while the max fps is not much higher, I noticed the gameplay in general is smoother! Cheers

    btw, if you put your card into performance/high mode: some firmwares don't spin up the fans aggressive enough. If you see sudden every-odd-second stutter, set your own, more aggressive fan profile and run that.

  • @VAHNeunzehnsechundsiebzig.3618 said:

    @Barabeam.4638 said:

    @VAHNeunzehnsechundsiebzig.3618 said:

    @Barabeam.4638 said:

    Note: The performance settings of my PC for both the CPU and GPU are still automated by the system. I still haven't figured out how to set them manually on performance mode, that may add to the performance.

    as root:
    echo performance > /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor

    for cpu

    for gpu install radeon-profile, run the daemon, set your card up any way you want

    Thank you!
    For the CPU I tried the line you provided and it didn't work, I got > bash: /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor: ambiguous redirect
    I googled it a bit and found this line which worked like a charm:

    I am not using bash, that might have been the reason ;)

    echo performance | sudo tee /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor
    

    I had the radeon-profile installed, but I was missing the daemon, and totally forgot to set it up. got it up and running ^^.

    Now while the max fps is not much higher, I noticed the gameplay in general is smoother! Cheers

    btw, if you put your card into performance/high mode: some firmwares don't spin up the fans aggressive enough. If you see sudden every-odd-second stutter, set your own, more aggressive fan profile and run that.

    Thanks for the heads up, I tried adjusting the fan curves and I noticed the gameplay smoother indeed. I guess I will log temperatures and compare the default mode with what I have made to get hints at what temp. I am likely to get stutters to optimize my curve. if all goes well, I will learn how to write a simple script that activates the cpu line, launch radeon-profile, then launch gw2. not sure if that is possible, but will google my way through it and keep you posted as it may help others save time :+1:

  • @ArmoredVehicle.2849 Yes no problem im waiting.
    On my side I started to work on something which is now very clean.
    I would like to see to find the least to work together on it.
    In addition, this corrects several current problems with your project.
    Happy Holidays

  • @draconicrose.6213 said:
    With Wintersday here and orphan routes to follow, any news on getting TaCo to work on Linux, @ArmoredVehicle.2849?

    Hello again @ArmoredVehicle.2849 hope you had a good holiday season! I was wondering if now you might have the time to look into TaCo? I have tried stuff myself, but I honestly can't get it to show up over the game and I'm very much out of my depth with it. Sorry to keep bothering you but it's the ONLY thing that makes me miss Windows.

  • Aaralyna.3104Aaralyna.3104 Member ✭✭✭✭

    @ArmoredVehicle.2849 .

    Someone at the reddit wants to contact you (something with some script he does not want to go to waste or something). The person has no game account (can't type here) so maybe you can reply in his reddit post?

    https://reddit.com/r/Guildwars2/comments/ejys5m/request_for_help_with_reaching_out_to_the_linux/

    I have no reddit account so I can't tell the OP there I forwarded his reddit post directly to you. Maybe Caolanmactire (the OP) sees this here as he can read the forum. This is the reason I didn't do it in a straight PM to you ;)

  • @Aaralyna.3104 said:
    @ArmoredVehicle.2849 .

    Someone at the reddit wants to contact you (something with some script he does not want to go to waste or something). The person has no game account (can't type here) so maybe you can reply in his reddit post?

    https://reddit.com/r/Guildwars2/comments/ejys5m/request_for_help_with_reaching_out_to_the_linux/

    I have no reddit account so I can't tell the OP there I forwarded his reddit post directly to you. Maybe Caolanmactire (the OP) sees this here as he can read the forum. This is the reason I didn't do it in a straight PM to you ;)

    Thanks for the heads up, I inspected his scripts. Will test them out and include them in the next release :)

    Sorry for not being very active lately. I'm still checking the thread regularly though.

  • I've been probing around with the available cpu schedulers a bit and the difference of running around in Amnoon is quite big
    (12 Core Ryzen 3900X with Navi on 4K)

    on both FSync and ESync:

    Default CFS: 35-55 FPS
    Zen Patched CFS: 40-65 FPS
    PDS: 30-55 FPS


    MuQSS and BMQ don't seem to like FSync

    MuQSS ESync: 30-45 FPS
    MuQSS FSync: 15-35 FPS
    BMQ Esync: 35-55 FPS
    BMQ Fsync: 30-45 FPS


    But for BMQ limiting GW2 to 6 cores with taskset -c 0-5 does bring it to 40-60 FPS.

    GPU was forced to high for this test (2GHz shader clock), but a short test againt auto (1.3 to 1.8 GHz shader clock) showed no difference in fps.
    cpufreq set to performance


    So at least for an high core Ryzen with AMD GPU the -zen kernels with patched CFS scheduler seem to be the best choice for Guild Wars 2

  • ArmoredVehicle.2849ArmoredVehicle.2849 Member ✭✭✭
    edited January 9, 2020

    I've updated the packages to v1.9.2.

    Changelog:

    • Updated DXVK to 1.5.1 (D9VK is now part of DXVK)
    • Replaced the setup and launch scripts with improved ones thanks to the work of reddit user ‘caolanmactire’. (thank you).

    @liberodark: My apologies for not contacting you yet, will try to find some time next week hopefully.

  • Ceit.1869Ceit.1869 Member ✭✭

    You might want to try the cpupower command for tinkering with frequency scaling instead of mucking around in /sys, it's a bit more straightforward to run under sudo and gives more info. The Arch Linux wiki has a good explanation as well as a lot on the different governors: https://wiki.archlinux.org/index.php/CPU_Frequency_Scaling#Scaling_governors

  • @ArmoredVehicle.2849 said:
    I've updated the packages to v1.9.2.

    Changelog:

    • Updated DXVK to 1.5.1 (D9VK is now part of DXVK)
    • Replaced the setup and launch scripts with improved ones thanks to the work of reddit user ‘caolanmactire’. (thank you).

    @liberodark: My apologies for not contacting you yet, will try to find some time next week hopefully.

    I will take a look at any changes you made and work on updating the Lutris installers of necessary

  • Barabeam.4638Barabeam.4638 Member ✭✭
    edited January 18, 2020

    @Ceit.1869 said:
    You might want to try the cpupower command for tinkering with frequency scaling instead of mucking around in /sys, it's a bit more straightforward to run under sudo and gives more info. The Arch Linux wiki has a good explanation as well as a lot on the different governors: https://wiki.archlinux.org/index.php/CPU_Frequency_Scaling#Scaling_governors

    I tried it out, it works like a charm as well, and fairly easy to memorize.

    @ArmoredVehicle.2849 I updated my version to 1.9.2 and did some gaming yesterday. Will play more tonight and keep you posted if there is anything of interest. Thanks!

    edit:
    Now after a few days of testing 1.9.2, I noticed that I more frequently get an error that affects my chatting Edit: That was fixed when I updated my Manjaro to the newest kernel released recently. Thanks!

  • jinxlaw.9467jinxlaw.9467 Member ✭✭
    edited January 21, 2020

    Is anyone having an issue where the client gets stuck while downloading at "Files Remaining: 49,100"? I tried Armored's 1.9.2, and two different lutris versions of gw2, but it does the same thing.
    I'm running on Manjaro kde.

    https://imgur.com/a/ISIkMOj

    Update: I moved the incomplete .dat file that I downloaded on linux to windows and test it on the native windows client. The .dat file was corrupted. I will either fully download gw2 then move it to linux or redownload gw2 on linux until it works.

  • @jinxlaw.9467 said:
    Is anyone having an issue where the client gets stuck while downloading at "Files Remaining: 49,100"? I tried Armored's 1.9.2, and two different lutris versions of gw2, but it does the same thing.
    I'm running on Manjaro kde.

    https://imgur.com/a/ISIkMOj

    Hi, I am running Manjaro KDE, 1.9.2 was slightly buggy until I updated my Manjaro to the most recent kernel. If your system is up to date though, there might be something else and I hope you find the help/guidance you need :) -providing hardware info might help I think

  • dusanyu.4057dusanyu.4057 Member ✭✭✭

    new version of wine shipped that is supposed to be a big improvement for gaming
    https://www.bleepingcomputer.com/news/linux/wine-50-released-with-numerous-gaming-improvements-for-linux/

  • Kiso.8465Kiso.8465 Member ✭✭
    edited January 25, 2020

    ive started using ubuntu and got a new ssd, which made the load times better but i got problems with going from like 30-40 fps walking around to 1 fps at random moments / would latency add to that problem or just laptop performance? also the download is stuck constantly on 40k things to download and resets every time if i dont download the entire thing

  • @Kiso.8465 said:
    ive started using ubuntu and got a new ssd, which made the load times better but i got problems with going from like 30-40 fps walking around to 1 fps at random moments / would latency add to that problem or just laptop performance? also the download is stuck constantly on 40k things to download and resets every time if i dont download the entire thing

    Since it's a fresh setup, the 1 fps moments you're seeing is probably due to first time shader compilation, eventually it smooths out on subsequent runs. As for the download issue I really can't tell, the forum lately had it's fair share of launcher issue.

  • yeah, I mentored some newbies playing on windows who have the download issue as well.

  • Kiso.8465Kiso.8465 Member ✭✭

    @VAHNeunzehnsechundsiebzig.3618 said:
    yeah, I mentored some newbies playing on windows who have the download issue as well.

    yeah, i apparently have to get an vpn as well to play gw2 now for some reason , ISP is not being helpful so i wasnt sure what can cause what

  • wanya.1697wanya.1697 Member ✭✭✭

    it might be enough to set a specific download server for the launcher in one of the threads it was mentioned as a solution for some at least

  • Nicodemus.1486Nicodemus.1486 Member ✭✭
    edited January 27, 2020

    any word from @liberodark / 04D95143-7F7C-4289-8567-88D4F26CEEF9.2615? or are they gone? i've been waiting for their installer to update.

    i went ahead and just did a write into with overwrite, which should be enough i think.

  • DoktorBaum.3017DoktorBaum.3017 Member
    edited January 31, 2020

    Since this appears to be a tech support thread, I'm just going to test my luck here. I tried about 4 different ways to run GW2 on Ubuntu 18.04, 3 of them pretty much worked (Armored Vehicle Scripts / manually get all the Wine things / Lutris) up to the moment of downloading all the files for gw2.dat in the installation process through the launcher. There is always about 10% missing and then it gives up and there is no way to get it to finish. It doesn't freeze, the megabytes shown are constantly rising, but 1: up to a point of being way too big, 2: the gw2.dat doesn't grow anymore, 3: It never gets more of the files mentioned on the launcher, 4: it never gets away from 90% or 91%.
    Running the game anyways (since it is ready to play at like 30% already) is, as far as I know, known to have unplayable performance and does so in my case too.

    Right now, I want to see if I can get 100% on windows first, and if so, just copy the files to my Ubuntu system (the wiki tells me they are not machine dependant). I've seen kind of similar launcher issues reported in here and maybe someone has an idea of where it might come from, since not everyone can use windows.
    @jinxlaw.9467 did that work for you?

    Update: another thread mentions something that could be related

    Some servers currently have corrupted files, causing the launcher to get stuck downloading the same file endlessly. To fix this, use the following option:

    -assetsrv 54.84.216.160

  • DoktorBaum.3017DoktorBaum.3017 Member
    edited January 31, 2020

    okay, at this point I am 90% sure this problem has nothing to do with the linux launching methods. Sorry for bothering this thread.

  • update 3: in case anyone tries - like me - looking for a solution here in this thread, i might have it now.
    100% not a linux issue, it appears the european servers are giving out corrupted files, switching the servers to download from to US seems to solve the problem for most people (by using arguments -assetsrv [current IP] [or] origincdn.101.arenanetworks.com , possibly -patchconnections 1). in some cases apparently people had to be connected to their router via cable as oppose to wireless.
    again, doesn't really belong here I think but maybe it helps a few people coming across.

  • Kanok.3027Kanok.3027 Member ✭✭✭
    edited February 1, 2020

    So, trying to get this up and running on my brand new installation of Manjaro (latest release and fully updated), and I got this:
    000b:fixme:winediag:start_process Wine Staging 4.21 is a testing version containing experimental patches. 000b:fixme:winediag:start_process Please mention your exact version when filing bug reports on winehq.org. 000b:err:wineboot:main Cannot set the dir to L"C:\\windows" (2) 000b:err:wineboot:create_disk_serial_number wine: failed to create L"C:\\.windows-serial". 000b:err:wineboot:process_run_key Error running cmd L"C:\\windows\\system32\\winemenubuilder.exe -a -r" (2). wine: could not open working directory L"unix\\home\\jesse\\Guild Wars 2\\data\\drive_c\\GW2\\", starting in the Windows directory. 000d:fixme:service:scmdatabase_autostart_services Auto-start service L"PlugPlay" failed to start: 2 000d:fixme:service:scmdatabase_autostart_services Auto-start service L"WineBus" failed to start: 2 000d:fixme:service:scmdatabase_autostart_services Auto-start service L"MountMgr" failed to start: 2 000b:err:shell:SHGetFolderPathAndSubDirW Failed to create directory L"C:\\users\\jesse\\Application Data". 000b:err:shell:SHGetFolderPathAndSubDirW Failed to create directory L"C:\\users\\jesse". 000b:err:shell:SHGetFolderPathAndSubDirW Failed to create directory L"C:\\users\\jesse\\Local Settings\\Application Data". 000b:err:shell:SHGetFolderPathAndSubDirW Failed to create directory L"C:\\users\\jesse\\Local Settings\\Temporary Internet Files". 000b:err:wininet:cache_containers_init Couldn't get path for default container 0 000b:err:shell:SHGetFolderPathAndSubDirW Failed to create directory L"C:\\users\\jesse\\Local Settings\\History". 000b:err:wininet:cache_containers_init Couldn't get path for default container 1 000b:err:shell:SHGetFolderPathAndSubDirW Failed to create directory L"C:\\users\\jesse\\Cookies". 000b:err:wininet:cache_containers_init Couldn't get path for default container 2 Wine cannot find the ncurses library (libncurses.so.5). 0009:fixme:reg:GetEnabledXStateFeatures 0009:fixme:heap:RtlSetHeapInformation 0x20000 0 0x22fca0 4 stub 0009:fixme:heap:RtlSetHeapInformation 0x580000 0 0x22fc80 4 stub 0009:fixme:heap:RtlSetHeapInformation 0x580000 1 (nil) 0 stub 0009:fixme:ntdll:NtQuerySystemInformation info_class SYSTEM_PERFORMANCE_INFORMATION 0009:err:winediag:wined3d_dll_init Setting multithreaded command stream to 0. 0009:err:winediag:wined3d_dll_init The GLSL shader backend has been disabled. You get to keep all the pieces if it breaks. 0009:err:ddraw:ddraw_create_swapchain Failed to create swapchain, hr 0x8876086c. 0009:err:ddraw:ddraw_set_cooperative_level Failed to create swapchain, hr 0x8876086c. 0009:err:shell:SHGetFolderPathAndSubDirW Failed to create directory L"C:\\users\\jesse\\Application Data". 0011:fixme:ver:GetCurrentPackageId (0x165fda0 (nil)): stub 0017:err:winediag:nodrv_CreateWindow Application tried to create a window, but no driver could be loaded. 0017:err:winediag:nodrv_CreateWindow The explorer process failed to start.

    System is: Pentium G4560, GTX 1050 TI, 16GB Ram, Manjaro Juhraya 18.1.5, video-nvidia-440 proprietary drivers

    EDIT: Used the installer instead of the package

    I Rev, therefore I am. Don't ruin my favorite class, please and thank you.