"defeat Mark II Beta Exterminator": Power Golem outside the ring, Exterminator Core didn't spawn — Guild Wars 2 Forums

"defeat Mark II Beta Exterminator": Power Golem outside the ring, Exterminator Core didn't spawn

deatine.2498deatine.2498 Member ✭✭
edited March 10, 2018 in Bugs: Game, Forum, Website

Edit: I changed the original because the bug I suspect I experienced was somewhat different than I first thought.

So, at specific points in the battle with the Mark II Beta Exterminator, it spawns a Unstable Exterminator Core that you have to attack if you want to do actual damage to the Mark II Beta Exterminator itself.
I went through that once, but at the second point at which it was supposed to occur, no Unstable Exterminator Core spawned anywhere to be seen, a weird Power Golem with the green swords above it spawned outside the ring behind the barrier. You can't go or shoot through the barrier. If I can't kill the Power Golem for Volatile Cores (?) and can't hit an Exterminator Core (because it's not there) the fight does not proceed.

It is also impossible to die in this fight. It is also not possible to just stand on the Exterminator and kill it over the course of an estimated three hours with autoattacks because it pushes you back occasionally.
So I had to restart the game to get out. Which means, I have to restart the story in the Charr kindergarden and have to do the (in my opinion much too long) "get the cubs to safety with Braham" thing again.
Did I just miss something?

Comments

  • I had a similar problem with this fight. The cores did spawn until the golem was down to 31% health, but then using the leyline crystal skill did nothing except the count (I had 4) went from 4 to 3 and then up to 4 again. Meanwhile the golem lost 1% health regardless and I don't think anything I did made a difference since at 15% I got so bored I went to make a snack and when I came back, it was nearly dead - its health went down by itself, but at last the exterminator core had spawned, but I wasn't there to see how it happened. This was in BST timezone around 9.30pm 15th May, solo with character Athelis Drae, level 80 human necromancer.

  • This is sad to read as it's 12 days after this post l just experienced the same issue. I tried submitting a bug report but do not expect much from it. :/ Did it help to force quit out of the game and then try it again?

  • I didn't need to since it lost health by itself and eventually died, though it was very slow.

  • edited August 7, 2018

    Updated: made my way through. Resolved.

  • morfiend.9736morfiend.9736 Member ✭✭
    edited August 11, 2018

    ran into this today, pounding on this thing, doing almost no damage, need mobs/crystals not spawning during event (at least in the first 30% so far and first 15 minutes of beating on it..)

    afk to make some coffee. while i wait on this thing to die over an hour..

    update: around 60% the mobs starting dropping the ley crystals (finally). unsure if guild wars was lagging or this fight is supposed to take 30 minutes. smh.

  • Currently just chillin whilst this is going on. Fr tho this blows xD
    Health ain't budgin at all and I was so close to killing it. ;-;
    Imma just wait
    If that doesn't work I'll just restart the whole thing.

  • More kitten garbage kitten buggy LS mechanics, in a fight that takes an eternity and still can't be completed due to bugs. kitten waste of my time.

  • 2019 and still not fixed.
    lel

  • Same issue with the 3 crystals skill to 4 then back to 3 then 4 again and nothing is actually happening. I am doing damage to it but so little that it's taking forever.

  • Here too exactly the same, not fixed.

©2010–2018 ArenaNet, LLC. All rights reserved. Guild Wars, Guild Wars 2, Heart of Thorns, Guild Wars 2: Path of Fire, ArenaNet, NCSOFT, the Interlocking NC Logo, and all associated logos and designs are trademarks or registered trademarks of NCSOFT Corporation. All other trademarks are the property of their respective owners.