Story Mission Disconnects At The End Of Quest — Guild Wars 2 Forums

Story Mission Disconnects At The End Of Quest

Bought the game on Monday and have not had a single issue until I started going through HoT story mode this evening. At the end of every single story mission it disconnects me and continues to do so. There will be that one time out of 6-10+ tries that it will won't disconnect but it's getting beyond a joke now.

I noticed that there's a lot of people in the same situation as me and have been for months now. The "fix" that tech support posted is not working at all.

Is AreaNet looking into this or do they have any updates as I'm not the most tech savvy so I would need a dummy's guide to try other fixes (I've done basic stuff like changing graphics, rebooting my router etc but nothings worked). I feel that this a bit ridiculous just to play the story mode of a game, I'm also not impressed that this is happening after I've just forked out nearly £90. If I cannot get this to work then I hope a refund will be given.

My computer specs re as follows (Windows 10);

Device Name : DESKTOP-NII5JIC
Processor: Inter(R) Core(TM) i5-7400 CPU @ 3.00GHz 3.00
Installed RAM: 8.00 GB
Graphic Card : NVIDIA GeForce GTX 1050 Ti 4GB

Comments

  • Hey Moonbear! I have recently came back to GW2 and have been playing for little over a week now and i keep having the same issue and its absolutely disgusting, playing 40mins to sometimes over an hour on a chapter in story mode only to be on the final talk between the npc's before your finished and the server just disconnects you....
    i have tried every option on the forums and everything i could think of, even reinstall windows and that just to see if it would make a difference and it dont.. i have friends who play with me and they live 5 mins around the corner from me and yet they have no issues?
    My computer beasts the game on max settings and i can play the game in open world pvp wvw all the new zones no problem no disconnects and the moment i try to do a little story mode it kicks me.. i would really love to get this fixed or someone find out what the issue is so i can play the game as i really enjoy playing it..

    my pc specs:
    Intel i7-6700k (oc'd) 4.8GHz
    16 gigs ram
    geforce 1070 gtx

  • MoonBearBush.1943MoonBearBush.1943 Member ✭✭
    edited April 13, 2018

    It would appear they need to pull their fingers out if you get what I mean.. This has been ongoing since the end of last year at least and it would appear there's no actual fix for it. Just a band aid for one or two missions.

    My friends and I also play together (we live relatively close to each other) and I have the better internet out of us all yet I'm the one having issues with this.

    I'm leaning towards a full refund because the more I look into this the more it would appear AreaNet really are not interested in fixing this absurd issue.

  • Inculpatus cedo.9234Inculpatus cedo.9234 Member ✭✭✭✭

    You can peruse the Dev Tracker for the latest Dev response to this issue.
    You can try a VPN. You can try minimizing the client right before trouble spots. Some players have had success with those tips.
    You can contact the Tech CS Team via the 'Support' link above/below.

    Good luck.

  • Just sat and tried all of that and even changed my client ports with no luck. Going to send a refund ticket through . My money/time will better spent elsewhere.

    Thanks for trying to help though. Greatly appreciated.

  • Yeah, nothing works to fix this. I re-did a mission 3 times the other day, wasted over an hour before it let me finish. Today I did the Modremoth fight and it kicked me to character select as I was about to turn you know who into salad, and I was, still am absolutely livid I wasted all that time. I'm seriously considering asking for a refund, but this is just terrible. Not to mention the bugs that still exist from release because the devs want to line their pocket making new micro-transactions instead of actually fixing the game.

    Yes, I've submitted a ticket about, but no, no one has contacted me, but this comes back to the lining their pockets comment, it takes WAY to long to get a reply, and I'm 99% sure the reply will be trash and this issue won't be fixed.

  • So I got a response stating that I was not entitled to a refund as I'd used the gems I got from buying the deluxe edition of PoF. What's ridiculous about this is I bought the game on 9th April (Monday past) so I can even use the Black Lion Trading Post properly (I believe it unlocked today) so my gems were spent on utility items (infinite picks and some other account bound stuff like that etc.) and the rest was used for some gold which I haven't used as I was waiting until I could use the trading post properly.

    I also bought the standard edition of HoT alongside the deluxe version of PoF.

    I'm rather baffled that I'm not entitled to refund when I forked out a substantial amount of money on a game that I know doesn't work properly (same thing happens in PoF) because I used the gems that came with it?! That some shady practice right there...

    So what I've got with my dealing of AreaNet so far is that once they have your money they will do their kitten best to not give it back even though the vast majority of their game will not work.

    I've tried all I bloody can to get it to work like running it as admin, changing client ports to 443, 80 etc, turning off my AV/adding GW2 into the exceptions list, trying that host code nonsense that AreaNet posted as a"fix", rebooting my router (please note that I am plugged straight in via cable). I even called my internet provider Virgin to troubleshoot this and they can't see anything wrong on my end but I have requested a new router to test that out anyways.

    I love this game and used to think AreaNet are good folks but I'm beginning to lose my kitten here.

  • Healix.5819Healix.5819 Member ✭✭✭✭
    edited April 14, 2018

    @MoonBearBush.1943 said:
    So I got a response stating that I was not entitled to a refund as I'd used the gems I got from buying the deluxe edition of PoF.

    When they refund an account, they simply take away the expansion, so they're not willing to refund it because they can't revert the spent gems. You could try asking to have everything refunded and to terminate the account, suggesting a chargeback if they refuse. If you want to be permabanned and have no plans of buying anything through DigitalRiver again, you can force a chargeback instead.

    This problem has been linked to various causes, with basically everything in between potentially causing it. It is possible for your router to be the problem, or even your network adapter. Software can cause it, but you'd need a clean install to truly check that. I remember one person confirming it was caused by their download manager for example, and recently Discord has been a common problem in other areas. Someone claimed it was a GPU problem, where running another 3D application in the background with GW2 windowed got them past the point. Some have had success minimizing the game, if you get disconnected during cutscenes, or can get someone else to carry you past the point. Some have fixed it by simply running the game on port 80 or 443 (-clientport 80), while others had to use a VPN.

    If you have a separate modem and router, try connecting directly to the modem. If you can't, try disabling the additional features on the router, such as the firewall, QoS and UPnP support. If you have an alternate way to connect (wireless / different network card), try it. If you haven't tried a VPN, TunnelBear is a popular choice, while support recommends proXPN.

  • I've managed to progress through 3 missions now and the only way I get it to work is by skipping the cut scenes and spamming attacks/moving my character during NPC dialogues. I did however still DC but the mission reward popped up so when I logged back all was good.

    I find this utterly ridiculous the length of effort it takes to get this game to work. I played GW back in the day and GW2 when it first came out on an alternative account never had a single issue.

    This seems to all stem from their expansions. The fact they have yet to pull their finger out their a*se and fix this is beyond a joke (after doing some digging it would appear this has been an ongoing issue since HoT was released not far off 3 years ago.)

    I've tried the VPN tactic, I'm in windowed mode already, all my network drivers are up to date along with my graphics card, rebooted my router and contacted my internet provider who said there's nothing wrong on my end (have ordered a new up to date router to test regardless, that will be here in a week), done the whole client port thing, disabled my AV and added into my exceptions list, I never run Discord in the background and I'm plugged straight in via Ethernet and still no luck.

    The thing is I can go hours on end when I'm off work and not have a single DC (yet to try fractals, raids etc which I'm sure will be a barrel of laughs).

    Another thing that just adds salt to the wound is that to even test this kitten, I have to spend 20-60+ minutes grinding through a quest until the very end to see whatever I've changed has worked.... that is an absolute joke.

    In regards to chargebacks, are you saying that I can push them to fully refund me everything but I will never be able to play one of their games again on this account? Would you be able to make an alternative account and start fresh if they somehow fix this further down the line? (change email address etc.)

  • Healix.5819Healix.5819 Member ✭✭✭✭

    @MoonBearBush.1943 said:
    In regards to chargebacks, are you saying that I can push them to fully refund me everything but I will never be able to play one of their games again on this account?

    A chargeback is a last resort option where you contact your bank/card to forcibly refund the payment. Doing this will permanently terminate your GW2 account, which can't be undone, and your billing information will be blacklisted by DigitalRiver, which is the payment processor GW2 uses. It has these penalties because it's seen as fraud from the vendor's perspective and they are forced to deal with the processing fees, which is why support should accept your request to refund everything and terminate your account instead. If you wanted to make a completely new account in the future, you could, you just wouldn't be able to buy anything using your card again if you force a chargeback.

    @MoonBearBush.1943 said:
    My friends and I also play together (we live relatively close to each other) and I have the better internet out of us all yet I'm the one having issues with this.

    You could try taking your computer to them to rule out your network, then try using their computer, which would either confirm it's your computer or an account problem.

  • @MoonBearBush.1943 said:
    So I got a response stating that I was not entitled to a refund as I'd used the gems I got from buying the deluxe edition of PoF. What's ridiculous about this is I bought the game on 9th April (Monday past) so I can even use the Black Lion Trading Post properly (I believe it unlocked today) so my gems were spent on utility items (infinite picks and some other account bound stuff like that etc.) and the rest was used for some gold which I haven't used as I was waiting until I could use the trading post properly.

    I also bought the standard edition of HoT alongside the deluxe version of PoF.

    I'm rather baffled that I'm not entitled to refund when I forked out a substantial amount of money on a game that I know doesn't work properly (same thing happens in PoF) because I used the gems that came with it?! That some shady practice right there...

    So what I've got with my dealing of AreaNet so far is that once they have your money they will do their kitten best to not give it back even though the vast majority of their game will not work.

    I've tried all I bloody can to get it to work like running it as admin, changing client ports to 443, 80 etc, turning off my AV/adding GW2 into the exceptions list, trying that host code nonsense that AreaNet posted as a"fix", rebooting my router (please note that I am plugged straight in via cable). I even called my internet provider Virgin to troubleshoot this and they can't see anything wrong on my end but I have requested a new router to test that out anyways.

    I love this game and used to think AreaNet are good folks but I'm beginning to lose my kitten here.

    I am also with Virgin MoonBear.. i was also going to ring them and ask for a new router.. its strange because after googling i see that elder scrolls online also have this issue with disconnecting.. all over the world, its bloody kitten.. i was bloody well enjoying the PoF story and close to finishing it and then it just got too much like you said playing for 40mins to over an hour only to get kicked off .. not to mention we are gated in terms of achievements and mounts we need to go the story for ... bad game design honestly

  • @Qutyp.1325 said:

    @MoonBearBush.1943 said:
    So I got a response stating that I was not entitled to a refund as I'd used the gems I got from buying the deluxe edition of PoF. What's ridiculous about this is I bought the game on 9th April (Monday past) so I can even use the Black Lion Trading Post properly (I believe it unlocked today) so my gems were spent on utility items (infinite picks and some other account bound stuff like that etc.) and the rest was used for some gold which I haven't used as I was waiting until I could use the trading post properly.

    I also bought the standard edition of HoT alongside the deluxe version of PoF.

    I'm rather baffled that I'm not entitled to refund when I forked out a substantial amount of money on a game that I know doesn't work properly (same thing happens in PoF) because I used the gems that came with it?! That some shady practice right there...

    So what I've got with my dealing of AreaNet so far is that once they have your money they will do their kitten best to not give it back even though the vast majority of their game will not work.

    I've tried all I bloody can to get it to work like running it as admin, changing client ports to 443, 80 etc, turning off my AV/adding GW2 into the exceptions list, trying that host code nonsense that AreaNet posted as a"fix", rebooting my router (please note that I am plugged straight in via cable). I even called my internet provider Virgin to troubleshoot this and they can't see anything wrong on my end but I have requested a new router to test that out anyways.

    I love this game and used to think AreaNet are good folks but I'm beginning to lose my kitten here.

    I am also with Virgin MoonBear.. i was also going to ring them and ask for a new router.. its strange because after googling i see that elder scrolls online also have this issue with disconnecting.. all over the world, its bloody kitten.. i was bloody well enjoying the PoF story and close to finishing it and then it just got too much like you said playing for 40mins to over an hour only to get kicked off .. not to mention we are gated in terms of achievements and mounts we need to go the story for ... bad game design honestly

    I contacted Virgin and they're giving me the Super Hub 3 (I've heard mixed reviews..._) for free, The reason I did this is to increase my speed to VIVID 350 which can only be used through the SH3 which is an extra £10 on top. I'll see how that goes.

    I literally done the starting mission in PoF to get the mount and haven't touched it since so I hope I don't have anymore issues in that regard.

    A little tip that's helped me get through 4-5 story missions on HoT, Play in Windowed mode and during NPC dialogues, move your character back and forth with Q&E and spam spells etc. This has helped me big time!! I get hand cramps but it makes this kitten games Story playable somewhat.

  • I had the same problem with disconnecting on story mode missions. Having talked to technical support we discovered that my problem was that I didn’t have up to date video driver. I have updated and the problem went away. Thought this might help some people.

  • Zeral.8249Zeral.8249 Member ✭✭

    It's such a shame that any devs aren't responding or letting people know they're listening here. I've only just started having the issue as of two days ago and I gotta tell ya. It's really f'kin frustrating and the fact that it always happens on the final interaction just before completion is even worse when the mission has no checkpoints. Very demotivating.

  • Inculpatus cedo.9234Inculpatus cedo.9234 Member ✭✭✭✭

    You can find the Dev posts on the issue in the 'official' Story Disconnections thread.

    Good luck.

©2010–2018 ArenaNet, LLC. All rights reserved. Guild Wars, Guild Wars 2, Heart of Thorns, Guild Wars 2: Path of Fire, ArenaNet, NCSOFT, the Interlocking NC Logo, and all associated logos and designs are trademarks or registered trademarks of NCSOFT Corporation. All other trademarks are the property of their respective owners.