Confront Balthazar — Guild Wars 2 Forums

Confront Balthazar

Completed the fight as a minion master and ranger and it did not proceed. The dragon is still chained and Balthazar was standing there with no health swaying like a drunk leaving us no way to proceed. Is this a known bug should i bother trying it all again?

Comments

  • I was having the same issue right now although I know this is a bit late since you posted a few days ago. But it maybe useful to someone else with this problem. What worked for me was jumping down from the final platform and running up the stairs on the right. That activated the animation and the story proceeded. But before I hopped on the final platform with the bunnyroo mount and that made my story stall.

    Remember who you are and what you stand for.

  • Completed this story point solo, then tried to help my wife complete it the next day - on the same account. Balthazaar kills me instantly, but leaves my wife in down state. Balth and Vlast dissapear and my wife is able to leave down state. No way to proceed from here because Vlaast and Balth are gone... any thoughts? This happened twice the same way.

  • My wife tried it alone and the glitch never happened. This definitely sounds like a bug.

©2010–2018 ArenaNet, LLC. All rights reserved. Guild Wars, Guild Wars 2, Heart of Thorns, Guild Wars 2: Path of Fire, ArenaNet, NCSOFT, the Interlocking NC Logo, and all associated logos and designs are trademarks or registered trademarks of NCSOFT Corporation. All other trademarks are the property of their respective owners.