Can't sign in support page — Guild Wars 2 Forums

Can't sign in support page

I don't know what to do: I can't log in to the support service. Redirect in account management, and in support page again requires a username and password. Tried different IP addresses, browsers, clear cookies and cache, changed computers/devices. How do I sign in with my name on the support page? Anonymous tickets don't seem to reach - there are no notifications on the mail (watched all the folders and places, mail gmail).

Comments

  • Inculpatus cedo.9234Inculpatus cedo.9234 Member ✭✭✭✭
    edited June 13, 2018

    Anonymous submission should work, are you not receiving the near-immediate automated response? Have you tried white-listing all guildwars2.com and Arena.net addresses?
    The loop can be caused by adblockers/add-ons in browsers, as well as changed Account Names (email addresses associated with the game account).

    Good luck.

  • Once on my current email was attached to another account. Something must have gone wrong. It remains to find a way that will allow to reach support.

  • Inculpatus cedo.9234Inculpatus cedo.9234 Member ✭✭✭✭

    Are you receiving the automated "We got your ticket submission" email (from the anonymous submission), or no?

  • Only after the third sent ticket came notification to the mail! Hooray!

  • Inculpatus cedo.9234Inculpatus cedo.9234 Member ✭✭✭✭

    If you do happen to receive any other notifications, make sure to close all the duplicate tickets.

©2010–2018 ArenaNet, LLC. All rights reserved. Guild Wars, Guild Wars 2, Heart of Thorns, Guild Wars 2: Path of Fire, ArenaNet, NCSOFT, the Interlocking NC Logo, and all associated logos and designs are trademarks or registered trademarks of NCSOFT Corporation. All other trademarks are the property of their respective owners.