Plague Scarab Egg bugged — Guild Wars 2 Forums
Home Bugs: Game, Forum, Website

Plague Scarab Egg bugged

I did the meta event and killed all the 11 plague experiment but no drop of the plague scarab egg. New Gw 2 feature ?

Comments

  • I can confirm that this happened for multiple people when I did the event. I was lucky enough to get it, though only on the third plague experiment that I tagged. My girlfriend tagged several but didn't get the reward.

  • polvere.2805polvere.2805 Member ✭✭✭

    I am actually sure i got enough credit as i landed various attacks with my thief that has quite the strong burst. If it requires even more damage then it's true BS. It's a meta event and it's normal that a lot of people gather there. Also i got Gold partecipation. One of the most annoying collection from the alpha beetle to the steam cretures and the anomaly.

  • @Illconceived Was Na.9781 said:
    I can confirm that this won't happen if you start with the plague experiment farthest away. The zerg focuses on ones closest to the dead asuran and by the time you get to those, it's less likely that you can do enough damage to get credit for the collection.

    We'll try this out, thanks for the tip.

    As polvere says, I would agree that this does not seem like a desirable situation; a meta event requires a zerg by default, and a zerg makes it hard to land hits on things that die quickly. Having a collection requirement locked behind a mob like that is likely to result in frustrating experiences for a large number of players.

  • polvere.2805polvere.2805 Member ✭✭✭
    edited July 1, 2018

    I did as @Illconceived Was Na.9781 Suggested and it worked.

    I have to say that it's stupid that you have to use such stupid tricks for a collection. Just give the item on event completition and we would all be happy with it

  • @polvere.2805 said:
    I did as @Illconceived Was Na.9781 Suggested and it worked.

    Glad you got the item, which is the most important thing (for now).

    Hype is the path to the dark side. Hype leads to unfulfilled expectations. Disappointment leads to anger. Anger leads to disgust. Disgust leads to "oh, new shinies! I'm back!"

  • zaekeon.5128zaekeon.5128 Member ✭✭✭

    done the event twice and hit and smashed everything and didn't get credit...what it wrong with this thing.

  • polvere.2805polvere.2805 Member ✭✭✭

    Try as if was suggested above. Anet wont probably fix it soon

  • We tried it as well, and it worked indeed to focus on the last one instead of going with the zerg.
    I still doubt whether this is currently working as intended, but at least there is a workaround.

  • Almost every other meta-event an item drops you get given an item if you do something right. Even if a bit of damage, you'd still get it as the server will register you having done damage to the thing. I've done Tarir a lot, and others (Tequatl, Karka Queen, etc.) and it works this way IME. Having a set percentage of damage done to an immobile mob is dumb and seems very buggy to me.

  • Eziair.2509Eziair.2509 Member ✭✭
    edited September 29, 2019

    Over a year later and I can say this still happends.
    Did the meta about 10mins ago and got... nothing. Will try tomorow the tip to hit the last one first, thank you.

    Edit : Yep it still works. Me and some other player got the last one down to 1/3 hp before the masses tured up and I got the Plague Egg.

  • Confirmed as of today.
    ran into the same bug, no drops for 3 turns of the meta
    i followed the advice about separating from the zerg and hitting the last one solo, instant pop! thanks for the pro tip.

    P.S. if you have a big zerg, u need to be careful about the mobs as they will obstruct you from hitting the plagued sac and you will need to take them out first. They will however be veterans with big HP bars , so recommend getting your stuff for this venture :)

  • Mickey.4207Mickey.4207 Member ✭✭

    April 2021 and it's still happening. I will try the workaround but GG Anet. 3 years later you still haven't fixed this. Amazing.