AVOID: NVIDIA GeForce Experience — Guild Wars 2 Forums

AVOID: NVIDIA GeForce Experience

Actions taken for more smoother Guildwars 2:
1. Updated NVIDIA and selected "Fresh install / Do not automatically optimise new games"
2. Copied 32bit and 64bit GW2.exe (renamed GW2.exe to GW2_x86 first) to another location (actually another partitioned drive)
3. Deleted old GW2 folder in old location
4. Ran GW2-x86.exe (which will create GW2_x86-64.exe ....)
5. Shortcuts created for:
"X:\somepath\GuildWars 2\Gw2_x86.exe" -diag
"X:\somepath\GuildWars 2\Gw2_x86-64.exe" -diag

 (because you never know)

6. Told NVIDIA no I don't want shadowplay
7. Did not tell NVIDA my current location of this GW2
8. Altered video settings in game

Comments

  • What do you mean smoother? Are you having framerate issues with Nvidia GeForce Experience? I've been using it since its launch and I don't have any issues. Although, I do not optimize any games.

  • Well it only detects the 32bit client not the 64bit client in the game folder.
    And I've seen confused settings if you get NVIDIA to optimize the game (I sent feedback to NVIDIA, no reply). This has been the case for about 6 months now.

©2010–2018 ArenaNet, LLC. All rights reserved. Guild Wars, Guild Wars 2, Heart of Thorns, Guild Wars 2: Path of Fire, ArenaNet, NCSOFT, the Interlocking NC Logo, and all associated logos and designs are trademarks or registered trademarks of NCSOFT Corporation. All other trademarks are the property of their respective owners.