Scourge - Torch of Proficiency Greyed Out — Guild Wars 2 Forums

Scourge - Torch of Proficiency Greyed Out

I just returned after about a year away and found that I had saved up enough hero points to fill out my elite specialization. I chose Scourge.

Problem: Torch Proficiency shows as greyed out still even though Scourge is at 100%. I tried to equip a torch but it's red, indicating the specialization Scourge is required.

Screenshot of elite specialization wheel:
https://imgur.com/sNllMkc

Screenshot of torch, can't equip:
https://imgur.com/dtsNztg

I tried to click on Torch but the tooltip says 'you can wield torches' so I'm confused about what to do. I'm level 80 and I have all the core completed (see screenshot). Do I need part of Reaper or something?

Comments

  • Glacial.9516Glacial.9516 Member ✭✭✭

    Did you equip the Scourge trait line? You can only use the scourge weapon and abilities when you have the trait line equipped (and it can only be equipped in the 3rd slot). The same applies to reaper so it would be impossible to use both Greatsword and Torch in the same build, for example.

  • Oh boy, I feel dumb. Thank you! I'm all set now. :)

©2010–2018 ArenaNet, LLC. All rights reserved. Guild Wars, Guild Wars 2, Heart of Thorns, Guild Wars 2: Path of Fire, ArenaNet, NCSOFT, the Interlocking NC Logo, and all associated logos and designs are trademarks or registered trademarks of NCSOFT Corporation. All other trademarks are the property of their respective owners.