[BUG & Solution] Tower Down Level 70 - Page 3 — Guild Wars 2 Forums
Home Bugs: Game, Forum, Website

[BUG & Solution] Tower Down Level 70

13>

Comments

  • Sill bugged in 2020, the quest hangs with Tonn unresponsive after blowing up the second tower. The quest log says "Escort Tonn's team to the undead towers" and the quest marker point me to the third tower.

  • Pirana.2601Pirana.2601 Member ✭✭

    Just ran this a little bit ago and the first time around it bugged with Tonn hanging back, figured it probably bugged, came here and read people were having similar issues.

    The second time I ran through it, I kept as close to Tonn as possible, most of the time in these story missions, I jump way ahead and start killing things and wait for the pack to catch up, this time i figured I would 'baby' the mission and stay as close as possible. Moving forward, even after disposing of mobs, I would run back in Tonn's direction, sometimes he would just stand there until I got close to him, at that point, he would move. Then anytime I came across the next mob, I would use a ranged weapon to pull the npc's to me as to not move out of Tonn's area. This method worked perfectly. Whether or not this is a work-around or not, I have no idea. I might have just gotten lucky and it didn't bug. Either way though, try it and see if it works out.

  • Same, I played through mission as normal, accompanying the team to take out the enemies as we took down each tower, but got stuck on the final tower, with Tonn hanging back by the second tower location. When I left the instance and tried it again going around and killing all the enemies before triggering the first cutscene with Tonn, I was able to play it through to the end. (I also killed all the enemies who were in the water near the third tower, though there were some spiders that spawned on the trip I either missed or don't spawn unless you have the team with you, but I was still able to finish anyway.)

  • Saebur.7215Saebur.7215 Member

    Tonn stuck after destroying first tower....how is this still a bug O_O