Unable to purchase gems [Merged] - Page 5 — Guild Wars 2 Forums

Unable to purchase gems [Merged]

1235>

Comments

  • ArenaNet must really not want my money...
    Tried to purchase gems. Tried different amounts... nothing

    https://imgur.com/a/EobyjMW?

  • It's funny. I had this problem a little over 2 weeks ago, and they fixed it, and I bought gems, and now the problem is back again. YAY! Time to wait 2 - 4 days for a response again and not be able to buy the items I want in the gem store again because they'll leave before then! :)

  • Strange to encounter a gaming company that don't want our money. Most have any and all payment methods tested and verified before even releasing the game, whereas this game is several years old, and this still ain't fixed properly.
    I am not going to submit any reports on this, just too much hassle with waiting several days to be able to give you some money.

  • Inculpatus cedo.9234Inculpatus cedo.9234 Member ✭✭✭✭

    And yet, the vast majority are able to purchase Gems. If there is an individual issue with your account, you are best served by contacting the Billing CS Team, (who will then contact the payment provider).

    Good luck.

  • Same issue, last 4 days the trading has not been working. And creating a ticket is a NO GO, they request game Serial nr, come the f. down, where is my sn now since i had the game since launch.. yepp,, unknown location.. JFC..

  • Inculpatus cedo.9234Inculpatus cedo.9234 Member ✭✭✭✭

    'They' don't require the Serial Key number. It clearly states on the ticket form to 'skip' if you do not have that information.

  • I just submitted a ticket on this myself. Was looking forward to buying the shrine guardian ears. So much for that.
    Also, as always, the ticketing system is an absolute, shameful mess. Constantly logs you out after you've signed in. It Fails the CAPTCHA authentication (and never prompts you to try and verify anything).
    It's almost like they dont WANT people to submit tickets...

  • Problem is persisting for me as well. Was fine a couple days ago, but now it's the same error message trying every few hours or so.

  • Xenic.1387Xenic.1387 Member ✭✭

    Issue is present for me as well. I tried PayPal and Credit Card and same error that was posted by Blink Squish

  • i am still facing same problem are they ever going fix this, this is the only game have issue with purchases that i have played ....

  • Inculpatus cedo.9234Inculpatus cedo.9234 Member ✭✭✭✭

    If you want your issue addressed, you will need to contact the Billing CS Team. (Support link above/below.)

  • Having the same problem! Cant buy gems. Kinda getting annoyed

  • zoejo.2317zoejo.2317 Member ✭✭

    I'm in the same situation and impressed that this goes so far back in time without solutions, as evidenced by this thread.
    Anyway, rebooting PC and router did nothing for me.
    Gem cards are basically unobtainable where I live - the retailers they mention don't even operate here, and none of their websites even has gem cards...
    I'm assuming I'll miss the gem store deal that made me want to buy gems in the first place.

    Bummer.

  • Inculpatus cedo.9234Inculpatus cedo.9234 Member ✭✭✭✭

    @zoejo.2317 said:
    I'm in the same situation and impressed that this goes so far back in time without solutions, as evidenced by this thread.
    Anyway, rebooting PC and router did nothing for me.
    Gem cards are basically unobtainable where I live - the retailers they mention don't even operate here, and none of their websites even has gem cards...
    I'm assuming I'll miss the gem store deal that made me want to buy gems in the first place.

    Bummer.

    You can contact the Billing CS Team via the 'Support' link for assistance (as posted many times in this thread).

    Good luck.

  • zoejo.2317zoejo.2317 Member ✭✭

    @Inculpatus cedo.9234 said:

    @zoejo.2317 said:
    I'm in the same situation and impressed that this goes so far back in time without solutions, as evidenced by this thread.
    Anyway, rebooting PC and router did nothing for me.
    Gem cards are basically unobtainable where I live - the retailers they mention don't even operate here, and none of their websites even has gem cards...
    I'm assuming I'll miss the gem store deal that made me want to buy gems in the first place.

    Bummer.

    You can contact the Billing CS Team via the 'Support' link for assistance (as posted many times in this thread).

    Good luck.

    I did. Thanks!

©2010–2018 ArenaNet, LLC. All rights reserved. Guild Wars, Guild Wars 2, Heart of Thorns, Guild Wars 2: Path of Fire, ArenaNet, NCSOFT, the Interlocking NC Logo, and all associated logos and designs are trademarks or registered trademarks of NCSOFT Corporation. All other trademarks are the property of their respective owners.