BUG: ’’Taking All Their Secrets’’ [Fixed] — Guild Wars 2 Forums
Home Bugs: Game, Forum, Website

BUG: ’’Taking All Their Secrets’’ [Fixed]

Alga.6498Alga.6498 Member ✭✭✭✭
edited September 3, 2018 in Bugs: Game, Forum, Website

I have a in-game problem regards the newest META in Kourna.
The ’’Taking All Their Secrets’’ achievement has been stuck on 7/10 and wont rasie despite grabbing the loots for atleast x20 now.
Is this a common bug that you’re already working on?
I tried to get someone to answer my question afterwards the META was over if they had the same problem, only 1 replied and he had the same issue.
Please let me know!

I've already contacted Support about this and they only told me to report the bug here….. :confused:


  • I've got the same problem. I'm stuck at 0/10 and I've looted the place enough to get the achievement several times over.

  • Same here. I'm stuck at 2/10 and I have done the META at least 2 more times yesterday and today, but the achievement doesn't progress.

  • Same problem here, stuck a 5/10 , done META 4 times since then and it wont update

  • Rawr.9467Rawr.9467 Member ✭✭✭

    Same here, stuck at 7/10 as well

    You either die a noob or live long enough to be called a hacker

  • I have the same problem, stuck at 1/10 even though i completed the event multiple times.

  • Same, stuck at 6/10 and have done it at least 10 times more over the past few days.

  • Still not fixed after latest patch...

  • same here stuck at 9/10,
    there is also another forum post on the same issue:

  • Still stuck, at 9/10.

  • I have the same problem, stuck at 4/10 even though i completed the event different times.

  • Mewcifer.5198Mewcifer.5198 Member ✭✭✭✭

    Stuck 4/10 here

    My list of suggestions for GW2
    Max Masteries | 20k AP

  • still bugged for me since 3 weeks :'(

  • I've put a ticket and bugreport in, bug is still there

  • Agrippa Oculus.3726Agrippa Oculus.3726 Member ✭✭✭
    edited August 20, 2018

    still stuck at 6/10

    Also tried a couple of things that might or might not have to do with it:

    • Tried with 2 different character, both having completed the latest story instances
    • Tried with a character not fully completed the latest story instances
    • Tried by using the pass
    • Tried by using a (mesmer) portal
    • Tried by participating in the full meta event chain (although, this just comes to mind: lately haven't given any spare parts to the collector though)
    • Tried opening all chests from before the stairs up till the room itself

    But I always keep on being stuck at 6/10
    Anyone else still has a suggestion?

    Btw, might be completely unrelated, but I'm also not able to use the portal in front of the bridge from/to the Allied Encampment.

  • Am having same issue....stuck at 8/10. Also noticed that the portal mentioned in the previous post does not work for me, either. In addition, in playing through the living story again for the achievements, I've noticed some other strange things, too. First, when I went to progress the story to the Forwarned instance by using the portal created by Blish in the Desert Highlands, I was sent instead to the Domain of Kourna map proper. When I was finally able to enter the Forwarned instance, and was trying to accomplish the Disorienting achievement, I received zero credit toward that achievement and am stuck at 0/25 even though I was able to obtain the proper response from the Awakened defenders I was doing it to many times. There seem to be bugs a-plenty in the Domain of Kourna at the moment, and I don't mean beetles and scarabs.

  • Alga.6498Alga.6498 Member ✭✭✭✭

    Yay, it's finally fixed! :)