GRIFFON MOUNT MAJOR BUGS [WITH VIDEO] — Guild Wars 2 Forums

GRIFFON MOUNT MAJOR BUGS [WITH VIDEO]

GoldenKeyboard.6830GoldenKeyboard.6830 Member
edited September 27, 2017 in Bugs: Game, Forum, Website

As shown in the video; the Griffon mount while mid-air dismounts and locks the user of any movement until they fall to their death.

This is most consistent when using the swoop attack key to dive and space to acquire speed boost.

My theory is that we are interfering with the skybox and therefore dismounted.

LINK TO VIDEO :

Comments

  • Kidel.2057Kidel.2057 Member ✭✭✭

    I was able to reproduce this 100% of the time during one of the Griffon adventures. It doesn't have to do with the skybox (at least in that case) but with the use of the skills unlocked by the second mastery (that you're forced to use to complete the adventure). So basically the adventure can't be completed because the mount goes in a T pose, you're marked as dismounted, you fall and you die. At respawn you have the griffon in T pose, you can summon it again to fix the animation, but no skill works (not even normal gliding). The only fix is to go back to character selection screen.

    Another weird (and unrelated) bug is if you summon the mount immediately after you spawn on a new map. Basically the camera doesn't follow the character and I can move but the camera stands still in the initial position, and I see my character go far and far away. This is fixed by unsummoning and summoning the mount again and works with any mlount.

  • I also have this bug, makes riding the griffon a complete mess.

    If I run a griffon master course it always bugs in the same places, its like some points of the maps bugs the griffon.

  • This keeps happening to me. I cant use my giffon at all.

  • Bumps up. This NEEDS ATTENTION. Its been days, my 250g + time for collection events and mastery + xp grind isnt worth it when my mount bugs midway.

  • This bug really makes the Griffon Adventures no fun. :(
    I can accept when it's my own fault that I failed the adventure, but half the time this bug forces me to start over.
    I've given up on the Derelict Delve griffon run for now because the bug keeps activating at the second/third ring.

  • So, I'm clearly dumb, but I don't even understand the controls for the fully upgraded Griffon. Maybe some is due to this bug, but what exactly is "movement skill 2" - the keyboard for "2" is blank, what else is it? Even the description for diving says to use "Swoop" or "movement skill 1". Are these different things? I'm very confused!

  • I find this happening to me on the ground as well.

    @Jong.5937 said:
    So, I'm clearly kitten, but I don't even understand the controls for the fully upgraded Griffon. Maybe some is due to this bug, but what exactly is "movement skill 2" - the keyboard for "2" is blank, what else is it? Even the description for diving says to use "Swoop" or "movement skill 1". Are these different things? I'm very confused!

    If you look in your key bindings it is defaulted at 'C'

  • Crise.9401Crise.9401 Member ✭✭
    edited September 30, 2017

    I have had this happen several times too, most frequent when I was messing about with griffon in Rata Sum, also in Black Citadel though. Happens when you use the unnamed "pull up" skill unlocked by the second mastery as far as I can see (trying to use wing flap for a speed boost at the same time might increase the likelihood).

  • Jong.5937Jong.5937 Member ✭✭

    @Jazzyforcefield.3954 said:
    If you look in your key bindings it is defaulted at 'C'

    Thanks, confirmed, I am stupid! :)

  • Ayumi Spender.1082Ayumi Spender.1082 Member ✭✭✭✭

    I get this all the time trying to use the speed flight.
    Everything else on Griffon is fine except that. I've fallen to my death way too many times because of it.

  • Came here to make sure this is bumped as well and keeps happening to myself. was excited to try out the new mastery and when I tried it in any maps or altitudes I'd get it 100% of the time. This is a new thing for the game so wouldn't expect it to run 100% smoothly from the get go but really hope they can fix this soon so I may enjoy the mount after all the work to get it.

  • Jong.5937Jong.5937 Member ✭✭

    It doesn't seem to happen for me if I use the special movement key binds (V and C, by default) instead of "Swoop".

  • Ayumi Spender.1082Ayumi Spender.1082 Member ✭✭✭✭

    @Jong.5937 said:
    It doesn't seem to happen for me if I use the special movement key binds (V and C, by default) instead of "Swoop".

    I just tried that one and the speed up is not even close to what the swoop one does.

  • castlemanic.3198castlemanic.3198 Member ✭✭✭✭

    I dont know how much use this would be to the devs, but at one point me and a guildie who were using the griffin at the same time were dismounted in the exact same fashion, remounted in mid air but still dropped like rocks. We both were in chat like "kitten just happened?" and communicated back and forth. I personally havent been able to replicate the results, nor have i tried to do it, but it HAS happened to me randomly.

    Don't know what the cause is or if that provides any useful information, sometimes it happens once in a blue mine, othertimes twice in 5 minutes.

    Whataboutism is disingenuous at best. If you join a debate and provide little to no proof when the other side provides lots of evidence, you can't then declare yourself the winner of that debate.

  • Happens constantly to me as well.

  • Is it happening in PoF or lvl 80 areas? Is it due to crossing from one effective level area to another?

  • Llethander.3972Llethander.3972 Member ✭✭✭

    Don't use the attack (#1) skill to dive. Use the Mount Movement key (check your keybinds for it). This issue only occurs when using the attack skill to execute dives.

  • Ayumi Spender.1082Ayumi Spender.1082 Member ✭✭✭✭

    @Heimskarl Ashfiend.9582 said:
    Is it happening in PoF or lvl 80 areas? Is it due to crossing from one effective level area to another?

    Happens everywhere.

  • Latorn.4209Latorn.4209 Member ✭✭
    edited October 6, 2017

    My friends and I have run into the same issue multiple times :(

    Edit: May have found a fix by using "Mount Ability 1 & 2" keybinds

  • Was wondering if it was just me , too. I use a Nostromo n52 for controls mainly. I press 1 and go to a dice, press the spacebar key, and it flies out at speed. Does not seem to matter if I flap or not, 99% of the time is stops dead and fall to my death. Someone said to try V instead, so put V on the middle mouse button, still having the same issue.

    Have used the Nostromo n52 & n52 TE (no macros used) for a game crontroller across many games and prefer it. Then see others that are 30 second (or thereabout) on their griffon races, and me I get going and then this but flattens the Griffon in flight. Can't dismount in mid-air, and the griffon is only there, dead, graphically. Soon as I die, press F6 (remapped to Griffon) twice to get out of it. First F6 Griffon shows me standing on top of it, but it's still spread eagle. Press F6 again and can get out of it to resummon.

    Not sure what the issue is either. At first was able to put in a dive, pull up really hard and to my surprise had gained altitude. But on those times the stupid griffon would go into a stall - not moving forward. So I;d have to press forward again ... then it dropped. So was thinking the game had lagged and thought I stalled. Since that happened, every time I go into a dive and hit spacebar key or V it will go for some unknown amount of time. and .... drop. So when it happened again I'd flap, which seemed to cause the griffon to slow back down, and .... drop. Argh!

  • Locce.8405Locce.8405 Member ✭✭✭

    I have this happen to me all the time. I use dive maneuvers quite frequently and when I mistime the pulling up and collide with something or when an enemy ranged attack hits me at the wrong moment... T-pose and doom. Sometimes I get out of this when with luck the griffon dive attack triggers during a hop instead of the player skill 1, but often enough this problem persists even after death and can only be resolved with a relog.

  • Pimpology.6234Pimpology.6234 Member ✭✭✭
    edited October 7, 2017

    can't even dismount at all while riding griffon, key bound and not in combat

    but for that effect doesn't even have to be in adventure. happened to me in open world.

    I'm The DEVIL.

  • Very annoying bug. Have died numerous times to this.

  • @Llethander.3972 said:
    Don't use the attack (#1) skill to dive. Use the Mount Movement key (check your keybinds for it). This issue only occurs when using the attack skill to execute dives.

    ^100% this, if you still have problems while keeping to this, come back again

  • It does not seem as prevalent as before but it does still continue to happen. Did manage to get one massive dive, and remembered had to pull up sooner than expected and gosh of I didn't fly across the zone lickity split!

    Tried again in a shallower area, got a modest speed boost. Landed, did it again to get to an event, was flying then ... yup, griffon decided to go on coffee break in flight. So the bus is still there. Maybe it's on older or slower machines, or those of us with low bandwidth internet?

  • @GoldenKeyboard.6830 said:
    LINK TO VIDEO :

    That is a nice mix of armor what is it?

  • atheria.2837atheria.2837 Member ✭✭✭

    @Kidel.2057 said:
    I was able to reproduce this 100% of the time during one of the Griffon adventures. It doesn't have to do with the skybox (at least in that case) but with the use of the skills unlocked by the second mastery (that you're forced to use to complete the adventure). So basically the adventure can't be completed because the mount goes in a T pose, you're marked as dismounted, you fall and you die. At respawn you have the griffon in T pose, you can summon it again to fix the animation, but no skill works (not even normal gliding). The only fix is to go back to character selection screen.

    Another weird (and unrelated) bug is if you summon the mount immediately after you spawn on a new map. Basically the camera doesn't follow the character and I can move but the camera stands still in the initial position, and I see my character go far and far away. This is fixed by unsummoning and summoning the mount again and works with any mlount.

    My guildmate had this happen - she won't report it because she is tired of not getting any answers from anyone even with customer support tickets.

©2010–2018 ArenaNet, LLC. All rights reserved. Guild Wars, Guild Wars 2, Heart of Thorns, Guild Wars 2: Path of Fire, ArenaNet, NCSOFT, the Interlocking NC Logo, and all associated logos and designs are trademarks or registered trademarks of NCSOFT Corporation. All other trademarks are the property of their respective owners.