"Connection error(s) detected. Retrying..." — Guild Wars 2 Forums

"Connection error(s) detected. Retrying..."

Hi, i get this message "Connection error(s) detected. Retrying..." when i try to launch the launcher in normal and in repair mode. The Gw2 site told me to use CMD to reset some stuff, to reset my router (which I had a techinician do, I live in a student complex and do not have access to reset the router myself.) I reset my computerr and it still did not work. Then i tried to install the game on another computer and it gets the same message as the original one. The guy told me that I would have to wait until tomorrow to see if the problem insists and said that the fault must lie with arenanet because all other connections are fine, which they are. But I know arenanet and this stuff happens evenly, but what can i tell him? what actually causes the problem in the first case? Is it unmatching IPs? something to do with ipv6? I know that this problem wont solve itself because ive encountered it before many times.. sigh... Only with anet for some reason NOT POINTING FINGERS, NOT AT ALL :DD But yeah, again what should I tell the guy the problem is? Cuz I cant even redownload the game because I cant reach anet servers on any of my computers. Thank you

Comments

  • Deimos.4263Deimos.4263 Member ✭✭✭

    It may be the case that the default port used for gw2 (6112) is blocked by your network administrators. Try adding -clientport 80 or -clientport 443 to your shortcut options to have it use the same ports browsers do:

    https://wiki.guildwars2.com/wiki/Command_line_arguments

  • Healix.5819Healix.5819 Member ✭✭✭✭

    This message on the launcher means it can't connect to the patch server. You can quickly test your connection to the server by visiting the patch index (alternate primary server), which should be a text-only page with numbers.

    If you're running Gw2Setup.exe, rename it to Gw2.exe and place it wherever you want to install it. Right click Gw2.exe > properties > and if it says it's blocked, unblock it. You can use the following option with Gw2.exe to use the primary patch server (this IP is only valid for a few days):
    -assetsrv 52.86.76.75

    Alternatively, try using Google DNS:
    https://developers.google.com/speed/public-dns/docs/using

  • @Healix.5819 said:
    This message on the launcher means it can't connect to the patch server. You can quickly test your connection to the server by visiting the patch index (alternate primary server), which should be a text-only page with numbers.

    If you're running Gw2Setup.exe, rename it to Gw2.exe and place it wherever you want to install it. Right click Gw2.exe > properties > and if it says it's blocked, unblock it. You can use the following option with Gw2.exe to use the primary patch server (this IP is only valid for a few days):
    -assetsrv 52.86.76.75

    Alternatively, try using Google DNS:
    https://developers.google.com/speed/public-dns/docs/using

    Thanks a lot! the IP worked wonderfully, but I wonder what will happen when it changes? Must I simply remove it and hope it will figure itself out?

  • Healix.5819Healix.5819 Member ✭✭✭✭
    edited September 26, 2018

    @Lipzipper.3160 said:
    Thanks a lot! the IP worked wonderfully, but I wonder what will happen when it changes? Must I simply remove it and hope it will figure itself out?

    Eventually the IP will stop working, so if you've included it in your shortcut, remember to remove it the next time you see the connection error message.

    There could be a problem with your default DNS provider, so a proper permanent solution would be switching to a different one, like 1.1.1.1 or Google. Since you mentioned testing it on a different computer, you probably didn't do this, but if you've ever modified your hosts file for GW2, undo it.

    If you'd like to compare results, you can lookup the IPs with cmd.exe using your default provider, and again with 1.1.1.1 and/or 8.8.8.8 (Google):
    nslookup assetcdn.101.arenanetworks.com
    nslookup assetcdn.101.arenanetworks.com 1.1.1.1
    nslookup assetcdn.101.arenanetworks.com 8.8.8.8

    If you want to permanently use the -assetsrv option, you can try using the name instead of the IP, though this won't work if your DNS is the problem. The alternative name for the CDN is:
    -assetsrv drwkwiejruot6.cloudfront.net

    If you must use the primary server:
    -assetsrv origincdn.101.arenanetworks.com

    If you want to keep using the IP, you'll need to look it up every time the connection fails:
    nslookup origincdn.101.arenanetworks.com 1.1.1.1

  • @Healix.5819 said:

    @Lipzipper.3160 said:
    Thanks a lot! the IP worked wonderfully, but I wonder what will happen when it changes? Must I simply remove it and hope it will figure itself out?

    Eventually the IP will stop working, so if you've included it in your shortcut, remember to remove it the next time you see the connection error message.

    There could be a problem with your default DNS provider, so a proper permanent solution would be switching to a different one, like 1.1.1.1 or Google. Since you mentioned testing it on a different computer, you probably didn't do this, but if you've ever modified your hosts file for GW2, undo it.

    If you'd like to compare results, you can lookup the IPs with cmd.exe using your default provider, and again with 1.1.1.1 and/or 8.8.8.8 (Google):
    nslookup assetcdn.101.arenanetworks.com
    nslookup assetcdn.101.arenanetworks.com 1.1.1.1
    nslookup assetcdn.101.arenanetworks.com 8.8.8.8

    If you want to permanently use the -assetsrv option, you can try using the name instead of the IP, though this won't work if your DNS is the problem. The alternative name for the CDN is:
    -assetsrv drwkwiejruot6.cloudfront.net

    If you must use the primary server:
    -assetsrv origincdn.101.arenanetworks.com

    If you want to keep using the IP, you'll need to look it up every time the connection fails:
    nslookup origincdn.101.arenanetworks.com 1.1.1.1

    Oh my, thank you so much! This thread is now the most valuable connection fix site on the web! What you've created here is pure art!

    No, i'm not sarcastic haha

  • There's the Knowledge Base, as well:

    https://help.guildwars2.com/hc/en-us/articles/201863018
    https://help.guildwars2.com/hc/en-us/articles/230665807-Problems-Downloading-or-Patching

    Sometimes handier than searching through the forums.

    Good luck.

  • @Inculpatus cedo.9234 said:
    There's the Knowledge Base, as well:

    https://help.guildwars2.com/hc/en-us/articles/201863018
    https://help.guildwars2.com/hc/en-us/articles/230665807-Problems-Downloading-or-Patching

    Sometimes handier than searching through the forums.

    Good luck.

    Thank you, but I am aware, these are the sites i referred to that did not help me. To anyone else that might have the same problem, a very easy and fast fix was given here for us who do not have great knowledge of what DNS ivp6 and other IP address stuff actually is and how it works

  • I have the same issue. The same connection issue. The repair DOES NOT work with that. It still needs a connection. Everything else related to Internet works but not the game :( Anet fix the launcher!

  • Did you try to add this? -assetsrv drwkwiejruot6.cloudfront.net

  • Lipzipper.3160Lipzipper.3160 Member ✭✭
    edited October 2, 2018

    @Archdevil.1748 said:
    I have the same issue. The same connection issue. The repair DOES NOT work with that. It still needs a connection. Everything else related to Internet works but not the game :( Anet fix the launcher!

    Right click the gw2 launcher and select properties

    Replace the similar text in the window with this -assetsrv drwkwiejruot6.cloudfront.net

    It should look like this then and work if the DNS is not the problem
    "C:\Program Files\gw2\gw2.exe.exe" -assetsrv drwkwiejruot6.cloudfront.net

    The text before the - is different depending on what u have named the folders and where you have placed them

    Note that there is a "space" between " and -

  • MORT.3721MORT.3721 Member

    There's another possible solution. At least it worked for me.
    Go to \AppData\Roaming (it is on system drive in your personal folder)
    Then find Guild Wars 2 folder and delete it completely.
    Yes, it will remove your settings, but that's small price for the fix, i guess

©2010–2018 ArenaNet, LLC. All rights reserved. Guild Wars, Guild Wars 2, Heart of Thorns, Guild Wars 2: Path of Fire, ArenaNet, NCSOFT, the Interlocking NC Logo, and all associated logos and designs are trademarks or registered trademarks of NCSOFT Corporation. All other trademarks are the property of their respective owners.