Bug: Chuka and Champawat IV Secluded Tour — Guild Wars 2 Forums

Bug: Chuka and Champawat IV Secluded Tour


This collection is stuck at 7/9 for me. I have completed both the Griffonrook Run and Craze's Folly jumping puzzles but neither have awarded the related feasibility report. I have submitted bug reports with screenshots through the game.

As it stands I am unable to progress this collection. All of the other reports were awarded fine and most were done on the same day as these two.

If anyone else has had similar experience, and knows a way to get the items awarded then please share.




  • Same issue here with griffonrook jp it's not getting updated, I've redone the jp several times also reinstalled gw2 but nothing so far, submitted a ticket now it's just a waiting game

  • Nokomis.5076Nokomis.5076 Member ✭✭✭

    From the wiki for Craze's Folly, I've read the following line:

    You can get the Craze's Folly Feasibility Report needed for Chuka and Champawat IV: Secluded Tour just by walking to the end of the left tunnel on the ground.

    Maybe you can try this?

    I don't know how the Collection works, but the chest at Griffonrook Run can only be opened with a Bomb. Did you just run to the end of the JP or also opened the chest?

    Was I able to help you or give you a hint? Click on Helpful and/or Thumbs up, I would appreciate it alot!
    When you encounter a bug ingame, at first you should file a ticket via the ingame command /bug, as only this way the devs will know exactly where you were, when the bug happened.

  • I've done the griffonrook jp with the bomb, although wiki does say that the chest isn't needed for the report to be updated just that your character reaches the end of the jumping puzzle for the collection.

  • It's still bugged. I've submitted a report with a screen shot of me standing next to the opened chest at the end of the JP. I've also seen on wiki where it states you do not need the bomb to get the achievement for the collection. Awaiting feedback from the bug devs....

  • Drecien.4508Drecien.4508 Member ✭✭✭

    I remember only having to get past the chest on the tip of the ledge to gain the achievement. No need to open the chest.

    New mount skins?! Anet take my money!

  • I tried the very edge, on the tip, I've tried standing on the chest, I've run across all four areas of the platform with the chest to include killing the last griffon up top and eating the egg at the far end. Nothing.

  • Yoshi.6780Yoshi.6780 Member ✭✭
    edited March 3, 2019

    Worked for me

  • Klinch.2964Klinch.2964 Member
    edited June 27, 2019

    I'm currently in the same boat with Craze's Folly. I've opened the chest, run all around the platform, but nothing. I cannot get this collection to trigger. Edit: it finally triggered

©2010–2018 ArenaNet, LLC. All rights reserved. Guild Wars, Guild Wars 2, Heart of Thorns, Guild Wars 2: Path of Fire, ArenaNet, NCSOFT, the Interlocking NC Logo, and all associated logos and designs are trademarks or registered trademarks of NCSOFT Corporation. All other trademarks are the property of their respective owners.