Summoning w/Superior Run of the Lich/Ogre — Guild Wars 2 Forums

Summoning w/Superior Run of the Lich/Ogre

Is there a problem with the summoning on the Superior Run of the Lich and Ogre? I applied the Ogre one first and haven't see a rock dog appear in combat. I did the same with the Lich and haven't seen a jagged horror appear. Is this a chance for them to appear or is summoning just broken?

Comments

  • DeanBB.4268DeanBB.4268 Member ✭✭✭✭

    Rock dog works for me.

    X__________________________
    (Signature Required)

  • Tekoneiric.6817Tekoneiric.6817 Member ✭✭✭✭

    @DeanBB.4268 said:
    Rock dog works for me.

    Do they only work on specific professions?

  • DeanBB.4268DeanBB.4268 Member ✭✭✭✭

    I have a set on a melee necromancer that I haven't played much since the change. When combat starts, the dog appears. It's kinda funny since the dog is way bigger than my asura!

    X__________________________
    (Signature Required)

  • Tekoneiric.6817Tekoneiric.6817 Member ✭✭✭✭

    @DeanBB.4268 said:
    I have a set on a melee necromancer that I haven't played much since the change. When combat starts, the dog appears. It's kinda funny since the dog is way bigger than my asura!

    Does it appear in all game modes (PvE, PvP, WvW)? I tried in PvE and WvW with my engineer. I have the Ogre one on my ranger and it doesn't appear in combat. I even removed all armor and weapon except the one with the Ogre ruin in case another rune or sigil was causing the problem and notta. I took my eng into combat with the flame thrower. Anyone have any suggestions or insight on this?

  • Pterikdactyl.7630Pterikdactyl.7630 Member ✭✭✭✭

    @Tekoneiric.6817 said:

    @DeanBB.4268 said:
    I have a set on a melee necromancer that I haven't played much since the change. When combat starts, the dog appears. It's kinda funny since the dog is way bigger than my asura!

    Does it appear in all game modes (PvE, PvP, WvW)? I tried in PvE and WvW with my engineer. I have the Ogre one on my ranger and it doesn't appear in combat. I even removed all armor and weapon except the one with the Ogre ruin in case another rune or sigil was causing the problem and notta. I took my eng into combat with the flame thrower. Anyone have any suggestions or insight on this?

    You need to apply 6 of the same runes total to your armor, each on a different piece, for it to take effect. The numbers next to the bonuses are what you get when you have that many runes applied to your currently equipped armor. This means that you'll have to choose whether you want Ogre or Lich if you want the summon.

  • Tekoneiric.6817Tekoneiric.6817 Member ✭✭✭✭

    @Pterikdactyl.7630 said:

    @Tekoneiric.6817 said:

    @DeanBB.4268 said:
    I have a set on a melee necromancer that I haven't played much since the change. When combat starts, the dog appears. It's kinda funny since the dog is way bigger than my asura!

    Does it appear in all game modes (PvE, PvP, WvW)? I tried in PvE and WvW with my engineer. I have the Ogre one on my ranger and it doesn't appear in combat. I even removed all armor and weapon except the one with the Ogre ruin in case another rune or sigil was causing the problem and notta. I took my eng into combat with the flame thrower. Anyone have any suggestions or insight on this?

    You need to apply 6 of the same runes total to your armor, each on a different piece, for it to take effect. The numbers next to the bonuses are what you get when you have that many runes applied to your currently equipped armor. This means that you'll have to choose whether you want Ogre or Lich if you want the summon.

    Ah, strange that I did not know this. Makes sense now. Thanks for the info.

©2010–2018 ArenaNet, LLC. All rights reserved. Guild Wars, Guild Wars 2, Heart of Thorns, Guild Wars 2: Path of Fire, ArenaNet, NCSOFT, the Interlocking NC Logo, and all associated logos and designs are trademarks or registered trademarks of NCSOFT Corporation. All other trademarks are the property of their respective owners.