Getting error code 42 and infinite loading screen — Guild Wars 2 Forums

Getting error code 42 and infinite loading screen

This is strange. Sometimes, i can log on to the game. Then, a message showing error code 42 (cannot connect to game server) appears. And having infinite loading screen while changing maps. Sometimes, I cannot log on to the game because the game said error code 42 (cannot connect to game server). I tried following the ways listed on gw2 support that may be able to solve this problem but they do not work.

P.S. I am a player from Hong Kong

Comments

  • I am having this problem as well. I'm a player from the Philippines. I've tried just about everything from the 'Solving Problems' page and I've yet to make anything work.

  • Have you tried a VPN?

  • @Inculpatus cedo.9234 said:
    Have you tried a VPN?

    Tried using the free VPN ones, did not solve the problem.

  • Can try others, they don't all take the same path.

    Good luck.

  • I used my phone for a usb tether and seemed to work. But it's not really a fix for this kind of problem.

  • I get an infinite loading screen on the new map, everytime no matter what i do, when i try to go to that map i never get past the loading screen, i have to kill the game via the task manager then restart the game, then go back into the map,

    I can replicate this bug everytime i try to zone into the new map from any other map in the game.

©2010–2018 ArenaNet, LLC. All rights reserved. Guild Wars, Guild Wars 2, Heart of Thorns, Guild Wars 2: Path of Fire, ArenaNet, NCSOFT, the Interlocking NC Logo, and all associated logos and designs are trademarks or registered trademarks of NCSOFT Corporation. All other trademarks are the property of their respective owners.