Low FPS on PC — Guild Wars 2 Forums

Low FPS on PC

Hi, i recently got back to GW2 and i realised that i am getting very low fps. I had play other games and i can play at high graphic settings. My gw2 graphic settings are all low but i still get very bad frame rates. I get around 15-25 most of the time and it can go down to single digit fps when i am doing events that has alot of people. Is there a solution for the low fps? Here are the specs for my pc

Processor : AMD Ryzen 5 1600 six-core processor 3.79GHZ
RAM : 8GB
GPU : NVIDIA GTX 1070

Comments

  • Noah.7951Noah.7951 Member ✭✭
    edited January 9, 2019

    Hello,

    Is your game running off your Graphics Card or Processor?
    From the way you described this, it sounds like the game is running completely off your processor.

    If it is, go to Nividia Control panel, program settings, add Gw2, then when set the preferred graphics processor to use your gtx 1070

  • The amd ryzen should not have an cpu gpu processor. They are named Ryzen 3 2200G/ Ryzen 5 2400G respectivly if they wanted to be used as an gpu aswell as cpu. AMD doesn't offer many cpu's with gpu processors.

    First off what resolution are you playing at? If you play @ 3840x2160p with an 1070 yea.. you can get the low fps obviously. Also Multi-Monitor Setup might affect it aswell. We would need more info in that regard. Also what GPU you are using in specific and maybe your Operating System / Is your gpu driver up to date? Is directX up to date?

  • My resolution in gw2 settings is 1920x1080. Currently my OS is windows 10 and its updated. Directx is directx 12. I don't use multi monitor. I am using nvidia geforce gtx 1070.

  • That doesn't add up there shouldnt be such a huge fps drop with those settings. the 1070 goes easily 60 fps / 1440p

    I would call you have a bad driver for your Nvidia gpu. But i was actually refering if you have a custom brand like zotac, msi etc.

    Try to disable reflections and see it again but else / shrug... would call it driver issue

  • Cookiie.8513Cookiie.8513 Member
    edited January 10, 2019

    Is there anyway to fix the driver issue? Because this only occurs in gw2 and not other games. Could it be that i am not ultilising my cpu? When i run the game, i am only using 1.30+ GHz

  • The game only takes as much from the cpu as it needs. Since you are on low settings. Btw how do you check the fps? Ingame menu or fraps? Also why is your cpu at 3.79 ghz per core if the factory turbo boost ends at 3.6,? This is not an interrogation just trying to find the faults. Overclocking if not done properly can cause errors and crashing. (there is no reason to even remotly oc an cpu as the cpu market bArely has evolved over the last 6 years in terms of gaming)

    I had an driver issue on ark another game which even led my entire pc getting rebooted due to a faulty driver. Best thing is to update the driver via Geforce Experience.

  • dandamanno.4136dandamanno.4136 Member ✭✭
    edited January 10, 2019

    @Azurdrache.9671 said:
    The game only takes as much from the cpu as it needs. Since you are on low settings. Btw how do you check the fps? Ingame menu or fraps? Also why is your cpu at 3.79 ghz per core if the factory turbo boost ends at 3.6,? This is not an interrogation just trying to find the faults. Overclocking if not done properly can cause errors and crashing. (there is no reason to even remotly oc an cpu as the cpu market bArely has evolved over the last 6 years in terms of gaming)

    I had an driver issue on ark another game which even led my entire pc getting rebooted due to a faulty driver. Best thing is to update the driver via Geforce Experience.

    If his CPU is not ramping up to full speed upon playing an mmo like GW2 (which like most mmo's is heavily CPU bound) then that is exactly where his problem lies. His CPU should be at his maximum clock speed while running around any map, even if his utilization is less than 100%.

    OP, make sure you go into Windows Power settings and check things like system cooling policy and minimum/maximum CPU frequencies.

    edit: For example I have a i5 4670k (similar single core performance, but much less multi-core performance than yours) at 4.2GHZ, and a 1060. Just sitting in Verdant Brink my CPU is at 50-70% utilization depending on core, and the GPU is almost the same at 60-70%. Both running at maximum frequencies. There is no way your CPU should be sitting at 1.3GHZ while running any modern game, let alone this mmo.

  • Azurdrache.9671Azurdrache.9671 Member ✭✭
    edited January 10, 2019

    That is why i brought up the clockspeeds aswell if you look at those numbers. Have a look about the specs at https://www.tomshardware.com/reviews/amd-ryzen-5-1600-cpu,5073.html or this link 1600 vs 1600x https://www.game-debate.com/cpu/index.php?pid=2463&pid2=2462&compare=ryzen-r5-1600-vs-ryzen-r5-1600x . The corespeed would only be possible on the 1600x. Op mentioned he has an 1600 not x. :thinking: could be bios related.

    Also the op could have opened the resource tool to see his idle cpu just running the OS vs his load cpu during gw2 and just said us the difference. I'll replicate his settings later on my r7 2700x.

    I'd suggest the op to download win 10 64 bit and make a test installation on an drive which he/she/it can format later again without any data loss. Let win 10 update itself fully (no need to register a key .. the 1 month trial is enough) also installing directx/nvidia driver and maybe soubd driver just the bare necessities and then run gw2 again to see if its any software related. No need to format your pc and loose your current data.

    Also to edit: my cpu prio was an i7 4790k which almost permanently ran at 100% but my amd cpu doesn't do that /shrug

  • godofcows.2451godofcows.2451 Member ✭✭
    edited January 10, 2019

    make sure to turn off gamebar and dvr in windows 10. Google some guide on how to turn both off and everything related to them.
    Not unless you need them. Most likely no.

    Max performance from both gpu and processor. I believe AMD has a throttle feature. "Cool and Quiet" or something of the like, if i remember right. Find some guide out there to turn it off to prevent down throttling. Do the same for the gpu. Max performance should be in nvidia's control panel. What you're after is to prevent down throttling from both components. See if you fare better afterwards.

  • Fixed on OP's end (faulty BIOS)

©2010–2018 ArenaNet, LLC. All rights reserved. Guild Wars, Guild Wars 2, Heart of Thorns, Guild Wars 2: Path of Fire, ArenaNet, NCSOFT, the Interlocking NC Logo, and all associated logos and designs are trademarks or registered trademarks of NCSOFT Corporation. All other trademarks are the property of their respective owners.