Item not found in items/ for some item IDs in commerce/prices — Guild Wars 2 Forums

Item not found in items/<itemID> for some item IDs in commerce/prices

Recently I've been working on a coding project with the Guild Wars 2 API. In my program, I retrieved a list of item IDs from https://api.guildwars2.com/v2/commerce/prices, than I tried to retrieve the name for each item in the item ID list with https://api.guildwars2.com/v2/items?ids=,....,. I requested 200 item details at a time. However when I got to item 3800, I tried to get another 200 names but I only got 177, which I found very odd. So I did a test, and I found out that some ids in commerce/prices cannot be found in https://api.guildwars2.com/v2/items. For example, item "Box of Rejuvenating Scale Armor", with an item ID of 8973, is found in the list in https://api.guildwars2.com/v2/commerce/prices. But when I search for it in https://api.guildwars2.com/v2/items, like so: https://api.guildwars2.com/v2/items/8973, it gives an error saying the item id is invalid. I find this quite trivial because how can something being sold in the trading post not exist? Meaning, has the item been deleted from the game? Or is item/ only used to search for a specific category of items (e.g. items and crafting materials, but not boxes)? Or am I missing something else? Help would be highly appreciated 😊.

P.S. English is not my first language, so please tolerate any improper use of terminology or incorrect grammar.

Comments

  • Aikan.5674Aikan.5674 Member
    edited February 1, 2019

    As far as I understand it:
    The API does not show an element (item, achievement...) before that element has been found, crafted, or discovered by someone in-game. That process is called whitelisting; it's meant to avoid people using the API to get too much insight on the game. The whitelists (set of elements that have been whitelisted) have been lost last July, and they had to be reconstructed.
    I guess that the items you found in the TP listings were crafted and listed before that crash. Since no one interacted with them since, they have not been re-whitelisted and are missing from v2/items.

©2010–2018 ArenaNet, LLC. All rights reserved. Guild Wars, Guild Wars 2, Heart of Thorns, Guild Wars 2: Path of Fire, ArenaNet, NCSOFT, the Interlocking NC Logo, and all associated logos and designs are trademarks or registered trademarks of NCSOFT Corporation. All other trademarks are the property of their respective owners.