"unable to connect to the log-in server" — Guild Wars 2 Forums

"unable to connect to the log-in server"

Before I blame my connection, I've already tried both DSL line and 4G mobile connection, both results to the same error on the GW2 launcher: "The game client was unable to connect to the log-in server. Please restart your client and try again."

Also I was getting unusually high ping and disconnection from the last game session for the past 20 minutes, something I have not experienced for a pretty long time. I mean actual 3-second ping displayed in the options menu, not some weird downstream delay coming from your servers. Nothing else is taking up bandwidth on my internet connection, only just a normal 40KB/sec coming from the world boss session.

There must be something happening that's out of my control.

Comments

©2010–2018 ArenaNet, LLC. All rights reserved. Guild Wars, Guild Wars 2, Heart of Thorns, Guild Wars 2: Path of Fire, ArenaNet, NCSOFT, the Interlocking NC Logo, and all associated logos and designs are trademarks or registered trademarks of NCSOFT Corporation. All other trademarks are the property of their respective owners.