LWS4E2 Achivement "X-T3R-M1N-8" icon / timer won't show up — Guild Wars 2 Forums

LWS4E2 Achivement "X-T3R-M1N-8" icon / timer won't show up

I tried this achivement with my guild mates today. I used a character that just unlocked this part of the episode and went in there the first time. At the boss fight the yellow achivement icon showed up and the timer begun, but sadly we were too slow and didn't manage to get the 3-min mark. No big deal, we leave the instance and try again but now the achivement icon absolutely refuses to show up on any of us. And no, the achivement is not completed on my character, it's still unfinished.

I tried:

  • relogging
  • quitting the story and opening the instance with another character (by selecting the part "Help the Olmakhan")

We killed it 4 times yet the timer for the achivement doesn't show up. This is absolutely frustrating since this chapter is extremely long and it feels like forever until you finally reach the endboss fight.

I used the search function in the forums and found that some people already reported that last year. Whatever issue is with this specific part of the episode, it isn't fixed. For me this looks like it bugs out once you fail to do it once with your group.

©2010–2018 ArenaNet, LLC. All rights reserved. Guild Wars, Guild Wars 2, Heart of Thorns, Guild Wars 2: Path of Fire, ArenaNet, NCSOFT, the Interlocking NC Logo, and all associated logos and designs are trademarks or registered trademarks of NCSOFT Corporation. All other trademarks are the property of their respective owners.