SAB Race [PROGRESS IMPOSSIBLE] — Guild Wars 2 Forums

SAB Race [PROGRESS IMPOSSIBLE]

Hey there!

I am unable to complete the race in the SAB. No matter how often I tried. I ran through all the cloud checkpoints till the last, orange point was at the main gate. Went there. Nothing happened.

Race is bugged, plx fix.

Comments

  • Nokomis.5076Nokomis.5076 Member ✭✭✭

    It can't be bugged, if it's working for kinda everyone else. Are you sure, you haven't missed anything? The flying part contains some serious up and down passages. Eventually you flew too high at one of the points or even at the goal.

    Was I able to help you or give you a hint? Click on Helpful and/or Thumbs up, I would appreciate it alot!
    When you encounter a bug ingame, at first you should file a ticket via the ingame command /bug, as only this way the devs will know exactly where you were, when the bug happened.

  • Ashantara.8731Ashantara.8731 Member ✭✭✭✭

    It is certainly not bugged. As with all races, there is a risk of starting prematurely, namely when the counter hits 0:00. You have to wait for the first target to activate before leaving the race's starting area or you will get disqualified - there is an on-screen notification when that happens, plus if you don't see the race markers above the clouds it means they are not enabled for you.

©2010–2018 ArenaNet, LLC. All rights reserved. Guild Wars, Guild Wars 2, Heart of Thorns, Guild Wars 2: Path of Fire, ArenaNet, NCSOFT, the Interlocking NC Logo, and all associated logos and designs are trademarks or registered trademarks of NCSOFT Corporation. All other trademarks are the property of their respective owners.