Scepter #3 bug - Channel but does nothing? — Guild Wars 2 Forums

Scepter #3 bug - Channel but does nothing?

Magolith.9412Magolith.9412 Member ✭✭✭
edited April 1, 2019 in Mesmer

I've been using primarily scepter for almost a year now, and just started noticing this in the past few weeks. Several times, #3 has channeled and did nothing. No evades, no dmg ticks, just channeling and doing nothing. I know for certain that I'm in range when it happens. I'm usually around 400-600. I'd say it's happened to me maybe 5 times in a few weeks. I'll have to capture a vid next time. But, I'm curious if it's happened to anybody else.

YouTube | [WS] Mesmer Mag [Fort Aspenwood]

Comments

  • Dawdler.8521Dawdler.8521 Member ✭✭✭✭
    edited April 1, 2019

    The channel can be extremely sporadic at times. It often fails right after weapon switch for me.

    But hey look at the bright side - at least its not blowtorch which is literally like having a squid tentacle arm when it comes to accuracy and heaven forbid there is a >5 degree slope near you.

    Dont look a gift Asura in the mouth.
    No seriously, dont. Shark teeth.

  • Pyroatheist.9031Pyroatheist.9031 Member ✭✭✭✭

    Sounds like lag to me. The server believes the target is out of range.

    Ohey, I've got a signature

  • Magolith.9412Magolith.9412 Member ✭✭✭

    @Pyroatheist.9031 said:
    Sounds like lag to me. The server believes the target is out of range.

    Likely. My connection isn't the greatest, but I usually play late night around 12-3am to mitigate. Shouldn't have been having issues when it occurred last night. Hard to tell though.

    YouTube | [WS] Mesmer Mag [Fort Aspenwood]

  • whoknocks.4935whoknocks.4935 Member ✭✭✭✭

    When i start casting the skill and I interrupt it, you can see the beam attached to your target, I don't know if the enemy sees it too, that's pretty good if it does.

    This being said, scepter3 is a LoS skill, so it can fail or bug way more time than usual, for example you cast it on a target you have LoS, but the server maybe lags and you don't have LoS for the server and that does nothing, might be the case, maybe if you have a video I understand better what you mean.

  • Magolith.9412Magolith.9412 Member ✭✭✭

    Yea I'll capture a vid next time. Last occurrence was on flat open terrain near SWC on desert BL. It's likely lag or something. Idk.

    YouTube | [WS] Mesmer Mag [Fort Aspenwood]

  • Me Games Ma.8426Me Games Ma.8426 Member ✭✭✭

    My first guess would be that you don't completely face your target. Scepter 3 can be annoying in that manner as it just stops doing its work when you try to hit something that's slithtly beind your character.

  • Magolith.9412Magolith.9412 Member ✭✭✭

    @Me Games Ma.8426 said:
    My first guess would be that you don't completely face your target. Scepter 3 can be annoying in that manner as it just stops doing its work when you try to hit something that's slithtly beind your character.

    Usually when that happens it just goes on a short CD. I'm well aware of when that happens and try to avoid doing it. The issue I'm talking about is the skill fully channels onto the enemy, but does absolutely nothing.

    YouTube | [WS] Mesmer Mag [Fort Aspenwood]

©2010–2018 ArenaNet, LLC. All rights reserved. Guild Wars, Guild Wars 2, Heart of Thorns, Guild Wars 2: Path of Fire, ArenaNet, NCSOFT, the Interlocking NC Logo, and all associated logos and designs are trademarks or registered trademarks of NCSOFT Corporation. All other trademarks are the property of their respective owners.