Client disconnect after completing cinematic in "To Kill A God" — Guild Wars 2 Forums

Client disconnect after completing cinematic in "To Kill A God"

Reported this in-game and haven't gotten a response.

I was disconnected 3/3 times after killing Balthazar in "To Kill A God". Watched the post-fight cinematic, then immediately get the "game client lost its connection to the server" pop up.

Grasping at straws, I hid my outfit, Brand's Wolfblood, and skipped the cinematic and was finally able to progress. Don't know unfortunately if it was skipping or the outfit that changed things, but one of those two appears to have some issues with this encounter.

Comments

  • Can confirm that I have the same issue. I have tried this fight multiple times as well. The game DCs after the cinematics.

    Other problems encountered during this quest:

    • The dragon disappears completely. Only respawns, if you restart from the waypoint.
    • The dragon goes far outside the fire ring. Forcing me to restart the quest.
  • Also, three times disconnect for me, cinematic starts, then I disconnect, the second time it went black, then disconnect, third time I come back from the cutscene, aurene flys off and bam disconnect. Have opened a ticket, I really do not want to start this a fourth time.

  • The disconnects had been happening to me recently and I did get suggestions from Support to make sure my firewall and antivirus was set to exclude GW2 and two other files. Everything was going great, I did a few more PoF story instances with no problem, then I was kicked at the very end of To Kill a God. It stinks to have completed the instance, feeling pretty good at the accomplishment and then losing it all because of some silly glitch. I'm not really up for running it again if the same thing happens. RNGesus is now affecting instances as well, I guess. I did update my support ticket and hopefully there's some "magic fix".

  • I can confirm that I have the same issue. I have reported it in game and in the forums and have yet to see a solution. There area numb er of other threads with similar reports. I disconnect in every Path of Fire story that has a cinematic at the end. I disconnect once the cinematic ends but do not get credit for progress or the reward. I am so frustrated after fighting Balthazar so many times with no credit !

  • I'm having the same issue

  • Same issue.

  • Healix.5819Healix.5819 Member ✭✭✭✭

    If you're getting disconnect in the story at specific points, it's a repeatable problem and you don't normally get disconnected outside of the story, I've heard of 2 causes.

    It can be caused by an interference with your connection. You can attempt to run the game on port 80 or 443 (-clientport 80) as a potential workaround, or use a VPN to fully tunnel the connection.

    It can be caused by your GPU essentially turning off during cinematics or swapping to an integrated GPU if you have one. If you're running Gw2-64.exe, you can try renaming it to Gw2.exe or alternatively configuring Gw2-64.exe to only use your dedicated GPU under your GPU's control panel. You can also try to keep the GPU alive by running something else in the background, such as using GPU-Z to both monitor and run a test. This may be caused by power saving options.

  • Same issue here... DC after the fight completes..
    kitten annoying... Andd I know it registered just fine because I unlocked the achievement: "Won't get killed again".
    I can play this game hours on end without any disconnect issues. It only happens in certain instances and only seems to happen during the last "big chapter" of a story. My internet connection is NOT at fault, I can guarantuee it (Network & Security Engineer by profession, I would know if my connection was bad)
    As such I performed some tests with some packet captures (Wireshark) to "see" whats going on... At the moment you get a DC message, I can see a TCP reset happening.. Might be a bad keep alive mechanism but that's only a guess since I don't manage the Anet environment.. Might also even mean nothing, but it's there...
    A fix for this would be much appreciated..

  • I am also having this issue. Has anyone found a solution to this?

  • Same problem. After cinematic is complete, black screen then disconnect screen. Doesn't happen in any other instances. Fix please.

  • Same issue for me too. Please... I hope this gets fixed soon, there's only so many times I'm willing to kill Balthazar..

  • May 3rd, 2018 and this bug STILL exists. This is core material from your expansion story and months later we're still dealing with a fundamental crash in your code. I'd cry if the rage would ever subside.

  • June 20th, 2018 and I just encountered this same issue --> 2/2 times defeated Balthazar --> disconnect. Although it does feel good to kill a god multiple times, it slowly gets annoying....
    Will try to skip the animation the next time and report back.
    Until then... happy god killing to all of you guys.

  • SlippyCheeze.5483SlippyCheeze.5483 Member ✭✭✭✭

    In another thread, ANet have confirmed that they know this exists, but that they have (as yet) been unable to identify what is causing the problem.

    To test a personal theory, if y'all wouldn't mind mentioning what brand and model of router you have, that'd be interesting.

  • July 1st--this happened to me. Killed Balthazar, black screen, lost client. Now, it gives me a green star where I can start again, but I'm not sure I can reach it. (not where the starting instance is--where Balthazar would be) Should I quit the chapter and start again or...? Hope this gets resolved soon!!

  • still doing it since 2017...

    what? did your chief bug fixer post a bad tweet or something?

  • Bariel.3562Bariel.3562 Member ✭✭

    Sadly despite it being an issue for quite a few people for a prolonged period of time they don't appear to be doing anything about it, nor have they even acknowledged it as a known issue and after a year I question whether they've really ever bothered to take a look at this at all.

  • Inculpatus cedo.9234Inculpatus cedo.9234 Member ✭✭✭✭

    @Bariel.3562 said:
    Sadly despite it being an issue for quite a few people for a prolonged period of time they don't appear to be doing anything about it, nor have they even acknowledged it as a known issue and after a year I question whether they've really ever bothered to take a look at this at all.

    Not true, as evidenced by the Dev posts in the 'official' thread.

  • Bariel.3562Bariel.3562 Member ✭✭

    @Inculpatus cedo.9234 said:

    Not true, as evidenced by the Dev posts in the 'official' thread.

    Which bit isn't true? It's not listed as a bug/known issue on the 'official' tracker - https://help.guildwars2.com/hc/en-us/articles/231272908-Known-Issue-Tracker and whilst a dev posted in a forum thread a month or two back it didn't say much more than they had been unable to reproduce the problem which isn't the same as acknowledgement that it's a known issue with the game. Nor have they seemingly reached out to any user who is able to consistently reproduce the problem to capture the information they need to provide a resolution.

    That's also backed up by the fact I've been going back and forth with support on this and their suggestions haven't inspired me at all that they've really delved too deeply into this. They're certainly not asking me to capture any debugging information, wireshark, tcpdumps, etc that I'd expect a developer to want to need to track down root cause of disconnects for various users.

    I can find threads going back over a year on this, by now it really shouldn't be an issue that all they can say is "we can't reproduce"!!!

  • Still an issue on 08/08/18 . Definitely a way for me to be discouraged seeing the first post date. Three of three times killing him, I disconnect at the Aurine part even when skipping the cut scene. I don't remember the game being so unstable so consistently until this time coming back. :/

  • I was plagued with this problem too. Tried 5 times to complete Victory or Death. Something I read in one of the forums got me thinking and I changed one setting that seems to have helped. I'm not going to guarantee it will work and requires more testing to be confident... but I was able to complete 2 story quests where I'd disconnected repeatedly and my wife also finished one she'd tried 3 times.

    Options > General > Streaming > Content Streaming >> change to "On Demand"

    The setting was set to 'Idle'. Something someone said in a forum post regarding the disconnects seeming to come during transitions from cutscene to non-cutscene made me think that perhaps the game was trying to get some piece of content and since the download setting was set to Idle, it was waiting for the connection to be Idle. After waiting a period of time, it failed out the download which caused it to lose the instance. By setting it to On Demand, it allows the game to download that content when needed. This is totally just a theory, but has been working for me so far. Your mileage may vary. Good luck.

  • It's now Sept. 20, 2018, and it is still doing this same **** glitch!!! I reported it after 2 Balthazar beatdowns and 2 disconnects! Gonna try to do what Valdacil suggests and see if that helps. I really do not want to have to do this more than 3x already! ANET, please fix this problem once and for all!!!

  • I made the change on Content Streaming in my Options as suggested above from "Idle" to "On Demand." Was able to fight Balthazar a 3rd time, and complete the following cinematic without issue. Don't know if this was just by luck, or this change made the difference, but it couldn't hurt to do it anyways rather than fight him over and over again if it does help.

  • I have defeated him 3 times already, and even tried doing what valdacil suggested.... I even was able to hit skip to end button and I STILL GET DISCONNECTED! this is just awful! Its Jan 2019?! how is this still a problem? ....

  • @Valdacil.5367 said:
    Options > General > Streaming > Content Streaming >> change to "On Demand"

    3 fights / 3 disconnect.... i follow your advice andd Bammm!!!! history complete!!
    Thank you Commander!!!!

  • It is now September 2019 and it is still happening . i have had it happen twice in a row on a particular My Story cut scene at the end and just had it happen in another My Story instance. Both in Chapter 8.

©2010–2018 ArenaNet, LLC. All rights reserved. Guild Wars, Guild Wars 2, Heart of Thorns, Guild Wars 2: Path of Fire, ArenaNet, NCSOFT, the Interlocking NC Logo, and all associated logos and designs are trademarks or registered trademarks of NCSOFT Corporation. All other trademarks are the property of their respective owners.