gem exchange tab - blank screen — Guild Wars 2 Forums

gem exchange tab - blank screen

I just traded gold to gems like an hour ago. It worked fine. Suddenly , now I can't . When I click on the tab for the gem exchange I just get a blank screen. No error message , no "working" or "loading" indication. And the gem store tab , and trading post tab work fine. I reloaded my game several times , and deleted my gw2 temp cache. Neither helped. Anyone have an idea ?

Comments

  • crepuscular.9047crepuscular.9047 Member ✭✭✭✭
    edited June 12, 2019

    probably server side lag, happens a lot with that entire trading screen window, gem store, gem exchange, trading post, just blank

    [RIP Fashion Wars 2005-2018]     [TTS] [KA] [SI]     [RIP Fashion Wars 2005-2018]
    Praise the Inevitable Eternal Transcendent King Palawa Ignacious Joko, the Beloved and Feared Undying Eternal Monarch of All !!!
    ... til Aurene ate him for dessert 😭
  • Vio.2740Vio.2740 Member ✭✭

    @crepuscular.9047 said:
    probably server side lag, happens a lot with that entire trading screen window, gem store, gem exchange, trading post, just blank

    No. This has been going on for over a day. It's not just lag. And as I said, the gem store tab and trading post load fine.

  • crepuscular.9047crepuscular.9047 Member ✭✭✭✭
    edited June 12, 2019

    @Vio.2740 said:

    @crepuscular.9047 said:
    probably server side lag, happens a lot with that entire trading screen window, gem store, gem exchange, trading post, just blank

    No. This has been going on for over a day. It's not just lag. And as I said, the gem store tab and trading post load fine.

    no idea then, mine is fine, guildies too, few of them traded in gold and bought the new skyscale mount skin immediately when it came out, gold to gem was 700, now back down to 643g

    [RIP Fashion Wars 2005-2018]     [TTS] [KA] [SI]     [RIP Fashion Wars 2005-2018]
    Praise the Inevitable Eternal Transcendent King Palawa Ignacious Joko, the Beloved and Feared Undying Eternal Monarch of All !!!
    ... til Aurene ate him for dessert 😭
  • Vio.2740Vio.2740 Member ✭✭

    @crepuscular.9047 said:

    @Vio.2740 said:

    @crepuscular.9047 said:
    probably server side lag, happens a lot with that entire trading screen window, gem store, gem exchange, trading post, just blank

    No. This has been going on for over a day. It's not just lag. And as I said, the gem store tab and trading post load fine.

    no idea then, mine is fine, guildies too, few of them traded in gold and bought the new skyscale mount skin immediately when it came out, gold to gem was 700, now back down to 643g

    I'm starting to think I was mistakenly flagged somehow. Since I've re-downloaded the whole game already , and it's been like 2 days already.

  • Healix.5819Healix.5819 Member ✭✭✭✭

    Close the game, open a command prompt (cmd.exe) and enter:
    ipconfig /flushdns

    ... or change DNS providers.

    Open the %temp% folder and delete all folders beginning with gw2cache.

  • Vio.2740Vio.2740 Member ✭✭

    @Healix.5819 said:
    Close the game, open a command prompt (cmd.exe) and enter:
    ipconfig /flushdns

    ... or change DNS providers.

    Open the %temp% folder and delete all folders beginning with gw2cache.

    I did the flushdns. As for changing DNS , I'm not sure if that would help , as I have been playing for a long time with my current isp with no problem , also it said on the link that one should be a "competent user" for the process , and I am not lol. I have already cleared my temp files several times , as well as done a repair and a full re-download of the game. Still not working.

  • Healix.5819Healix.5819 Member ✭✭✭✭
    edited June 12, 2019

    As a temporary alternative to changing your DNS, open notepad as an administrator, then open:
    C:\Windows\System32\drivers\etc\hosts

    At the bottom, create a new line and add the following, then save it:
    13.249.44.19 2exchange.staticwars.com
    52.200.36.142 exchange-live.ncplatform.net
    52.200.36.142 exchange-dfw-live.ncplatform.net

    However, the last one can vary by country, where -dfw- is the default. Use a dns sniffer if you need to find out.

    For future reference:

    The IPs will eventually change, so to look them up yourself, open a command prompt (cmd.exe) and enter:
    nslookup 2exchange.staticwars.com 1.1.1.1
    nslookup exchange-live.ncplatform.net 1.1.1.1

    exchange-live.ncplatform.net and its variations (-dfw-) should all have the same IP

    Exit GW2 if it was open, delete gw2cache again (every time, because it can cache the bad responses), then try it.

    If it still fails, something is probably blocking access to the specified IPs, in which case you can try to open them in your browser, or -dfw- wasn't right for you. Also, sometimes the pages will simply fail to load, so if you've never tried it, switch to the trading post tab, then back to the exchange and wait a few seconds, and do that a few times to ensure it doesn't load at all (and with no error message in black text).

    If it works, note that this isn't a solution, you've confirmed your DNS provider is outdated.

    Lastly, remove those lines from your hosts file.

©2010–2018 ArenaNet, LLC. All rights reserved. Guild Wars, Guild Wars 2, Heart of Thorns, Guild Wars 2: Path of Fire, ArenaNet, NCSOFT, the Interlocking NC Logo, and all associated logos and designs are trademarks or registered trademarks of NCSOFT Corporation. All other trademarks are the property of their respective owners.